summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-23 15:54:36 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-23 15:54:36 +0000
commit0d140f13b964b6cf951e92f270d0c7f6704e2395 (patch)
tree705fc3688e97a227606cde7141abd7f40f15b71f /dev-vcs/subversion
parentAdd ~ppc64, wrt bug #455960 (diff)
downloadgentoo-2-0d140f13b964b6cf951e92f270d0c7f6704e2395.tar.gz
gentoo-2-0d140f13b964b6cf951e92f270d0c7f6704e2395.tar.bz2
gentoo-2-0d140f13b964b6cf951e92f270d0c7f6704e2395.zip
Keep Python sources symlinked during builds. Required for Ruby bindings, for some reason. Bug #458764.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-vcs/subversion')
-rw-r--r--dev-vcs/subversion/ChangeLog6
-rw-r--r--dev-vcs/subversion/subversion-1.7.8.ebuild10
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 2b80236fd710..42f8473cc66c 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.98 2013/02/22 17:44:33 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.99 2013/02/23 15:54:36 mgorny Exp $
+
+ 23 Feb 2013; Michał Górny <mgorny@gentoo.org> subversion-1.7.8.ebuild:
+ Keep Python sources symlinked during builds. Required for Ruby bindings, for
+ some reason. Bug #458764.
22 Feb 2013; Zac Medico <zmedico@gentoo.org> subversion-1.7.7.ebuild,
subversion-1.7.8.ebuild:
diff --git a/dev-vcs/subversion/subversion-1.7.8.ebuild b/dev-vcs/subversion/subversion-1.7.8.ebuild
index b72f011f7be1..8a46d66975c4 100644
--- a/dev-vcs/subversion/subversion-1.7.8.ebuild
+++ b/dev-vcs/subversion/subversion-1.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.8.ebuild,v 1.2 2013/02/22 17:44:33 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.8.ebuild,v 1.3 2013/02/23 15:54:36 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -229,14 +229,13 @@ src_compile() {
if use python; then
swig_py_compile() {
local p=subversion/bindings/swig/python
- ln -fs "${BUILD_DIR}" ${p} || die
+ rm -f ${p} || die
+ ln -s "${BUILD_DIR}" ${p} || die
python_export PYTHON_INCLUDEDIR
emake swig-py \
swig_pydir="$(python_get_sitedir)/libsvn" \
swig_pydir_extra="$(python_get_sitedir)/svn"
-
- rm ${p} || die
}
# this will give us proper BUILD_DIR for symlinking
@@ -305,6 +304,7 @@ src_install() {
if use python; then
swig_py_install() {
local p=subversion/bindings/swig/python
+ rm -f ${p} || die
ln -s "${BUILD_DIR}" ${p} || die
emake \
@@ -312,8 +312,6 @@ src_install() {
swig_pydir="$(python_get_sitedir)/libsvn" \
swig_pydir_extra="$(python_get_sitedir)/svn" \
install-swig-py
-
- rm ${p} || die
}
BUILD_DIR=python \