summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-02-09 20:25:06 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-02-09 20:25:06 +0000
commit15841560a0c957f822da1a7517a46ae4faae3906 (patch)
tree6a35ed7853ca565d2a09ac76b4e197010ea7d045 /dev-vcs/mercurial
parentVersion bump, wrt bug #302591 (diff)
downloadgentoo-2-15841560a0c957f822da1a7517a46ae4faae3906.tar.gz
gentoo-2-15841560a0c957f822da1a7517a46ae4faae3906.tar.bz2
gentoo-2-15841560a0c957f822da1a7517a46ae4faae3906.zip
Version bump mercurial to 2.5.1.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-vcs/mercurial')
-rw-r--r--dev-vcs/mercurial/ChangeLog7
-rw-r--r--dev-vcs/mercurial/mercurial-2.5.1.ebuild142
2 files changed, 148 insertions, 1 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 80593167caf8..deabdb8997bd 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.111 2013/02/08 14:37:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.112 2013/02/09 20:25:06 djc Exp $
+
+*mercurial-2.5.1 (09 Feb 2013)
+
+ 09 Feb 2013; Dirkjan Ochtman <djc@gentoo.org> +mercurial-2.5.1.ebuild:
+ Version bump mercurial to 2.5.1.
08 Feb 2013; Jeroen Roovers <jer@gentoo.org> mercurial-2.4.2.ebuild:
Stable for HPPA (bug #442788).
diff --git a/dev-vcs/mercurial/mercurial-2.5.1.ebuild b/dev-vcs/mercurial/mercurial-2.5.1.ebuild
new file mode 100644
index 000000000000..01f5f1eeea03
--- /dev/null
+++ b/dev-vcs/mercurial/mercurial-2.5.1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.5.1.ebuild,v 1.1 2013/02/09 20:25:06 djc Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="threads"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit bash-completion-r1 elisp-common eutils distutils
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
+
+RDEPEND="bugzilla? ( dev-python/mysql-python )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ zsh-completion? ( app-shells/zsh )
+ app-misc/ca-certificates"
+DEPEND="emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments )"
+
+PYTHON_CFLAGS=(
+ "2.* + -fno-strict-aliasing"
+ "* - -ftracer -ftree-vectorize"
+)
+
+PYTHON_MODNAME="${PN} hgext"
+SITEFILE="70${PN}-gentoo.el"
+
+src_prepare() {
+ distutils_src_prepare
+ # fix up logic that won't work in Gentoo Prefix (also won't outside in
+ # certain cases), bug #362891
+ sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ cd "${S}"/contrib || die
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+ rm -rf contrib/{win32,macosx} || die
+}
+
+src_install() {
+ distutils_src_install
+ python_convert_shebangs 2 contrib/hg-ssh
+
+ newbashcomp contrib/bash_completion ${PN} || die
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg || die
+ fi
+
+ rm -f doc/*.?.txt || die
+ dodoc CONTRIBUTORS README doc/*.txt || die
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
+
+ dobin hgeditor || die
+ dobin contrib/hgk || die
+ dobin contrib/hg-ssh || die
+
+ rm -f contrib/hgk contrib/hg-ssh || die
+
+ rm -f contrib/bash_completion || die
+ cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
+ doman doc/*.? || die
+
+ cat > "${T}/80mercurial" <<-EOF
+HG="${EPREFIX}/usr/bin/hg"
+EOF
+ doenvd "${T}/80mercurial" || die
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ insinto /etc/mercurial/hgrc.d
+ doins "${FILESDIR}/cacerts.rc"
+}
+
+src_test() {
+ cd "${S}/tests/" || die
+ rm -rf *svn* || die # Subversion tests fail with 1.5
+ rm -f test-archive* || die # Fails due to verbose tar output changes
+ rm -f test-convert-baz* || die # GNU Arch baz
+ rm -f test-convert-cvs* || die # CVS
+ rm -f test-convert-darcs* || die # Darcs
+ rm -f test-convert-git* || die # git
+ rm -f test-convert-mtn* || die # monotone
+ rm -f test-convert-tla* || die # GNU Arch tla
+ rm -f test-doctest* || die # doctest always fails with python 2.5.x
+ rm -f test-largefiles* || die # tends to time out
+ if [[ ${EUID} -eq 0 ]]; then
+ einfo "Removing tests which require user privileges to succeed"
+ rm -f test-command-template* || die # Test is broken when run as root
+ rm -f test-convert* || die # Test is broken when run as root
+ rm -f test-lock-badness* || die # Test is broken when run as root
+ rm -f test-permissions* || die # Test is broken when run as root
+ rm -f test-pull-permission* || die # Test is broken when run as root
+ rm -f test-clone-failure* || die
+ rm -f test-journal-exists* || die
+ rm -f test-repair-strip* || die
+ fi
+
+ testing() {
+ local testdir="${T}/tests-${PYTHON_ABI}"
+ rm -rf "${testdir}" || die
+ "$(PYTHON)" run-tests.py --tmpdir="${testdir}"
+ }
+ python_execute_function testing
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-vcs/cvs"
+ elog " dev-vcs/darcs"
+ elog " dev-vcs/git"
+ elog " dev-vcs/monotone"
+ elog " dev-vcs/subversion"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}