summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-17 10:14:45 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-17 10:14:45 +0000
commite44f71ae25e4b9d8ca1d34d2ba186d7c2d8b674f (patch)
tree5e3c225dccaee84ff12e5843131eb6baf920d869 /dev-vcs/hgsubversion
parentcorrection to dep in 0.9.24-r1 (diff)
downloadgentoo-2-e44f71ae25e4b9d8ca1d34d2ba186d7c2d8b674f.tar.gz
gentoo-2-e44f71ae25e4b9d8ca1d34d2ba186d7c2d8b674f.tar.bz2
gentoo-2-e44f71ae25e4b9d8ca1d34d2ba186d7c2d8b674f.zip
bump, fixes Bug #465190
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-vcs/hgsubversion')
-rw-r--r--dev-vcs/hgsubversion/ChangeLog11
-rw-r--r--dev-vcs/hgsubversion/files/invalid_utf8.tar.gzbin0 -> 8227 bytes
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.5.ebuild39
3 files changed, 47 insertions, 3 deletions
diff --git a/dev-vcs/hgsubversion/ChangeLog b/dev-vcs/hgsubversion/ChangeLog
index 58a52381e49b..6bfc74f4d38e 100644
--- a/dev-vcs/hgsubversion/ChangeLog
+++ b/dev-vcs/hgsubversion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/hgsubversion
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.28 2012/06/21 07:03:55 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.29 2013/06/17 10:14:45 idella4 Exp $
+
+*hgsubversion-1.5 (17 Jun 2013)
+
+ 17 Jun 2013; Ian Delaney <idella4@gentoo.org> +files/invalid_utf8.tar.gz,
+ +hgsubversion-1.5.ebuild:
+ bump, fixes Bug #465190
21 Jun 2012; Jeff Horelick <jdhore@gentoo.org> hgsubversion-1.4.ebuild:
marked x86 per bug 422079
@@ -118,4 +124,3 @@
07 Feb 2010; Dirkjan Ochtman <djc@gentoo.org> +hgsubversion-1.0.ebuild,
+metadata.xml:
Add initial version of hgsubversion.
-
diff --git a/dev-vcs/hgsubversion/files/invalid_utf8.tar.gz b/dev-vcs/hgsubversion/files/invalid_utf8.tar.gz
new file mode 100644
index 000000000000..537021f18693
--- /dev/null
+++ b/dev-vcs/hgsubversion/files/invalid_utf8.tar.gz
Binary files differ
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.5.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.5.ebuild
new file mode 100644
index 000000000000..dabe56b76a65
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/hgsubversion-1.5.ebuild,v 1.1 2013/06/17 10:14:45 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories."
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home http://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ || (
+ dev-python/subvertpy[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python]
+ )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+python_prepare_all() {
+ # https://bitbucket.org/durin42/hgsubversion/issue/390/latest-release-missing-invalid_utf8targz
+ # Still no response, faile imported to files to fix tests
+ cp -r "${FILESDIR}"/invalid_utf8.tar.gz tests/fixtures/ || die "deded"
+}
+
+python_test() {
+ "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+}