summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-02-02 10:16:50 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-02-02 10:16:50 +0000
commit3d6844b22c0504a27bcfcf1b3779a7c986e91776 (patch)
tree0ef5a259ee7df0e097375105bafadeb9af46e4d6 /dev-vcs/hgsubversion
parentsci-libs/plplot: Backport fix for cmake-3.10, #537670 (diff)
downloadgentoo-2-3d6844b22c0504a27bcfcf1b3779a7c986e91776.tar.gz
gentoo-2-3d6844b22c0504a27bcfcf1b3779a7c986e91776.tar.bz2
gentoo-2-3d6844b22c0504a27bcfcf1b3779a7c986e91776.zip
Version bump hgsubversion to 1.8
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-vcs/hgsubversion')
-rw-r--r--dev-vcs/hgsubversion/ChangeLog9
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.8.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-vcs/hgsubversion/ChangeLog b/dev-vcs/hgsubversion/ChangeLog
index ae18a5458d23..a20a3576882f 100644
--- a/dev-vcs/hgsubversion/ChangeLog
+++ b/dev-vcs/hgsubversion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/hgsubversion
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.36 2014/11/16 14:37:33 djc Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/ChangeLog,v 1.37 2015/02/02 10:16:50 djc Exp $
+
+*hgsubversion-1.8 (02 Feb 2015)
+
+ 02 Feb 2015; Dirkjan Ochtman <djc@gentoo.org> +hgsubversion-1.8.ebuild:
+ Version bump hgsubversion to 1.8
*hgsubversion-1.7 (16 Nov 2014)
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.8.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.8.ebuild
new file mode 100644
index 000000000000..73026de2b845
--- /dev/null
+++ b/dev-vcs/hgsubversion/hgsubversion-1.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hgsubversion/hgsubversion-1.8.ebuild,v 1.1 2015/02/02 10:16:50 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="hgsubversion is a Mercurial extension for working with Subversion repositories"
+HOMEPAGE="https://bitbucket.org/durin42/hgsubversion/wiki/Home http://pypi.python.org/pypi/hgsubversion"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+
+# although any ref absent in the source, tests fail badly with >=mercurial-2.8.1
+RDEPEND=">=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
+ dev-vcs/mercurial[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/subvertpy-0.7.4[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.5[python] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( README )
+
+#python_test() {
+# "${PYTHON}" tests/run.py || die "Tests failed under ${EPYTHON}"
+#}