summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-07-21 03:36:59 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-07-21 03:36:59 +0000
commit9c06515f0fae4741ab410884cacc14d4e24d1e52 (patch)
tree6364554502e6f31c5e1567b6b99e9ba8279bd56c /dev-vcs/gitosis-gentoo
parentAdded a patch to make the input box a bit smaller. (diff)
downloadgentoo-2-9c06515f0fae4741ab410884cacc14d4e24d1e52.tar.gz
gentoo-2-9c06515f0fae4741ab410884cacc14d4e24d1e52.tar.bz2
gentoo-2-9c06515f0fae4741ab410884cacc14d4e24d1e52.zip
Version bump
It includes commit a88bc14fe0b5507ea54c5d5fe695e828beefd7ca which exports GITOSIS_NAME and GITOSIS_EMAIL env vars (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/gitosis-gentoo')
-rw-r--r--dev-vcs/gitosis-gentoo/ChangeLog10
-rw-r--r--dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100718.ebuild50
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-vcs/gitosis-gentoo/ChangeLog b/dev-vcs/gitosis-gentoo/ChangeLog
index 24a5ba6d220a..8d75adca50f6 100644
--- a/dev-vcs/gitosis-gentoo/ChangeLog
+++ b/dev-vcs/gitosis-gentoo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-vcs/gitosis-gentoo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/ChangeLog,v 1.1 2010/06/19 16:19:58 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/ChangeLog,v 1.2 2010/07/21 03:36:59 tampakrap Exp $
+
+*gitosis-gentoo-0.2_p20100718 (21 Jul 2010)
+
+ 21 Jul 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +gitosis-gentoo-0.2_p20100718.ebuild:
+ Version bump
+ It includes commit a88bc14fe0b5507ea54c5d5fe695e828beefd7ca which exports
+ GITOSIS_NAME and GITOSIS_EMAIL env vars
19 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gitosis-gentoo-0.2_p20080203.ebuild, gitosis-gentoo-0.2_p20080711.ebuild,
diff --git a/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100718.ebuild b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100718.ebuild
new file mode 100644
index 000000000000..00d4bc445bfc
--- /dev/null
+++ b/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100718.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitosis-gentoo/gitosis-gentoo-0.2_p20100718.ebuild,v 1.1 2010/07/21 03:36:59 tampakrap Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_PV="20100718-a88bc14fe0b5507ea54c5d5fe695e828beefd7ca"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+DEPEND_GIT=">=dev-vcs/git-1.5.6.4"
+DEPEND="${DEPEND_GIT}
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-vcs/gitosis"
+
+S="${WORKDIR}/${PN}"
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_compile() {
+ pwd
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}
+
+pkg_postinst() {
+ einfo "If you need to actually use gitosis, you must unlock the git user."
+}