summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-14 04:57:27 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-14 04:57:27 +0000
commit9068de85b77a858440623dda083f9fa0aeb91984 (patch)
treec1b687213105538c2fe629dcd8875615c5d274b6 /dev-vcs/git
parentalso re-enable iconv support in new 1.7.10 versions (diff)
downloadgentoo-2-9068de85b77a858440623dda083f9fa0aeb91984.tar.gz
gentoo-2-9068de85b77a858440623dda083f9fa0aeb91984.tar.bz2
gentoo-2-9068de85b77a858440623dda083f9fa0aeb91984.zip
also add new USE=nls support to git-1.7.10 ebuilds
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog5
-rw-r--r--dev-vcs/git/git-1.7.10.2.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.10.ebuild6
3 files changed, 11 insertions, 6 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index 67a519660900..b6ca16b3efd3 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,10 +1,11 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.134 2012/06/14 04:55:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.135 2012/06/14 04:57:27 vapier Exp $
14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.9.1.ebuild,
git-1.7.9.2.ebuild, git-1.7.9.3.ebuild, git-1.7.9.4.ebuild,
- git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-9999.ebuild:
+ git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-1.7.10.ebuild,
+ git-1.7.10.2.ebuild, git-9999.ebuild:
Add USE=nls support to control gettext requirement.
14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.8.1.ebuild,
diff --git a/dev-vcs/git/git-1.7.10.2.ebuild b/dev-vcs/git/git-1.7.10.2.ebuild
index 1a152d984981..083b31e7b475 100644
--- a/dev-vcs/git/git-1.7.10.2.ebuild
+++ b/dev-vcs/git/git-1.7.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.2 2012/06/14 04:55:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.3 2012/06/14 04:57:27 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -145,6 +145,8 @@ exportmakeopts() {
use iconv \
|| myopts="${myopts} NO_ICONV=YesPlease"
+ use nls \
+ || myopts="${myopts} NO_GETTEXT=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \
diff --git a/dev-vcs/git/git-1.7.10.ebuild b/dev-vcs/git/git-1.7.10.ebuild
index 12e81a219a68..138fbf74bbe5 100644
--- a/dev-vcs/git/git-1.7.10.ebuild
+++ b/dev-vcs/git/git-1.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.3 2012/06/14 04:55:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.4 2012/06/14 04:57:27 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -145,6 +145,8 @@ exportmakeopts() {
use iconv \
|| myopts="${myopts} NO_ICONV=YesPlease"
+ use nls \
+ || myopts="${myopts} NO_GETTEXT=YesPlease"
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use pcre \