summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-10 07:41:36 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-10 07:41:36 +0000
commit359aeb44b5c755906e9c05ca0bd03c08ee4e6fea (patch)
tree3cf8f2d5c4317d9f500eb35f039797f863ee875c /dev-vcs/git-cola
parentremove myself from metadata (diff)
downloadgentoo-2-359aeb44b5c755906e9c05ca0bd03c08ee4e6fea.tar.gz
gentoo-2-359aeb44b5c755906e9c05ca0bd03c08ee4e6fea.tar.bz2
gentoo-2-359aeb44b5c755906e9c05ca0bd03c08ee4e6fea.zip
dev-vcs/git-cola: Version Bump
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog8
-rw-r--r--dev-vcs/git-cola/files/1.8.1-system-ssh-askpass.patch35
-rw-r--r--dev-vcs/git-cola/git-cola-1.8.1.ebuild96
3 files changed, 138 insertions, 1 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index b126ec1d1ec8..c77a691e4ce9 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.5 2012/11/12 19:13:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.6 2012/12/10 07:41:36 jlec Exp $
+
+*git-cola-1.8.1 (10 Dec 2012)
+
+ 10 Dec 2012; Justin Lecher <jlec@gentoo.org>
+ +files/1.8.1-system-ssh-askpass.patch, +git-cola-1.8.1.ebuild:
+ Version Bump
12 Nov 2012; Justin Lecher <jlec@gentoo.org> git-cola-1.8.0.ebuild:
Fix doc installation, #442892
diff --git a/dev-vcs/git-cola/files/1.8.1-system-ssh-askpass.patch b/dev-vcs/git-cola/files/1.8.1-system-ssh-askpass.patch
new file mode 100644
index 000000000000..8b9923245742
--- /dev/null
+++ b/dev-vcs/git-cola/files/1.8.1-system-ssh-askpass.patch
@@ -0,0 +1,35 @@
+ cola/app.py | 4 ++--
+ setup.py | 4 ----
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/cola/app.py b/cola/app.py
+index bc7906a..972eaa7 100644
+--- a/cola/app.py
++++ b/cola/app.py
+@@ -65,9 +65,9 @@ def setup_environment():
+ elif ssh_askpass:
+ askpass = ssh_askpass
+ elif sys.platform == 'darwin':
+- askpass = resources.share('bin', 'ssh-askpass-darwin')
++ askpass = resources.prefix('bin', 'ssh-askpass-darwin')
+ else:
+- askpass = resources.share('bin', 'ssh-askpass')
++ askpass = resources.prefix('bin', 'ssh-askpass')
+
+ compat.putenv('GIT_ASKPASS', askpass)
+ compat.putenv('SSH_ASKPASS', askpass)
+diff --git a/setup.py b/setup.py
+index e202edc..81765a1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -101,10 +101,6 @@ def cola_data_files():
+ data.extend([_app_path(localedir, 'git-cola.mo')
+ for localedir in glob('share/locale/*/LC_MESSAGES')])
+
+- if sys.platform == 'darwin':
+- data.append(_app_path('share/git-cola/bin', 'ssh-askpass-darwin'))
+- else:
+- data.append(_app_path('share/git-cola/bin', 'ssh-askpass'))
+ return data
+
+
diff --git a/dev-vcs/git-cola/git-cola-1.8.1.ebuild b/dev-vcs/git-cola/git-cola-1.8.1.ebuild
new file mode 100644
index 000000000000..5e92c709fae0
--- /dev/null
+++ b/dev-vcs/git-cola/git-cola-1.8.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.8.1.ebuild,v 1.1 2012/12/10 07:41:36 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="The highly caffeinated git GUI"
+HOMEPAGE="http://git-cola.github.com/"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/jsonpickle
+ dev-python/pyinotify
+ dev-python/PyQt4
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ dev-python/sphinx
+ app-text/xmlto )
+ sys-devel/gettext
+ test? ( dev-python/nose )"
+
+# tests currently broken due to unfinished translation framework
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # don't install docs into wrong location
+ sed -i \
+ -e '/doc/d' \
+ setup.py || die "sed failed"
+
+ sed -i \
+ -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
+ cola/resources.py || die "sed failed"
+
+ epatch \
+ "${FILESDIR}"/1.3.8-disable-tests.patch \
+ "${FILESDIR}"/1.8.1-system-ssh-askpass.patch
+
+ python_convert_shebangs 2 bin/git-cola bin/git-dag
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd share/doc/git-cola/
+ emake all
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ dodoc share/doc/git-cola/*.txt
+
+ if use doc ; then
+ dohtml -r share/doc/git-cola/_build/html/*
+ doman share/doc/git-cola/*.1
+ else
+ dohtml "${FILESDIR}/index.html"
+ fi
+}
+
+src_test() {
+ PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
+ --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
+ || die "running nosetests failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/git-cola/lib/cola
+
+ elog "Please make sure you have either a SSH key management installed and activated or"
+ elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
+ elog "Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH. "
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/git-cola/lib/cola
+}