summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-01-23 11:59:08 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-01-23 11:59:08 +0000
commitd928548e6d96142afbb9b93f860429517c319777 (patch)
tree2b9ab1a2b31d6195a6601fb64cfb6ce5630aea28 /dev-vcs/cvsps
parentremove old (diff)
downloadgentoo-2-d928548e6d96142afbb9b93f860429517c319777.tar.gz
gentoo-2-d928548e6d96142afbb9b93f860429517c319777.tar.bz2
gentoo-2-d928548e6d96142afbb9b93f860429517c319777.zip
Version bump. Now with incremental import!
(Portage version: 2.2.0_alpha153_p8/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-vcs/cvsps')
-rw-r--r--dev-vcs/cvsps/ChangeLog7
-rw-r--r--dev-vcs/cvsps/cvsps-3.10.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-vcs/cvsps/ChangeLog b/dev-vcs/cvsps/ChangeLog
index da2a672bfde2..d80793558e4b 100644
--- a/dev-vcs/cvsps/ChangeLog
+++ b/dev-vcs/cvsps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/cvsps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.17 2013/01/09 18:13:41 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/ChangeLog,v 1.18 2013/01/23 11:59:08 slyfox Exp $
+
+*cvsps-3.10 (23 Jan 2013)
+
+ 23 Jan 2013; Sergei Trofimovich <slyfox@gentoo.org> +cvsps-3.10.ebuild:
+ Version bump. Now with incremental import!
*cvsps-3.7 (09 Jan 2013)
diff --git a/dev-vcs/cvsps/cvsps-3.10.ebuild b/dev-vcs/cvsps/cvsps-3.10.ebuild
new file mode 100644
index 000000000000..fddbcfd8fe51
--- /dev/null
+++ b/dev-vcs/cvsps/cvsps-3.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsps/cvsps-3.10.ebuild,v 1.1 2013/01/23 11:59:08 slyfox Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates patchset information from a CVS repository"
+HOMEPAGE="http://www.catb.org/~esr/cvsps/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+src_prepare() {
+ tc-export CC
+ export prefix=/usr
+}
+
+src_install() {
+ default
+ dodoc README
+}