summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 21:25:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 21:25:47 +0000
commit8fb2eeb671579f4d7f331b799d6f2170d6fd3b41 (patch)
treec5aec8d3b4cc9a85a29478d4e4dedae3f76c8d34 /dev-vcs/cvs2svn
parentStable on amd64 wrt bug #327725 (diff)
downloadgentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.tar.gz
gentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.tar.bz2
gentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.zip
Set SUPPORT_PYTHON_ABIS (bug #329477).
(Portage version: 2.2.0_alpha28_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/cvs2svn')
-rw-r--r--dev-vcs/cvs2svn/ChangeLog10
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild26
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild26
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild26
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild26
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild26
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild20
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild26
8 files changed, 148 insertions, 38 deletions
diff --git a/dev-vcs/cvs2svn/ChangeLog b/dev-vcs/cvs2svn/ChangeLog
index 21c8ab98a5aa..6346629dd750 100644
--- a/dev-vcs/cvs2svn/ChangeLog
+++ b/dev-vcs/cvs2svn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/cvs2svn
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/ChangeLog,v 1.3 2010/06/22 18:43:50 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/ChangeLog,v 1.4 2011/03/25 21:25:47 arfrever Exp $
+
+ 25 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ cvs2svn-1.5.0.ebuild, cvs2svn-1.5.1.ebuild, cvs2svn-2.0.1.ebuild,
+ cvs2svn-2.1.0.ebuild, cvs2svn-2.1.1.ebuild, cvs2svn-2.2.0.ebuild,
+ cvs2svn-2.3.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #329477).
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
cvs2svn-1.5.0.ebuild, cvs2svn-1.5.1.ebuild, cvs2svn-2.0.1.ebuild,
diff --git a/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild
index c93077988815..db38ac217dde 100644
--- a/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild,v 1.2 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-1.5.0.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ~ppc x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -28,6 +39,7 @@ src_install() {
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " ${ROOT}usr/share/${PN}/"
}
@@ -35,5 +47,9 @@ pkg_postinst() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild b/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild
index 254ec38845bf..e1d7f2e7aba0 100644
--- a/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild,v 1.2 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-1.5.1.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -28,6 +39,7 @@ src_install() {
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " ${ROOT}usr/share/${PN}/"
}
@@ -35,5 +47,9 @@ pkg_postinst() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild
index 3fe8e946dfb6..aa3f244eb42f 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild,v 1.2 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.0.1.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -28,6 +39,7 @@ src_install() {
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " ${ROOT}usr/share/${PN}/"
}
@@ -35,5 +47,9 @@ pkg_postinst() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild
index 375e4715b833..b9c498fa38d8 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild,v 1.2 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.0.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -30,10 +41,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
index 7ce77b2ec142..9bdce604e05f 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.2 2010/06/22 18:43:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.3 2011/03/25 21:25:47 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -15,11 +20,17 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc x86"
IUSE=""
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
distutils_src_install
insinto "/usr/share/${PN}"
@@ -30,10 +41,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
index 733cb813894b..b8a43204c7c0 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild,v 1.3 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild,v 1.4 2011/03/25 21:25:47 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
PYTHON_USE_WITH_OR="berkdb gdbm"
PYTHON_USE_WITH_OPT="test"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit eutils distutils
@@ -19,16 +22,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
bazaar? ( >=dev-vcs/bzr-1.13 )
git? ( >=dev-vcs/git-1.5.4.4 )
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
src_prepare() {
epatch "${FILESDIR}/2.2.0-deprecated-modules.patch"
distutils_src_prepare
+ python_convert_shebangs -r 2 .
}
src_install() {
@@ -41,10 +46,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python -W ignore run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" -W ignore run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
index 2da1b1eaa806..58d77fd6b3ef 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild,v 1.3 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild,v 1.4 2011/03/25 21:25:47 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
PYTHON_USE_WITH_OR="berkdb gdbm"
PYTHON_USE_WITH_OPT="test"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils distutils
+inherit distutils
FILEVER="46528"
@@ -19,13 +22,19 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
bazaar? ( >=dev-vcs/bzr-1.13 )
git? ( >=dev-vcs/git-1.5.4.4 )
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
+src_prepare() {
+ distutils_src_prepare
+ python_convert_shebangs -r 2 .
+}
+
src_compile() {
distutils_src_compile
emake man
@@ -41,10 +50,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python -W ignore run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" -W ignore run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}