summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-03-26 20:24:46 +0000
committerSebastian Pipping <sping@gentoo.org>2010-03-26 20:24:46 +0000
commit0d0ed06576e3da57b8fa6d6db35287b970b608d1 (patch)
tree42aeb3a4e594060b86b4c82275e17fd28da5fde5 /dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
parentDrop mask for gcc-config-1.5. It seems to work after some fixes, but it's st... (diff)
downloadgentoo-2-0d0ed06576e3da57b8fa6d6db35287b970b608d1.tar.gz
gentoo-2-0d0ed06576e3da57b8fa6d6db35287b970b608d1.tar.bz2
gentoo-2-0d0ed06576e3da57b8fa6d6db35287b970b608d1.zip
dev-vcs/cvs2svn: New package (copied from dev-util/cvs2svn)
(Portage version: 2.2_rc67_p26/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
new file mode 100644
index 000000000000..60963ef5c4c0
--- /dev/null
+++ b/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.3.0.ebuild,v 1.1 2010/03/26 20:24:46 sping Exp $
+
+EAPI="2"
+PYTHON_USE_WITH_OR="berkdb gdbm"
+PYTHON_USE_WITH_OPT="test"
+
+inherit eutils distutils
+
+FILEVER="46528"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+DEPEND="dev-lang/python
+ >=dev-util/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ dev-vcs/rcs"
+
+src_compile() {
+ distutils_src_compile
+ emake man
+}
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2{svn,git,bzr}-example.options
+ doman *.1
+}
+
+src_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ python -W ignore run-tests.py || die "tests failed"
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}