summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2011-06-12 12:45:57 +0000
committerMichael Januszewski <spock@gentoo.org>2011-06-12 12:45:57 +0000
commitfcc3090de79e9762ae2e203fa19f0554deee4b88 (patch)
treecc45088aa13245acba8716fc11c3cd3a74a75d0b /dev-util
parentInitial version. New package: library for deep evaluation of data structures. (diff)
downloadgentoo-2-fcc3090de79e9762ae2e203fa19f0554deee4b88.tar.gz
gentoo-2-fcc3090de79e9762ae2e203fa19f0554deee4b88.tar.bz2
gentoo-2-fcc3090de79e9762ae2e203fa19f0554deee4b88.zip
Add upstream build fix for GCC 4.6 (bug #363259).
(Portage version: 2.1.10.2/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog6
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.6-mutable.patch19
-rw-r--r--dev-util/oprofile/oprofile-0.9.6.ebuild8
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 883852184ebe..710fafdb50f0 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.66 2011/05/22 16:41:59 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.67 2011/06/12 12:45:57 spock Exp $
+
+ 12 Jun 2011; Michał Januszewski <spock@gentoo.org> oprofile-0.9.6.ebuild,
+ +files/oprofile-0.9.6-mutable.patch:
+ Add upstream build fix for GCC 4.6 (bug #363259).
22 May 2011; Matt Turner <mattst88@gentoo.org> oprofile-0.9.6.ebuild:
Add ~alpha keyword
diff --git a/dev-util/oprofile/files/oprofile-0.9.6-mutable.patch b/dev-util/oprofile/files/oprofile-0.9.6-mutable.patch
new file mode 100644
index 000000000000..5b06fbdadef0
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-0.9.6-mutable.patch
@@ -0,0 +1,19 @@
+commit b18f60db60487ada38d5f04f52981628b28c6835
+Author: William Cohen <wcohen@redhat.com>
+Date: Wed Feb 9 15:27:47 2011 -0500
+
+ Do not use mutable for reference variable.
+
+diff --git a/libpp/format_output.h b/libpp/format_output.h
+index b6c4592..8e527d5 100644
+--- a/libpp/format_output.h
++++ b/libpp/format_output.h
+@@ -91,7 +91,7 @@ protected:
+ symbol_entry const & symbol;
+ sample_entry const & sample;
+ size_t pclass;
+- mutable counts_t & counts;
++ counts_t & counts;
+ extra_images const & extra;
+ double diff;
+ };
diff --git a/dev-util/oprofile/oprofile-0.9.6.ebuild b/dev-util/oprofile/oprofile-0.9.6.ebuild
index a77e01b3c9d9..5f1dbabed86b 100644
--- a/dev-util/oprofile/oprofile-0.9.6.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.6.ebuild,v 1.7 2011/05/22 16:41:59 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.6.ebuild,v 1.8 2011/06/12 12:45:57 spock Exp $
EAPI=1
inherit linux-info
@@ -26,6 +26,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/oprofile-0.9.6-mutable.patch
+}
+
src_compile() {
local myconf="--with-qt-dir=/void --with-x"