summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-23 17:42:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-23 17:42:00 +0000
commitfc241f7c0a0e05794057b2ac1cbb96ee440afb55 (patch)
tree0c3b6d5147c46d92c6255134d4b960170d4ec129 /dev-util
parentRestrict test (bug #310847). (diff)
downloadgentoo-2-fc241f7c0a0e05794057b2ac1cbb96ee440afb55.tar.gz
gentoo-2-fc241f7c0a0e05794057b2ac1cbb96ee440afb55.tar.bz2
gentoo-2-fc241f7c0a0e05794057b2ac1cbb96ee440afb55.zip
Initial commit by Alex Barker and me.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/skipfish/ChangeLog10
-rw-r--r--dev-util/skipfish/metadata.xml9
-rw-r--r--dev-util/skipfish/skipfish-1.13_beta.ebuild54
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
new file mode 100644
index 000000000000..b18b43dc82cb
--- /dev/null
+++ b/dev-util/skipfish/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/skipfish
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.1 2010/03/23 17:42:00 ssuominen Exp $
+
+*skipfish-1.13_beta (23 Mar 2010)
+
+ 23 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +skipfish-1.13_beta.ebuild:
+ Initial commit by Alex Barker and me.
+
diff --git a/dev-util/skipfish/metadata.xml b/dev-util/skipfish/metadata.xml
new file mode 100644
index 000000000000..7cc5007c5d79
--- /dev/null
+++ b/dev-util/skipfish/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/skipfish/skipfish-1.13_beta.ebuild b/dev-util/skipfish/skipfish-1.13_beta.ebuild
new file mode 100644
index 000000000000..8d84f429bd49
--- /dev/null
+++ b/dev-util/skipfish/skipfish-1.13_beta.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-1.13_beta.ebuild,v 1.1 2010/03/23 17:42:00 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${P/_beta/b}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ -e 's:LDFLAGS:LIBS:' \
+ -e 's:$(CC):$(CC) $(LDFLAGS) $(CFLAGS):' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl || die
+
+ dohtml assets/* || die
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}