summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 10:21:20 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-10 10:21:20 +0000
commitfb13b0c7d8bcb1b3f3e61ac3445494033d3594d2 (patch)
tree98d4658ff9889afe645ea02042a86bc41a3b3701 /dev-util
parentUpdate manifest, cause upstream change tarballs, remove old revision (diff)
downloadgentoo-2-fb13b0c7d8bcb1b3f3e61ac3445494033d3594d2.tar.gz
gentoo-2-fb13b0c7d8bcb1b3f3e61ac3445494033d3594d2.tar.bz2
gentoo-2-fb13b0c7d8bcb1b3f3e61ac3445494033d3594d2.zip
Migrate to distutils-r1.eclass, enable python3.3 support.
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gdbus-codegen/ChangeLog6
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild14
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild14
3 files changed, 19 insertions, 15 deletions
diff --git a/dev-util/gdbus-codegen/ChangeLog b/dev-util/gdbus-codegen/ChangeLog
index 996630e4d5fc..59c327be2081 100644
--- a/dev-util/gdbus-codegen/ChangeLog
+++ b/dev-util/gdbus-codegen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/gdbus-codegen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/ChangeLog,v 1.40 2012/11/27 07:32:22 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/ChangeLog,v 1.41 2012/12/10 10:21:20 tetromino Exp $
+
+ 10 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gdbus-codegen-2.34.2.ebuild, gdbus-codegen-2.34.3.ebuild:
+ Migrate to distutils-r1.eclass, enable python3.3 support.
*gdbus-codegen-2.34.3 (27 Nov 2012)
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild
index 9fe309b319bb..ffc107777517 100644
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild,v 1.1 2012/11/10 05:00:35 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/gdbus-codegen-2.34.2.ebuild,v 1.2 2012/12/10 10:21:20 tetromino Exp $
EAPI="4"
GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT="python2_5 python2_6 python2_7 python3_1 python3_2"
-PYTHON_USE="xml"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE="xml"
-inherit eutils gnome.org python-distutils-ng
+inherit eutils gnome.org distutils-r1
DESCRIPTION="GDBus code and documentation generator"
HOMEPAGE="http://www.gtk.org/"
@@ -17,8 +17,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND=""
-DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
# To prevent circular dependencies with glib[test]
PDEPEND=">=dev-libs/glib-${PV}:2"
@@ -30,7 +30,7 @@ python_prepare_all() {
sed -e "s:\"/usr/local\":\"${EPREFIX}/usr\":" \
-i config.py || die "sed config.py failed"
- mv gdbus-codegen.in gdbus-codegen || die "mv failed"
+ sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
}
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild
index e5b0657a4711..fa1a7ff2faf1 100644
--- a/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild,v 1.1 2012/11/27 07:32:22 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gdbus-codegen/gdbus-codegen-2.34.3.ebuild,v 1.2 2012/12/10 10:21:20 tetromino Exp $
EAPI="5"
GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT="python2_5 python2_6 python2_7 python3_1 python3_2"
-PYTHON_USE="xml"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE="xml"
-inherit eutils gnome.org python-distutils-ng
+inherit eutils gnome.org distutils-r1
DESCRIPTION="GDBus code and documentation generator"
HOMEPAGE="http://www.gtk.org/"
@@ -17,8 +17,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND=""
-DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
# To prevent circular dependencies with glib[test]
PDEPEND=">=dev-libs/glib-${PV}:2"
@@ -30,7 +30,7 @@ python_prepare_all() {
sed -e "s:\"/usr/local\":\"${EPREFIX}/usr\":" \
-i config.py || die "sed config.py failed"
- mv gdbus-codegen.in gdbus-codegen || die "mv failed"
+ sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
}