summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-25 10:53:54 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-25 10:53:54 +0000
commitfaa5b9fa4b1d3ddef8f11b1d92c6d5aca1cb0e79 (patch)
tree64285e31cbf0a22e9ca25d40c9f661cf7e54295e /dev-util
parentFix compilation against curl-7.21.7 (bug #376229) (diff)
downloadgentoo-2-faa5b9fa4b1d3ddef8f11b1d92c6d5aca1cb0e79.tar.gz
gentoo-2-faa5b9fa4b1d3ddef8f11b1d92c6d5aca1cb0e79.tar.bz2
gentoo-2-faa5b9fa4b1d3ddef8f11b1d92c6d5aca1cb0e79.zip
Version bump.
(Portage version: 2.1.10.6/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meld/ChangeLog7
-rw-r--r--dev-util/meld/meld-1.5.2.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 152e9c84f765..2383c926a4b2 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/meld
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.127 2011/07/17 20:51:34 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.128 2011/07/25 10:53:54 pacho Exp $
+
+*meld-1.5.2 (25 Jul 2011)
+
+ 25 Jul 2011; Pacho Ramos <pacho@gentoo.org> +meld-1.5.2.ebuild:
+ Version bump.
17 Jul 2011; Markus Meier <maekke@gentoo.org> meld-1.5.1.ebuild:
arm stable, bug #369909
diff --git a/dev-util/meld/meld-1.5.2.ebuild b/dev-util/meld/meld-1.5.2.ebuild
new file mode 100644
index 000000000000..9787f347021a
--- /dev/null
+++ b/dev-util/meld/meld-1.5.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.5.2.ebuild,v 1.1 2011/07/25 10:53:54 pacho Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+
+inherit python gnome2 eutils multilib
+
+DESCRIPTION="A graphical diff and merge tool"
+HOMEPAGE="http://meld.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gnome"
+
+RDEPEND="
+ >=dev-python/pygtk-2.14:2
+ >=dev-python/pygobject-2.8:2
+ gnome? ( >=dev-python/gconf-python-2.22:2 )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ app-text/scrollkeeper"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS help/ChangeLog"
+ # Needed for optimizing python modules against proper interpreter
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # fix the prefix so its not in */local/*
+ sed -e "s:/usr/local:${EPREFIX}/usr:" \
+ -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):" \
+ -i INSTALL || die "sed 1 failed"
+
+ # don't install anything to /usr/share/doc/meld
+ sed -e "s:\$(docdir)/meld:\$(docdir)/${PF}:" \
+ -i INSTALL || die "sed 2 failed"
+
+ # let the python eclass handle python objects
+ sed -e '/$(PYTHON) .* .import compileall;/s/\t/&#/g' \
+ -i Makefile || die "sed 3 failed"
+
+ # don't run scrollkeeper (with the wrong path),
+ # leave that to gnome2.eclass #145833
+ sed -e '/scrollkeeper-update/s/\t/&#/' \
+ -i help/*/Makefile || die "sed 4 failed"
+
+ # fix test suite, upstream bug #655251
+ sed -e 's,\(for file in \["\)\(meld"\]\),\1bin/\2,' \
+ -e 's,\(open("\)\(meldapp.py")\),\1meld/\2,' \
+ -i tools/check_release || die "sed 5 failed"
+
+ # replace all calls to python by specific major version
+ sed -e "s/\(PYTHON ?= \).*/\1$(PYTHON -2)/" \
+ -i INSTALL || die "sed 6 failed"
+ python_convert_shebangs 2 "${S}"/tools/*
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s/PO:=.*/PO:=${mylinguas}/" \
+ -i po/Makefile || die "sed 5 failed"
+ fi
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/meld
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize /usr/$(get_libdir)/meld
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/meld
+}