summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-10 14:09:41 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-10 14:09:41 +0000
commitf9f045fc9fd01b92bf65860bf5bbb0e2999b9b26 (patch)
treeb3aa64b2e15cac9b0330e91b6e71b7249c4abb3f /dev-util
parentsys-kernel/aufs-sources: Bump to latest aufs3, linux and genpatch release (diff)
downloadgentoo-2-f9f045fc9fd01b92bf65860bf5bbb0e2999b9b26.tar.gz
gentoo-2-f9f045fc9fd01b92bf65860bf5bbb0e2999b9b26.tar.bz2
gentoo-2-f9f045fc9fd01b92bf65860bf5bbb0e2999b9b26.zip
Remove unneeded virtual/yacc dependency (bug #503994). Run make test in src_test().
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/splint/ChangeLog10
-rw-r--r--dev-util/splint/splint-3.1.2-r1.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-util/splint/ChangeLog b/dev-util/splint/ChangeLog
index fddb6ce13df9..b30cdff87225 100644
--- a/dev-util/splint/ChangeLog
+++ b/dev-util/splint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/splint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/ChangeLog,v 1.28 2012/12/19 18:27:06 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/ChangeLog,v 1.29 2014/03/10 14:09:41 jer Exp $
+
+*splint-3.1.2-r1 (10 Mar 2014)
+
+ 10 Mar 2014; Jeroen Roovers <jer@gentoo.org> +splint-3.1.2-r1.ebuild:
+ Remove unneeded virtual/yacc dependency (bug #503994). Run make test in
+ src_test().
19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> splint-3.1.2.ebuild:
Add ~ia64, wrt bug #441688
diff --git a/dev-util/splint/splint-3.1.2-r1.ebuild b/dev-util/splint/splint-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..4326a3dafc8a
--- /dev/null
+++ b/dev-util/splint/splint-3.1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/splint/splint-3.1.2-r1.ebuild,v 1.1 2014/03/10 14:09:41 jer Exp $
+
+EAPI=5
+
+DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
+HOMEPAGE="http://lclint.cs.virginia.edu/"
+SRC_URI="http://www.splint.org/downloads/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ sys-devel/flex
+"
+
+src_configure() {
+ # We do not need bison/yacc at all here
+ # We definitely need libfl
+ BISON=no LEXLIB=-lfl econf
+}
+
+src_compile() {
+ local subdir
+ # skip test/ subdir
+ for subdir in src lib imports doc; do
+ emake -j1 -C ${subdir}
+ done
+}
+
+src_test() {
+ emake -C test
+}