summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-17 09:29:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-17 09:29:59 +0000
commitf1ed8ab86af85566105fb370f01874284413d556 (patch)
tree83158f58e25673cf69455221ef83b38d296462c1 /dev-util
parentVersion Bump, 270458, fixes for prestripped files. #252033 (diff)
downloadgentoo-2-f1ed8ab86af85566105fb370f01874284413d556.tar.gz
gentoo-2-f1ed8ab86af85566105fb370f01874284413d556.tar.bz2
gentoo-2-f1ed8ab86af85566105fb370f01874284413d556.zip
Version bump wrt #321575 by Andrey Hippo.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconfig/ChangeLog10
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.25.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index d54ad3453f28..acf0e9c77d80 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconfig
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.79 2009/05/11 22:20:51 leio Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.80 2010/06/17 09:29:59 ssuominen Exp $
+
+*pkgconfig-0.25 (17 Jun 2010)
+
+ 17 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-0.25.ebuild:
+ Version bump wrt #321575 by Andrey Hippo.
11 May 2009; Mart Raudsepp <leio@gentoo.org> -pkgconfig-0.17.2-r1.ebuild,
-pkgconfig-0.20.ebuild:
diff --git a/dev-util/pkgconfig/pkgconfig-0.25.ebuild b/dev-util/pkgconfig/pkgconfig-0.25.ebuild
new file mode 100644
index 000000000000..644f473332b6
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.25.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.25.ebuild,v 1.1 2010/06/17 09:29:59 ssuominen Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+MY_P=pkg-config-${PV}
+
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="elibc_FreeBSD hardened"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ local myconf
+ use elibc_FreeBSD && myconf="--enable-indirect-deps"
+
+ econf \
+ --docdir=/usr/share/doc/${PF}/html \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}