summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2014-05-18 22:49:31 +0000
committerBrian Dolbec <dolsen@gentoo.org>2014-05-18 22:49:31 +0000
commitf1aff969cb5ba2762596ea878239a4594073ffe1 (patch)
tree644350e139cee0ca6befcff9a2d598bc77fcd2c6 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-f1aff969cb5ba2762596ea878239a4594073ffe1.tar.gz
gentoo-2-f1aff969cb5ba2762596ea878239a4594073ffe1.tar.bz2
gentoo-2-f1aff969cb5ba2762596ea878239a4594073ffe1.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x65E309F2189DB0B8)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.12.2.ebuild102
-rw-r--r--dev-util/catalyst/catalyst-2.0.14.ebuild100
-rw-r--r--dev-util/catalyst/catalyst-2.0.17.ebuild (renamed from dev-util/catalyst/catalyst-2.0.15.ebuild)7
4 files changed, 11 insertions, 206 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index 16e97e296784..dc2c1def739c 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.273 2014/03/02 15:54:54 dolsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.274 2014/05/18 22:49:31 dolsen Exp $
+
+*catalyst-2.0.17 (18 May 2014)
+
+ 18 May 2014; Brian Dolbec <dolsen@gentoo.org> -catalyst-2.0.12.2.ebuild,
+ -catalyst-2.0.14.ebuild, -catalyst-2.0.15.ebuild, +catalyst-2.0.17.ebuild:
+ Version bump, remove old versions.
02 Mar 2014; Brian Dolbec <dolsen@gentoo.org> catalyst-9999.ebuild:
Swap out the ebuild for the new python structure.
diff --git a/dev-util/catalyst/catalyst-2.0.12.2.ebuild b/dev-util/catalyst/catalyst-2.0.12.2.ebuild
deleted file mode 100644
index a11649066a55..000000000000
--- a/dev-util/catalyst/catalyst-2.0.12.2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.12.2.ebuild,v 1.5 2014/01/18 11:38:05 vapier Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-inherit eutils multilib python
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-RESTRICT=""
-IUSE="ccache kernel_linux"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1 files/catalyst-spec.5
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
- elog "update_seed syntax has changed to make it more flexible."
- elog "This is an optional setting supported by stage1 that runs an emerge"
- elog "command on the seed stage before starting the stage1 build. (example:"
- elog "'--update dev-libs/mpfr dev-libs/mpc dev-libs/gmp')"
-}
diff --git a/dev-util/catalyst/catalyst-2.0.14.ebuild b/dev-util/catalyst/catalyst-2.0.14.ebuild
deleted file mode 100644
index 7411ac487434..000000000000
--- a/dev-util/catalyst/catalyst-2.0.14.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.14.ebuild,v 1.2 2014/01/18 11:38:05 vapier Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git-2
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-inherit eutils multilib python
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-RESTRICT=""
-IUSE="ccache kernel_linux"
-
-DEPEND="app-text/asciidoc"
-RDEPEND="app-arch/lbzip2
- app-crypt/shash
- virtual/cdrtools
- x86? ( >=sys-boot/syslinux-3.72 )
- amd64? ( >=sys-boot/syslinux-3.72 )
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
- echo
- if [[ ${PV} == *9999* ]]; then
- ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
- ewarn "work-in-progress code. Be aware that it's likely that it will not"
- ewarn "be in a working state at any given point. Please do not file bugs"
- ewarn "until you have posted on the gentoo-catalyst mailing list and we"
- ewarn "have asked you to do so."
- fi
- python_set_active_version 2
-}
-
-src_prepare() {
- python_convert_shebangs 2 catalyst modules/catalyst_lock.py
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- if [[ ${PV} == 3.9999* ]]; then
- doins -r modules files || die "copying files"
- else
- doins -r arch modules livecd || die "copying files"
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
- insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
- dodoc README AUTHORS
- doman files/catalyst.1 files/catalyst-spec.5
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}
-
-pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
-}
diff --git a/dev-util/catalyst/catalyst-2.0.15.ebuild b/dev-util/catalyst/catalyst-2.0.17.ebuild
index 4a574266abbe..bf6394c287be 100644
--- a/dev-util/catalyst/catalyst-2.0.15.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.15.ebuild,v 1.3 2014/01/18 11:38:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.17.ebuild,v 1.1 2014/05/18 22:49:31 dolsen Exp $
EAPI=5
@@ -15,11 +15,12 @@ else
SRC_URI="mirror://gentoo/${P}.tar.bz2
http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
http://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
- http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2"
+ http://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
+ http://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
fi
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
inherit eutils multilib python-single-r1 ${SRC_ECLASS}