summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-05 13:54:38 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-11-05 13:54:38 +0000
commitef6af909dfca51db1fd15ae9b021fcb70bd02b6b (patch)
tree3dd1d72cfbcfec4843293892dcd34624c4a49532 /dev-util
parentStable on amd64 wrt bug #441028 (diff)
downloadgentoo-2-ef6af909dfca51db1fd15ae9b021fcb70bd02b6b.tar.gz
gentoo-2-ef6af909dfca51db1fd15ae9b021fcb70bd02b6b.tar.bz2
gentoo-2-ef6af909dfca51db1fd15ae9b021fcb70bd02b6b.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdevplatform/ChangeLog8
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.4.1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index 44d8d6def563..b5adc346fd3e 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.71 2012/10/30 16:38:57 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.72 2012/11/05 13:54:38 kensington Exp $
+
+*kdevplatform-1.4.1 (05 Nov 2012)
+
+ 05 Nov 2012; Michael Palimaka <kensington@gentoo.org>
+ +kdevplatform-1.4.1.ebuild:
+ Version bump.
*kdevplatform-1.4.0 (30 Oct 2012)
diff --git a/dev-util/kdevplatform/kdevplatform-1.4.1.ebuild b/dev-util/kdevplatform/kdevplatform-1.4.1.ebuild
new file mode 100644
index 000000000000..add6fd904b5e
--- /dev/null
+++ b/dev-util/kdevplatform/kdevplatform-1.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.4.1.ebuild,v 1.1 2012/11/05 13:54:38 kensington Exp $
+
+EAPI=4
+
+KMNAME="kdevelop"
+KDE_MINIMAL="4.7"
+KDE_LINGUAS="bs ca ca@valencia da de el en_GB es et fi fr gl it nb nds nl pl pt
+pt_BR sl sv th uk zh_CN zh_TW"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+EGIT_REPONAME="${PN}"
+
+inherit kde4-base
+
+DESCRIPTION="KDE development support libraries and apps"
+LICENSE="GPL-2 LGPL-2"
+IUSE="cvs debug reviewboard subversion"
+
+if [[ $PV == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+DEPEND="
+ dev-libs/boost
+ reviewboard? ( dev-libs/qjson )
+ subversion? (
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-vcs/subversion
+ )
+"
+RDEPEND="${DEPEND}
+ !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
+ $(add_kdebase_dep konsole)
+ cvs? ( dev-vcs/cvs )
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build cvs)
+ $(cmake-utils_use_build reviewboard)
+ $(cmake-utils_use_build subversion)
+ )
+
+ kde4-base_src_configure
+}