summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2009-10-21 12:47:47 +0000
committerDirkjan Ochtman <djc@gentoo.org>2009-10-21 12:47:47 +0000
commitec47fe839b6ee7278fa1a144e261b7d7aaeae7f2 (patch)
tree4810617eafa19499fe5e504534115abfd9292e6a /dev-util
parentMask paman. (diff)
downloadgentoo-2-ec47fe839b6ee7278fa1a144e261b7d7aaeae7f2.tar.gz
gentoo-2-ec47fe839b6ee7278fa1a144e261b7d7aaeae7f2.tar.bz2
gentoo-2-ec47fe839b6ee7278fa1a144e261b7d7aaeae7f2.zip
Version bump boost-build to 1.40.0.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/ChangeLog8
-rw-r--r--dev-util/boost-build/boost-build-1.40.0.ebuild104
-rw-r--r--dev-util/boost-build/metadata.xml4
3 files changed, 115 insertions, 1 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 1d8ac24d3e23..424b18d14bf7 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.38 2009/07/16 09:33:38 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.39 2009/10/21 12:47:47 djc Exp $
+
+*boost-build-1.40.0 (21 Oct 2009)
+
+ 21 Oct 2009; Dirkjan Ochtman <djc@gentoo.org> +boost-build-1.40.0.ebuild,
+ metadata.xml:
+ Version bump to 1.40 (add myself to maintainers).
*boost-build-1.39.0 (16 Jul 2009)
diff --git a/dev-util/boost-build/boost-build-1.40.0.ebuild b/dev-util/boost-build/boost-build-1.40.0.ebuild
new file mode 100644
index 000000000000..6e5c2628b4f0
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.40.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.40.0.ebuild,v 1.1 2009/10/21 12:47:47 djc Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators _)
+MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
+HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples python"
+
+DEPEND="!<dev-libs/boost-1.34.0
+ !<=dev-util/boost-build-1.35.0-r1
+ python? ( dev-lang/python )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/boost_${MY_PV}/tools"
+
+src_unpack() {
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2}
+}
+
+src_prepare() {
+ # Remove stripping option
+ cd "${S}/jam/src"
+ sed -i -e 's|-s\b||' \
+ build.jam || die "sed failed"
+
+ # Force regeneration
+ rm jambase.c
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}/build/v2"
+ sed -i \
+ -e 's/\(off speed space\)/\1 none/' \
+ -e 's/\(debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+}
+
+src_compile() {
+ cd jam/src
+ local toolset
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ # For slotting
+ sed -i \
+ -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
+ Jambase || die "sed failed"
+
+ # The build.jam file for building bjam using a bootstrapped jam0 ignores
+ # the LDFLAGS env var (bug #209794). We have now two options:
+ # a) change the cc-target definition in build.jam to include separate compile
+ # and link targets to make it use the LDFLAGS var, or
+ # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
+ # (which should not be set by us).
+ if [[ -z "${LDFLAGS}" ]] ; then
+ CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
+ || die "building bjam failed"
+ else
+ LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
+ $(use_with python) || die "building bjam failed"
+ fi
+}
+
+src_install() {
+ newbin jam/src/bin.*/bjam bjam-${MAJOR_PV}
+
+ cd "${S}/build/v2"
+ insinto /usr/share/boost-build-${MAJOR_PV}
+ doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
+ build kernel options tools util || die
+
+ dodoc changes.txt hacking.txt release_procedure.txt \
+ notes/build_dir_option.txt notes/relative_source_paths.txt
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd jam/test
+ ./test.sh || die "tests failed"
+}
diff --git a/dev-util/boost-build/metadata.xml b/dev-util/boost-build/metadata.xml
index 64e111f55791..b209da63dacb 100644
--- a/dev-util/boost-build/metadata.xml
+++ b/dev-util/boost-build/metadata.xml
@@ -6,4 +6,8 @@
<email>dev-zero@gentoo.org</email>
<name>Tiziano Müller</name>
</maintainer>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
</pkgmetadata>