summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-09-11 08:09:33 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-09-11 08:09:33 +0000
commitebf933333a49d86ba794b60e6d24492060b04d98 (patch)
tree2f1bb3d721498c749b1ae0d583d41bb86914bb5d /dev-util
parentAdd a patch to fix mutt with dev-libs/cyrus-sasl-2.1.22. Fixes bug #146696. T... (diff)
downloadgentoo-2-ebf933333a49d86ba794b60e6d24492060b04d98.tar.gz
gentoo-2-ebf933333a49d86ba794b60e6d24492060b04d98.tar.bz2
gentoo-2-ebf933333a49d86ba794b60e6d24492060b04d98.zip
Add a xinetd configuration file.As per bug #145177. Thanks to Patrick Guimond <patg@patg.homeunix.org>
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/git-daemon.xinetd13
-rw-r--r--dev-util/git/git-1.4.2.ebuild17
3 files changed, 29 insertions, 8 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 048be5890241..03385af3d101 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.119 2006/09/07 00:14:01 christel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.120 2006/09/11 08:09:32 ferdy Exp $
+
+ 11 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/git-daemon.xinetd, git-1.4.2.ebuild:
+ Add a xinetd configuration file.As per bug #145177. Thanks to Patrick
+ Guimond <patg@patg.homeunix.org>
07 Sep 2006; Christel Dahlskjaer <christel@gentoo.org> git-1.4.1.1.ebuild:
Added ~mips, as per bug #126850
diff --git a/dev-util/git/files/git-daemon.xinetd b/dev-util/git/files/git-daemon.xinetd
new file mode 100644
index 000000000000..a0748b20ccf4
--- /dev/null
+++ b/dev-util/git/files/git-daemon.xinetd
@@ -0,0 +1,13 @@
+service git-daemon
+{
+ disable = yes
+ socket_type = stream
+ wait = no
+ user = nobody
+ type = UNLISTED
+ protocol = tcp
+ log_on_failure += USERID
+ port = 9418
+ server = /usr/bin/git-daemon
+ server_args = --inetd --syslog --export-all --base-path=/var/git
+}
diff --git a/dev-util/git/git-1.4.2.ebuild b/dev-util/git/git-1.4.2.ebuild
index cfcb6b897a9d..3d1ef5e00523 100644
--- a/dev-util/git/git-1.4.2.ebuild
+++ b/dev-util/git/git-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.ebuild,v 1.5 2006/08/15 14:51:06 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.ebuild,v 1.6 2006/09/11 08:09:32 ferdy Exp $
inherit python toolchain-funcs eutils elisp-common
@@ -106,6 +106,9 @@ src_install() {
use doc && dodoc contrib/gitview/gitview.txt
fi
+ insinto /etc/xinet.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
newinitd "${FILESDIR}"/git-daemon.initd git-daemon
newconfd "${FILESDIR}"/git-daemon.confd git-daemon
}
@@ -122,22 +125,22 @@ pkg_postinst() {
use emacs && elisp-site-regen
einfo
einfo "If you want to import arch repositories into git, consider using the"
- einfo "git-archimport command. You should install dev-util/tla before"
+ einfo "git-archimport command. You should install dev-util/tla before."
einfo
einfo "If you want to import cvs repositories into git, consider using the"
- einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
einfo
einfo "If you want to import svn repositories into git, consider using the"
- einfo "git-svnimport command. You should install dev-util/subversion before"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
einfo
einfo "If you want to manage subversion repositories using git, consider"
- einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
einfo
einfo "If you want to import a quilt series into git, consider using the"
- einfo "git-quiltimport command. You should install dev-util/quilt before"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
einfo
einfo "If you want to use the included CVS server you will need to install"
- einfo "dev-perl/DBI and dev-perl/DBD-SQLite"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
einfo
}