summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-07 11:41:27 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-07 11:41:27 +0000
commite5866b55151d22770d657d88d2c82248682749dd (patch)
tree43f685d1047b6fdcadcf9171643197b98b2b9db1 /dev-util
parentDrop unnecessary qt4.eclass usage, fixes bug 410107. Add gold linking patch a... (diff)
downloadgentoo-2-e5866b55151d22770d657d88d2c82248682749dd.tar.gz
gentoo-2-e5866b55151d22770d657d88d2c82248682749dd.tar.bz2
gentoo-2-e5866b55151d22770d657d88d2c82248682749dd.zip
Revision bump adds upstream patch to fix crash when building project if qt is built with USE=debug spotted by Matěj Laitl <matej@laitl.cz> wrt bug #414721.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdevelop/ChangeLog9
-rw-r--r--dev-util/kdevelop/files/kdevelop-4.3.1-fix-assert.patch28
-rw-r--r--dev-util/kdevelop/kdevelop-4.3.1-r1.ebuild51
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-util/kdevelop/ChangeLog b/dev-util/kdevelop/ChangeLog
index 83e4a3ed45ea..91de4fe9111d 100644
--- a/dev-util/kdevelop/ChangeLog
+++ b/dev-util/kdevelop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/kdevelop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/ChangeLog,v 1.230 2012/04/22 12:08:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/ChangeLog,v 1.231 2012/05/07 11:41:27 johu Exp $
+
+*kdevelop-4.3.1-r1 (07 May 2012)
+
+ 07 May 2012; Johannes Huber <johu@gentoo.org>
+ +files/kdevelop-4.3.1-fix-assert.patch, +kdevelop-4.3.1-r1.ebuild:
+ Revision bump adds upstream patch to fix crash when building project if qt is
+ built with USE=debug spotted by Matěj Laitl <matej@laitl.cz> wrt bug #414721.
22 Apr 2012; Markus Meier <maekke@gentoo.org> kdevelop-4.2.3.ebuild:
x86 stable, bug #368739
diff --git a/dev-util/kdevelop/files/kdevelop-4.3.1-fix-assert.patch b/dev-util/kdevelop/files/kdevelop-4.3.1-fix-assert.patch
new file mode 100644
index 000000000000..52ba5fadff4b
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-4.3.1-fix-assert.patch
@@ -0,0 +1,28 @@
+From: Michael Jansen <kde@michael-jansen.biz>
+Date: Sun, 08 Apr 2012 15:46:01 +0000
+Subject: addLineBatch(): Fix a crash if linesInBatch == 0
+X-Git-Url: http://quickgit.kde.org/?p=kdevelop.git&amp;a=commitdiff&amp;h=8a0b638c58dcfe261ce789963be2413300a65fc6
+---
+addLineBatch(): Fix a crash if linesInBatch == 0
+
+[...]
+#6 0x00007fa986970708 in QAbstractItemModel::beginInsertRows (this=0x3699fb0, parent=..., first=11, last=10) at /home/mjansen/ws/src/qt/qt/src/corelib/kernel/qabstractitemmodel.cpp:2413
+#7 0x00007fa959b46571 in MakeOutputModel::addLineBatch (this=0x3699fb0) at /home/mjansen/ws/src/kdevelop/kdevelop/projectbuilders/makebuilder/makeoutputmodel.cpp:217
+[...]
+---
+
+
+--- a/projectbuilders/makebuilder/makeoutputmodel.cpp
++++ b/projectbuilders/makebuilder/makeoutputmodel.cpp
+@@ -214,6 +214,10 @@ void MakeOutputModel::addLineBatch()
+ const int maxLines = 50;
+ const int linesInBatch = qMin(lineBuffer.count(), maxLines);
+
++ // If there is nothing to insert we are done.
++ if ( linesInBatch == 0 )
++ return;
++
+ beginInsertRows( QModelIndex(), rowCount(), rowCount() + linesInBatch - 1);
+
+ for(int i = 0; i < linesInBatch; ++i) {
+
diff --git a/dev-util/kdevelop/kdevelop-4.3.1-r1.ebuild b/dev-util/kdevelop/kdevelop-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..7a6a90ace23c
--- /dev/null
+++ b/dev-util/kdevelop/kdevelop-4.3.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/kdevelop-4.3.1-r1.ebuild,v 1.1 2012/05/07 11:41:27 johu Exp $
+
+EAPI=4
+
+KDE_LINGUAS="bs ca ca@valencia da de el en_GB es et fi fr gl it nb nds nl pl pt
+pt_BR ru sl sv th uk zh_CN zh_TW"
+VIRTUALX_REQUIRED=test
+KDE_SCM="git"
+
+inherit kde4-base
+
+DESCRIPTION="Integrated Development Environment for Unix, supporting KDE/Qt, C/C++ and many other languages."
+LICENSE="GPL-2 LGPL-2"
+IUSE="+cmake +cxx debug okteta qthelp"
+
+if [[ $PV == *9999* ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+DEPEND="
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ okteta? ( $(add_kdebase_dep okteta) )
+ qthelp? ( >=x11-libs/qt-assistant-4.4:4 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kapptemplate)
+ cxx? ( >=sys-devel/gdb-7.0[python] )
+"
+RESTRICT="test"
+# see bug 366471
+
+PATCHES=( "${FILESDIR}/${P}-fix-assert.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build cmake)
+ $(cmake-utils_use_build cmake cmakebuilder)
+ $(cmake-utils_use_build cxx cpp)
+ $(cmake-utils_use_with okteta LibKasten)
+ $(cmake-utils_use_with okteta LibOkteta)
+ $(cmake-utils_use_with okteta LibOktetaKasten)
+ $(cmake-utils_use_build qthelp)
+ )
+
+ kde4-base_src_configure
+}