summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-04-03 13:36:01 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-04-03 13:36:01 +0000
commite35aa6da4d71856baf78710d3edbb1c5e32b9d40 (patch)
tree46be1c727a3c2253967f97498e28865b55cc8cff /dev-util
parentadded multiple monitor support as per bug #204751 thanks to Matthew Howle and... (diff)
downloadgentoo-2-e35aa6da4d71856baf78710d3edbb1c5e32b9d40.tar.gz
gentoo-2-e35aa6da4d71856baf78710d3edbb1c5e32b9d40.tar.bz2
gentoo-2-e35aa6da4d71856baf78710d3edbb1c5e32b9d40.zip
use system pcre as suggested by Dennis Schridde in bug #215837
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/monotone/ChangeLog5
-rw-r--r--dev-util/monotone/monotone-0.39.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index 95a793d2dc5f..d5e33d71a28d 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.51 2008/04/02 02:11:15 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.52 2008/04/03 13:36:01 dragonheart Exp $
+
+ 03 Apr 2008; Daniel Black <dragonheart@gentoo.org> monotone-0.39.ebuild:
+ use system pcre as suggested by Dennis Schridde in bug #215837
*monotone-0.39 (02 Apr 2008)
diff --git a/dev-util/monotone/monotone-0.39.ebuild b/dev-util/monotone/monotone-0.39.ebuild
index 74ec150042ad..8bbb7db2a7aa 100644
--- a/dev-util/monotone/monotone-0.39.ebuild
+++ b/dev-util/monotone/monotone-0.39.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.39.ebuild,v 1.1 2008/04/02 02:11:15 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.39.ebuild,v 1.2 2008/04/03 13:36:01 dragonheart Exp $
inherit elisp-common flag-o-matic bash-completion eutils
@@ -16,7 +16,8 @@ IUSE="doc emacs ipv6 nls"
RDEPEND="
sys-libs/zlib
- emacs? ( virtual/emacs )"
+ emacs? ( virtual/emacs )
+ >=dev-libs/libpcre-7.6"
DEPEND="${RDEPEND}
>=dev-libs/boost-1.33.1
@@ -41,7 +42,9 @@ src_compile() {
append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
- econf $(use_enable nls) $(use_enable ipv6) || die "configure failed"
+ econf $(use_enable nls) \
+ $(use_enable ipv6) \
+ --with-system-pcre || die "configure failed"
emake || die "Compilation failed"
if use doc; then