summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-05-26 07:26:43 +0000
committerPacho Ramos <pacho@gentoo.org>2013-05-26 07:26:43 +0000
commitd70737b6687290132dc049f3e149f89b569c6f4f (patch)
treefe1cf435fc713e545e4a3ffd33e43bdbe7840ea9 /dev-util
parentStable for ppc, wrt bug #468862 (diff)
downloadgentoo-2-d70737b6687290132dc049f3e149f89b569c6f4f.tar.gz
gentoo-2-d70737b6687290132dc049f3e149f89b569c6f4f.tar.bz2
gentoo-2-d70737b6687290132dc049f3e149f89b569c6f4f.zip
Use plain localedir to install mo files to rather than trying to guess one (#432848#c11), fix handling absolute paths in single file key output (#470040).
(Portage version: 2.1.12.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intltool/ChangeLog11
-rw-r--r--dev-util/intltool/files/intltool-0.50.2-absolute-paths.patch63
-rw-r--r--dev-util/intltool/files/intltool-0.50.2-localedir-fix.patch70
-rw-r--r--dev-util/intltool/intltool-0.50.2-r1.ebuild33
4 files changed, 176 insertions, 1 deletions
diff --git a/dev-util/intltool/ChangeLog b/dev-util/intltool/ChangeLog
index 6e4d4389743f..3fca56037c9d 100644
--- a/dev-util/intltool/ChangeLog
+++ b/dev-util/intltool/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/intltool
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/intltool/ChangeLog,v 1.165 2013/02/21 03:01:23 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intltool/ChangeLog,v 1.166 2013/05/26 07:26:43 pacho Exp $
+
+*intltool-0.50.2-r1 (26 May 2013)
+
+ 26 May 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/intltool-0.50.2-absolute-paths.patch,
+ +files/intltool-0.50.2-localedir-fix.patch, +intltool-0.50.2-r1.ebuild:
+ Use plain localedir to install mo files to rather than trying to guess one
+ (#432848#c11), fix handling absolute paths in single file key output
+ (#470040).
21 Feb 2013; Zac Medico <zmedico@gentoo.org> intltool-0.50.2.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-util/intltool/files/intltool-0.50.2-absolute-paths.patch b/dev-util/intltool/files/intltool-0.50.2-absolute-paths.patch
new file mode 100644
index 000000000000..117f4a30c29b
--- /dev/null
+++ b/dev-util/intltool/files/intltool-0.50.2-absolute-paths.patch
@@ -0,0 +1,63 @@
+From c262cb09fa9f4dad056ba5b25a8627408bcf909a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 14 Apr 2013 20:41:41 +0200
+Subject: [PATCH] Fix handling absolute paths in single file key output.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Michał Górny <mgorny@gentoo.org>
+Fixes: https://bugs.gentoo.org/show_bug.cgi?id=464954
+---
+ intltool-merge.in | 17 ++++++++++++-----
+ 1 file changed, 12 insertions(+), 5 deletions(-)
+
+diff --git a/intltool-merge.in b/intltool-merge.in
+index 1afa2a4..47dbbdf 100644
+--- a/intltool-merge.in
++++ b/intltool-merge.in
+@@ -1108,13 +1108,20 @@ sub keys_merge_translation
+ {
+ my ($lang) = @_;
+
+- if ( ! -d $lang && $MULTIPLE_OUTPUT)
++ my $outpath = "$OUTFILE";
++
++ if ($MULTIPLE_OUTPUT)
+ {
+- mkdir $lang or -d $lang or die "Cannot create subdirectory $lang: $!\n";
++ $outpath = "$lang/$outpath";
++
++ if ( ! -d $lang )
++ {
++ mkdir $lang or -d $lang or die "Cannot create subdirectory $lang: $!\n";
++ }
+ }
+
+ open INPUT, "<${FILE}" or die "Cannot open ${FILE}: $!\n";
+- open OUTPUT, ">$lang/$OUTFILE" or die "Cannot open $lang/$OUTFILE: $!\n";
++ open OUTPUT, ">$outpath" or die "Cannot open $outpath: $!\n";
+ binmode (OUTPUT) if $^O eq 'MSWin32';
+
+ while (<INPUT>)
+@@ -1159,7 +1166,7 @@ sub keys_merge_translation
+ close OUTPUT;
+ close INPUT;
+
+- print "CREATED $lang/$OUTFILE\n" unless $QUIET_ARG;
++ print "CREATED $outpath\n" unless $QUIET_ARG;
+ }
+
+ sub keys_merge_translations
+@@ -1174,7 +1181,7 @@ sub keys_merge_translations
+ }
+ else
+ {
+- keys_merge_translation (".");
++ keys_merge_translation ();
+ }
+ }
+
+--
+1.8.1.5
+
diff --git a/dev-util/intltool/files/intltool-0.50.2-localedir-fix.patch b/dev-util/intltool/files/intltool-0.50.2-localedir-fix.patch
new file mode 100644
index 000000000000..a887c41d3b52
--- /dev/null
+++ b/dev-util/intltool/files/intltool-0.50.2-localedir-fix.patch
@@ -0,0 +1,70 @@
+=== modified file 'Makefile.in.in'
+--- Makefile.in.in 2013-05-12 18:38:08 +0000
++++ Makefile.in.in 2013-05-22 13:43:26 +0000
+@@ -33,8 +33,7 @@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+-DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++localedir = @localedir@
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+@@ -108,7 +107,7 @@
+ install-data-yes: all
+ linguas="$(USE_LINGUAS)"; \
+ for lang in $$linguas; do \
+- dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
++ dir=$(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkdir_p) $$dir; \
+ if test -r $$lang.gmo; then \
+ $(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
+@@ -142,8 +141,8 @@
+ uninstall:
+ linguas="$(USE_LINGUAS)"; \
+ for lang in $$linguas; do \
+- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
+- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
++ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
++ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
+ done
+
+ check: all $(GETTEXT_PACKAGE).pot
+
+=== modified file 'intltool.m4'
+--- intltool.m4 2012-02-20 14:50:33 +0000
++++ intltool.m4 2013-05-12 17:08:09 +0000
+@@ -155,31 +155,6 @@
+ # Substitute ALL_LINGUAS so we can use it in po/Makefile
+ AC_SUBST(ALL_LINGUAS)
+
+-# Set DATADIRNAME correctly if it is not set yet
+-# (copied from glib-gettext.m4)
+-if test -z "$DATADIRNAME"; then
+- AC_LINK_IFELSE(
+- [AC_LANG_PROGRAM([[]],
+- [[extern int _nl_msg_cat_cntr;
+- return _nl_msg_cat_cntr]])],
+- [DATADIRNAME=share],
+- [case $host in
+- *-*-solaris*)
+- dnl On Solaris, if bind_textdomain_codeset is in libc,
+- dnl GNU format message catalog is always supported,
+- dnl since both are added to the libc all together.
+- dnl Hence, we'd like to go with DATADIRNAME=share
+- dnl in this case.
+- AC_CHECK_FUNC(bind_textdomain_codeset,
+- [DATADIRNAME=share], [DATADIRNAME=lib])
+- ;;
+- *)
+- [DATADIRNAME=lib]
+- ;;
+- esac])
+-fi
+-AC_SUBST(DATADIRNAME)
+-
+ IT_PO_SUBDIR([po])
+
+ ])
+
diff --git a/dev-util/intltool/intltool-0.50.2-r1.ebuild b/dev-util/intltool/intltool-0.50.2-r1.ebuild
new file mode 100644
index 000000000000..e084fd1d9c19
--- /dev/null
+++ b/dev-util/intltool/intltool-0.50.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/intltool/intltool-0.50.2-r1.ebuild,v 1.1 2013/05/26 07:26:43 pacho Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Internationalization Tool Collection"
+HOMEPAGE="https://launchpad.net/intltool/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+"
+RDEPEND="${DEPEND}
+ sys-devel/gettext
+"
+DOCS=( AUTHORS ChangeLog NEWS README TODO doc/I18N-HOWTO )
+
+src_prepare() {
+ # Use plain localedir to install mo files to, rather than trying to
+ # guess one, bug #432848#c11
+ epatch "${FILESDIR}/${P}-localedir-fix.patch"
+
+ # Fix handling absolute paths in single file key output, bug #470040
+ epatch "${FILESDIR}/${PN}-0.50.2-absolute-paths.patch"
+}