summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-31 22:07:34 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-31 22:07:34 +0000
commitd42a33f158de7edba8fb5ef964892431bd573610 (patch)
treefaae35a788b89a238cf67bb3bfd3372b03f52120 /dev-util
parentadding hybrid authentication support. As distribution of binaries with that ... (diff)
downloadgentoo-2-d42a33f158de7edba8fb5ef964892431bd573610.tar.gz
gentoo-2-d42a33f158de7edba8fb5ef964892431bd573610.tar.bz2
gentoo-2-d42a33f158de7edba8fb5ef964892431bd573610.zip
Version bump to 2.0.5_pre3 to test some new stage-building code.
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.5_pre3.ebuild74
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0.5_pre33
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index da654579b10f..270abf108acd 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.172 2007/08/29 18:19:20 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.173 2007/08/31 22:07:34 wolf31o2 Exp $
+
+*catalyst-2.0.5_pre3 (31 Aug 2007)
+
+ 31 Aug 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.5_pre3.ebuild:
+ Version bump to 2.0.5_pre3 to test some new stage-building code.
*catalyst-2.0.5_pre2 (29 Aug 2007)
diff --git a/dev-util/catalyst/catalyst-2.0.5_pre3.ebuild b/dev-util/catalyst/catalyst-2.0.5_pre3.ebuild
new file mode 100644
index 000000000000..5d12a785b358
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.5_pre3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.5_pre3.ebuild,v 1.1 2007/08/31 22:07:34 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/lib/${PN}/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}
+ doexe catalyst || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.5_pre3 b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre3
new file mode 100644
index 000000000000..196a20baa597
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0.5_pre3
@@ -0,0 +1,3 @@
+MD5 eeae53de82088dfc0b7f5501c20441b8 catalyst-2.0.5_pre3.tar.bz2 787633
+RMD160 35cce56e9863e095aaaf5118bc95e29b3ce96c2c catalyst-2.0.5_pre3.tar.bz2 787633
+SHA256 5f64fbf10175b1477e6c9e1e8938a29ab0fe0848ce13b1b3150f04d183a70dd9 catalyst-2.0.5_pre3.tar.bz2 787633