summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-04-19 13:29:32 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-04-19 13:29:32 +0000
commitc977a90f1cbbb11664f04a85d2af8cee4a93a7c9 (patch)
treeaa84ead94ae47cb0dd7d2fdd2a071324146d29ed /dev-util
parentfixing digest issue (diff)
downloadgentoo-2-c977a90f1cbbb11664f04a85d2af8cee4a93a7c9.tar.gz
gentoo-2-c977a90f1cbbb11664f04a85d2af8cee4a93a7c9.tar.bz2
gentoo-2-c977a90f1cbbb11664f04a85d2af8cee4a93a7c9.zip
Made sed for ccache actually be determined by USE=ccache and removed sed for crc32->md5 since we no longer use Archive-Zip.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog7
-rw-r--r--dev-util/catalyst/catalyst-2.0_rc42.ebuild8
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index b73c6b2255be..0abd77199ae5 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.143 2006/04/18 21:04:49 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.144 2006/04/19 13:29:32 wolf31o2 Exp $
+
+ 19 Apr 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ catalyst-2.0_rc42.ebuild:
+ Made sed for ccache actually be determined by USE=ccache and removed sed for
+ crc32->md5 since we no longer use Archive-Zip.
*catalyst-2.0_rc42 (18 Apr 2006)
diff --git a/dev-util/catalyst/catalyst-2.0_rc42.ebuild b/dev-util/catalyst/catalyst-2.0_rc42.ebuild
index acdfdaf25605..c1b70363fd7d 100644
--- a/dev-util/catalyst/catalyst-2.0_rc42.ebuild
+++ b/dev-util/catalyst/catalyst-2.0_rc42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc42.ebuild,v 1.1 2006/04/18 21:04:49 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc42.ebuild,v 1.2 2006/04/19 13:29:32 wolf31o2 Exp $
inherit eutils
@@ -81,11 +81,9 @@ src_install() {
/etc/catalyst2/catalyst2.conf
dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
/etc/catalyst2/catalyst2.conf
- # This is the dirty hack for missing dev-perl/Archive-Zip
- dosed 's:hash_function="crc32":hash_function="md5":' \
- /etc/catalyst2/catalyst2.conf
# Here is where we actually enable ccache
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
/etc/catalyst2/catalyst2.conf
}