summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-26 11:02:01 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-26 11:02:01 +0000
commitc93a22613bea5d95eb1ea2568543af56292c831c (patch)
treeeb95eef84c24304770c70cf47926f9cf32fcbf4d /dev-util
parentRevert swt:3 removal; bug 282289 was outdated, two new packages depend on it now (diff)
downloadgentoo-2-c93a22613bea5d95eb1ea2568543af56292c831c.tar.gz
gentoo-2-c93a22613bea5d95eb1ea2568543af56292c831c.tar.bz2
gentoo-2-c93a22613bea5d95eb1ea2568543af56292c831c.zip
Fixed src_test, #277097
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shunit2/ChangeLog6
-rw-r--r--dev-util/shunit2/files/test.patch14
-rw-r--r--dev-util/shunit2/shunit2-2.1.4.ebuild19
-rw-r--r--dev-util/shunit2/shunit2-2.1.5.ebuild6
4 files changed, 34 insertions, 11 deletions
diff --git a/dev-util/shunit2/ChangeLog b/dev-util/shunit2/ChangeLog
index bf1eb4b54a6a..36a6967e14cc 100644
--- a/dev-util/shunit2/ChangeLog
+++ b/dev-util/shunit2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/shunit2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.3 2010/06/26 07:40:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.4 2010/06/26 11:02:00 jlec Exp $
+
+ 26 Jun 2010; Justin Lecher <jlec@gentoo.org> shunit2-2.1.4.ebuild,
+ shunit2-2.1.5.ebuild, +files/test.patch:
+ Fixed src_test, #277097
*shunit2-2.1.5 (26 Jun 2010)
diff --git a/dev-util/shunit2/files/test.patch b/dev-util/shunit2/files/test.patch
new file mode 100644
index 000000000000..a2a70289e94c
--- /dev/null
+++ b/dev-util/shunit2/files/test.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index 080ba0c..629781e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,8 @@ docs-docbook-prep:
+ $(BIN_DIR)/docbookPrep.sh "$(DOCBOOK_SHARE_DIR)"; \
+ fi
+
+-test: @echo "executing $(PROG) unit tests"
++test:
++ @echo "executing $(PROG) unit tests"
+ ( cd $(TEST_SRC_DIR); ./shunit2_test.sh )
+
+ dist: dist-clean build docs
diff --git a/dev-util/shunit2/shunit2-2.1.4.ebuild b/dev-util/shunit2/shunit2-2.1.4.ebuild
index ef91661ddcc3..d263f95b310f 100644
--- a/dev-util/shunit2/shunit2-2.1.4.ebuild
+++ b/dev-util/shunit2/shunit2-2.1.4.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.4.ebuild,v 1.2 2008/10/25 13:15:40 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.4.ebuild,v 1.3 2010/06/26 11:02:00 jlec Exp $
-DESCRIPTION="shUnit2 is a unit-test framework for Bourne-based shell scripts."
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts."
HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
@@ -16,16 +20,14 @@ DEPEND="${RDEPEND}
dev-lang/perl
net-misc/curl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2
+src_prepare() {
+ epatch "${FILESDIR}"/test.patch
+ sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2 || die
}
src_compile() {
local myconf="build"
use doc && myconf="${myconf} docs"
- use test && myconf="${myconf} test"
emake ${myconf} || die
}
@@ -39,6 +41,7 @@ src_install() {
fi
dodoc doc/*.txt || die
+ dohtml doc/*.html || die
insinto /usr/share/${PN}
doins build/* || die
diff --git a/dev-util/shunit2/shunit2-2.1.5.ebuild b/dev-util/shunit2/shunit2-2.1.5.ebuild
index bacef12cc8c8..4b301bb9f92e 100644
--- a/dev-util/shunit2/shunit2-2.1.5.ebuild
+++ b/dev-util/shunit2/shunit2-2.1.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.5.ebuild,v 1.1 2010/06/26 07:40:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.5.ebuild,v 1.2 2010/06/26 11:02:00 jlec Exp $
EAPI="3"
+inherit eutils
+
DESCRIPTION="Unit-test framework for Bourne-based shell scripts."
HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
@@ -19,13 +21,13 @@ DEPEND="${RDEPEND}
net-misc/curl"
src_prepare() {
+ epatch "${FILESDIR}"/test.patch
sed -i -e '/^__SHUNIT_SHELL_FLAGS/s:u::' src/shell/shunit2 || die
}
src_compile() {
local myconf="build"
use doc && myconf="${myconf} docs"
- use test && myconf="${myconf} test"
emake ${myconf} || die
}