summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-12-05 10:55:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-12-05 10:55:24 +0000
commitc932d3a5cde7d5ff3421535f92dad0ad9f99e199 (patch)
tree13090dc3a0732cc753de1a18431fdd08d741bb05 /dev-util
parentAdd kodkodi. Required for sci-mathematics/isabelle nitpick couter-example che... (diff)
downloadgentoo-2-c932d3a5cde7d5ff3421535f92dad0ad9f99e199.tar.gz
gentoo-2-c932d3a5cde7d5ff3421535f92dad0ad9f99e199.tar.bz2
gentoo-2-c932d3a5cde7d5ff3421535f92dad0ad9f99e199.zip
Version bump to latest.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/osc/ChangeLog7
-rw-r--r--dev-util/osc/osc-0.137.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-util/osc/ChangeLog b/dev-util/osc/ChangeLog
index c87ac9a04a47..2ab535e662cc 100644
--- a/dev-util/osc/ChangeLog
+++ b/dev-util/osc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/osc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.10 2012/11/19 13:33:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/ChangeLog,v 1.11 2012/12/05 10:55:24 scarabeus Exp $
+
+*osc-0.137.0 (05 Dec 2012)
+
+ 05 Dec 2012; Tomáš Chvátal <scarabeus@gentoo.org> +osc-0.137.0.ebuild:
+ Version bump to latest.
19 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> osc-0.136.0.ebuild,
osc-9999.ebuild:
diff --git a/dev-util/osc/osc-0.137.0.ebuild b/dev-util/osc/osc-0.137.0.ebuild
new file mode 100644
index 000000000000..8e20b476a2fe
--- /dev/null
+++ b/dev-util/osc/osc-0.137.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/osc/osc-0.137.0.ebuild,v 1.1 2012/12/05 10:55:24 scarabeus Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/openSUSE/osc.git"
+PYTHON_DEPEND="2:2.6"
+
+if [[ "${PV}" == "9999" ]]; then
+ EXTRA_ECLASS="git-2"
+else
+ OBS_PROJECT="openSUSE:Tools"
+ EXTRA_ECLASS="obs-download"
+fi
+
+inherit distutils ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Command line tool for Open Build Service"
+HOMEPAGE="http://en.opensuse.org/openSUSE:OSC"
+
+[[ "${PV}" == "9999" ]] || SRC_URI="${OBS_URI}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ "${PV}" == "9999" ]] || \
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/urlgrabber
+ dev-python/pyxml
+ dev-python/elementtree
+ app-arch/rpm[python]
+ dev-python/m2crypto
+"
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-util/obs-service-meta
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ dosym osc-wrapper.py /usr/bin/osc
+ keepdir /usr/lib/osc/source_validators
+ cd "${ED}"/usr/
+ find . -type f -exec sed -i 's|/usr/bin/build|/usr/bin/suse-build|g' {} +
+ find . -type f -exec sed -i 's|/usr/lib/build|/usr/share/suse-build|g' {} +
+ rm -f "${ED}"/usr/share/doc/${PN}*/TODO*
+}