summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-07-28 14:02:24 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-07-28 14:02:24 +0000
commitc5c7d11d8b58b53c6a5356d8719b9f90ce1c58c4 (patch)
tree11d67f79fe3856d94ff2f23fb3a7fed67fcc87c4 /dev-util
parentfixed crash in enca_set_threshold, thanks to Linubie and Franz Fellner, wrt t... (diff)
downloadgentoo-2-c5c7d11d8b58b53c6a5356d8719b9f90ce1c58c4.tar.gz
gentoo-2-c5c7d11d8b58b53c6a5356d8719b9f90ce1c58c4.tar.bz2
gentoo-2-c5c7d11d8b58b53c6a5356d8719b9f90ce1c58c4.zip
Fixed buld breakage against ghc-7.4 (bug #428226 by Chris Reffett)
(Portage version: 2.2.0_alpha120_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bustle/ChangeLog7
-rw-r--r--dev-util/bustle/bustle-0.2.3.ebuild7
-rw-r--r--dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch89
3 files changed, 98 insertions, 5 deletions
diff --git a/dev-util/bustle/ChangeLog b/dev-util/bustle/ChangeLog
index 01028c84c9af..2dbba7af9483 100644
--- a/dev-util/bustle/ChangeLog
+++ b/dev-util/bustle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/bustle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.8 2012/03/10 16:04:21 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.9 2012/07/28 14:02:24 slyfox Exp $
+
+ 28 Jul 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/bustle-0.2.3-ghc-7.4.patch, bustle-0.2.3.ebuild:
+ Fixed buld breakage against ghc-7.4 (bug #428226 by Chris Reffett)
10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/bustle-0.4.0-ghc-7.4.patch, bustle-0.4.0.ebuild:
@@ -40,4 +44,3 @@
+bustle-0.2.3.ebuild, +metadata.xml:
Initial version. Draw pretty sequence diagrams of D-Bus traffic. Ebuild
provided by Dennis Schridde bug #353906.
-
diff --git a/dev-util/bustle/bustle-0.2.3.ebuild b/dev-util/bustle/bustle-0.2.3.ebuild
index 9fd8dc5b8e64..3ae6e882cd52 100644
--- a/dev-util/bustle/bustle-0.2.3.ebuild
+++ b/dev-util/bustle/bustle-0.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.2.3.ebuild,v 1.4 2011/06/21 11:02:06 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.2.3.ebuild,v 1.5 2012/07/28 14:02:24 slyfox Exp $
# ebuild generated by hackport 0.2.13
@@ -18,7 +18,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-PATCHES=("${FILESDIR}/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch")
+PATCHES=("${FILESDIR}/0001-bustle-dbus-monitor-fix-linking-order-libs-go-after-.patch"
+ "${FILESDIR}"/${P}-ghc-7.4.patch)
RDEPEND="sys-apps/dbus
x11-libs/cairo
diff --git a/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch b/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch
new file mode 100644
index 000000000000..3c4544e32b7e
--- /dev/null
+++ b/dev-util/bustle/files/bustle-0.2.3-ghc-7.4.patch
@@ -0,0 +1,89 @@
+Starting with ghc-7.4 base and haskell98 are incompatible:
+
+ Ambiguous module name `Prelude':
+ it was found in multiple packages: base haskell98-2.0.0.1
+
+Gentoo-bug: https://bugs.gentoo.org/428226
+Reported-by: Chris Reffett
+diff --git a/Bustle/Noninteractive.hs b/Bustle/Noninteractive.hs
+index 2aa1e05..4a4d9b0 100644
+--- a/Bustle/Noninteractive.hs
++++ b/Bustle/Noninteractive.hs
+@@ -3,7 +3,8 @@ where
+
+ import Prelude hiding (log)
+
+-import System
++import System.Environment (getArgs)
++import System.Exit (exitFailure)
+ import System.IO (hPutStrLn, stderr)
+
+ import Bustle.Parser (readLog)
+diff --git a/Bustle/Stats.hs b/Bustle/Stats.hs
+index da374a5..939cafd 100644
+--- a/Bustle/Stats.hs
++++ b/Bustle/Stats.hs
+@@ -36,7 +36,7 @@ frequencies = reverse
+ where alt Nothing = Just 1
+ alt (Just n) = Just (n + 1)
+
+-mean :: Fractional a => [a] -> a
++mean :: (Eq a, Fractional a) => [a] -> a
+ mean = acc 0 0
+ where acc 0 _ [] = error "mean of empty list"
+ acc n t [] = t / n
+diff --git a/bustle-dot.hs b/bustle-dot.hs
+index aa7c45e..77d6f18 100644
+--- a/bustle-dot.hs
++++ b/bustle-dot.hs
+@@ -3,7 +3,9 @@ import Prelude hiding (log)
+ import Control.Monad
+ import Data.List
+ import Data.Maybe
+-import System
++import System.IO
++import System.Environment
++import System.Exit
+
+ import Bustle.Parser (readLog)
+ import Bustle.Types
+diff --git a/bustle.cabal b/bustle.cabal
+index 7ad7412..0a49ca1 100644
+--- a/bustle.cabal
++++ b/bustle.cabal
+@@ -27,11 +27,11 @@ Executable bustle
+ if flag(PostCabalizedGtk2HS)
+ -- Since gtk2hs 0.11, pango is a separate package, and its module names
+ -- have changed.
+- Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+ gtk > 0.11, glade, pango, glib, cairo
+ else
+- Build-Depends: haskell98, mtl, base >= 4 && < 5, containers, parsec,
++ Build-Depends: mtl, base >= 4 && < 5, containers, parsec,
+ filepath, process,
+ gtk > 0.10 && < 0.11, glade, pango, glib, cairo
+
+@@ -39,18 +39,18 @@ Executable bustle-count
+ Main-is: bustle-count.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-time
+ Main-is: bustle-time.hs
+ Other-modules: Bustle.Parser, Bustle.Stats, Bustle.Types,
+ Bustle.Noninteractive
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind
+
+ Executable bustle-dot
+ Main-is: bustle-dot.hs
+ Other-modules: Bustle.Parser, Bustle.Types
+- Build-Depends: haskell98, base >= 4 && < 5, containers, parsec
++ Build-Depends: base >= 4 && < 5, containers, parsec
+ Ghc-options: -Wall -fno-warn-unused-imports -fno-warn-unused-do-bind