summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-11-10 01:40:41 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-11-10 01:40:41 +0000
commitc2ea93add939bdc6a29ffaba52fcc194bc025161 (patch)
tree205bd8936f5ae04c1f5869cbf079fa536c5a1b81 /dev-util
parentnet-libs/libnet: 1.1.5: Fix broken SRC_URI (diff)
downloadgentoo-2-c2ea93add939bdc6a29ffaba52fcc194bc025161.tar.gz
gentoo-2-c2ea93add939bdc6a29ffaba52fcc194bc025161.tar.bz2
gentoo-2-c2ea93add939bdc6a29ffaba52fcc194bc025161.zip
Version bump, bug #342189
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog9
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.0-local-labels.patch24
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.0-non-exec-stack.patch137
-rw-r--r--dev-util/valgrind/valgrind-3.6.0.ebuild90
4 files changed, 259 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index c65d09830e6d..22c4bb90946e 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.117 2010/10/28 17:39:53 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.118 2010/11/10 01:40:41 blueness Exp $
+
+*valgrind-3.6.0 (10 Nov 2010)
+
+ 10 Nov 2010; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.0.ebuild, +files/valgrind-3.6.0-local-labels.patch,
+ +files/valgrind-3.6.0-non-exec-stack.patch:
+ Version bump, bug #342189
*valgrind-3.5.0-r1 (28 Oct 2010)
diff --git a/dev-util/valgrind/files/valgrind-3.6.0-local-labels.patch b/dev-util/valgrind/files/valgrind-3.6.0-local-labels.patch
new file mode 100644
index 000000000000..68e682255611
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.0-local-labels.patch
@@ -0,0 +1,24 @@
+--- coregrind/m_libcassert.c 2010-10-21 04:19:45.000000000 +0800
++++ coregrind/m_libcassert.c 2010-10-24 20:23:17.800001876 +0800
+@@ -81,8 +81,8 @@
+ { UInt cia, r1, lr; \
+ __asm__ __volatile__( \
+ "mflr 0;" /* r0 = lr */ \
+- "bl m_libcassert_get_ip;" /* lr = pc */ \
+- "m_libcassert_get_ip:\n" \
++ "bl 0f;" /* lr = pc */ \
++ "0:\n" \
+ "mflr %0;" /* %0 = pc */ \
+ "mtlr 0;" /* restore lr */ \
+ "mr %1,1;" /* %1 = r1 */ \
+@@ -100,8 +100,8 @@
+ { ULong cia, r1, lr; \
+ __asm__ __volatile__( \
+ "mflr 0;" /* r0 = lr */ \
+- "bl .m_libcassert_get_ip;" /* lr = pc */ \
+- ".m_libcassert_get_ip:\n" \
++ "bl 0f;" /* lr = pc */ \
++ "0:\n" \
+ "mflr %0;" /* %0 = pc */ \
+ "mtlr 0;" /* restore lr */ \
+ "mr %1,1;" /* %1 = r1 */ \
diff --git a/dev-util/valgrind/files/valgrind-3.6.0-non-exec-stack.patch b/dev-util/valgrind/files/valgrind-3.6.0-non-exec-stack.patch
new file mode 100644
index 000000000000..dc9969484a12
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.0-non-exec-stack.patch
@@ -0,0 +1,137 @@
+diff -ruN valgrind-3.6.0.orig/coregrind/Makefile.am valgrind-3.6.0/coregrind/Makefile.am
+--- valgrind-3.6.0.orig/coregrind/Makefile.am 2010-10-21 04:19:45.000000000 +0800
++++ valgrind-3.6.0/coregrind/Makefile.am 2010-10-24 20:39:42.655001876 +0800
+@@ -285,23 +285,12 @@
+ m_demangle/demangle.c \
+ m_demangle/dyn-string.c \
+ m_demangle/safe-ctype.c \
+- m_dispatch/dispatch-x86-linux.S \
+- m_dispatch/dispatch-amd64-linux.S \
+- m_dispatch/dispatch-ppc32-linux.S \
+- m_dispatch/dispatch-ppc64-linux.S \
+- m_dispatch/dispatch-arm-linux.S \
+- m_dispatch/dispatch-ppc32-aix5.S \
+- m_dispatch/dispatch-ppc64-aix5.S \
+- m_dispatch/dispatch-x86-darwin.S \
+- m_dispatch/dispatch-amd64-darwin.S \
+ m_initimg/initimg-linux.c \
+ m_initimg/initimg-aix5.c \
+ m_initimg/initimg-darwin.c \
+ m_initimg/initimg-pathscan.c \
+ m_mach/mach_basics.c \
+ m_mach/mach_msg.c \
+- m_mach/mach_traps-x86-darwin.S \
+- m_mach/mach_traps-amd64-darwin.S \
+ m_replacemalloc/replacemalloc_core.c \
+ m_scheduler/scheduler.c \
+ m_scheduler/sema.c \
+@@ -314,15 +303,6 @@
+ m_sigframe/sigframe-ppc64-aix5.c \
+ m_sigframe/sigframe-x86-darwin.c \
+ m_sigframe/sigframe-amd64-darwin.c \
+- m_syswrap/syscall-x86-linux.S \
+- m_syswrap/syscall-amd64-linux.S \
+- m_syswrap/syscall-ppc32-linux.S \
+- m_syswrap/syscall-ppc64-linux.S \
+- m_syswrap/syscall-arm-linux.S \
+- m_syswrap/syscall-ppc32-aix5.S \
+- m_syswrap/syscall-ppc64-aix5.S \
+- m_syswrap/syscall-x86-darwin.S \
+- m_syswrap/syscall-amd64-darwin.S \
+ m_syswrap/syswrap-main.c \
+ m_syswrap/syswrap-generic.c \
+ m_syswrap/syswrap-linux.c \
+@@ -343,6 +323,24 @@
+ m_ume/main.c \
+ m_ume/script.c
+
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S \
++ m_syswrap/syscall-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S
++
++if VGCONF_HAVE_PLATFORM_SEC
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S \
++ m_syswrap/syscall-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S
++endif
++
++if VGCONF_OS_IS_DARWIN
++COREGRIND_SOURCES_COMMON += \
++ m_start-@VGCONF_ARCH_PRI@-darwin.S \
++ m_start-@VGCONF_ARCH_SEC@-darwin.S \
++ m_mach/mach_traps-@VGCONF_ARCH_PRI@-darwin.S \
++ m_mach/mach_traps-@VGCONF_ARCH_SEC@-darwin.S
++endif
++
+ libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
+ $(COREGRIND_SOURCES_COMMON)
+ nodist_libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
+diff -ruN valgrind-3.6.0.orig/coregrind/m_dispatch/dispatch-amd64-linux.S valgrind-3.6.0/coregrind/m_dispatch/dispatch-amd64-linux.S
+--- valgrind-3.6.0.orig/coregrind/m_dispatch/dispatch-amd64-linux.S 2010-10-21 04:19:39.000000000 +0800
++++ valgrind-3.6.0/coregrind/m_dispatch/dispatch-amd64-linux.S 2010-10-24 20:39:41.462001899 +0800
+@@ -338,11 +338,11 @@
+ ret
+ .size VG_(run_a_noredir_translation), .-VG_(run_a_noredir_translation)
+
++#endif // defined(VGP_amd64_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_amd64_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -ruN valgrind-3.6.0.orig/coregrind/m_dispatch/dispatch-x86-linux.S valgrind-3.6.0/coregrind/m_dispatch/dispatch-x86-linux.S
+--- valgrind-3.6.0.orig/coregrind/m_dispatch/dispatch-x86-linux.S 2010-10-21 04:19:39.000000000 +0800
++++ valgrind-3.6.0/coregrind/m_dispatch/dispatch-x86-linux.S 2010-10-24 20:39:41.022001883 +0800
+@@ -304,12 +304,11 @@
+ ret
+ .size VG_(run_a_noredir_translation), .-VG_(run_a_noredir_translation)
+
++#endif // defined(VGP_x86_linux)
+
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_x86_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -ruN valgrind-3.6.0.orig/coregrind/m_syswrap/syscall-amd64-linux.S valgrind-3.6.0/coregrind/m_syswrap/syscall-amd64-linux.S
+--- valgrind-3.6.0.orig/coregrind/m_syswrap/syscall-amd64-linux.S 2010-10-21 04:19:41.000000000 +0800
++++ valgrind-3.6.0/coregrind/m_syswrap/syscall-amd64-linux.S 2010-10-24 20:39:40.576001879 +0800
+@@ -205,11 +205,11 @@
+ ML_(blksys_finished): .quad 5b
+ .previous
+
++#endif // defined(VGP_amd64_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_amd64_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -ruN valgrind-3.6.0.orig/coregrind/m_syswrap/syscall-x86-linux.S valgrind-3.6.0/coregrind/m_syswrap/syscall-x86-linux.S
+--- valgrind-3.6.0.orig/coregrind/m_syswrap/syscall-x86-linux.S 2010-10-21 04:19:41.000000000 +0800
++++ valgrind-3.6.0/coregrind/m_syswrap/syscall-x86-linux.S 2010-10-24 20:39:40.152001876 +0800
+@@ -164,12 +164,12 @@
+ ML_(blksys_committed): .long 4b
+ ML_(blksys_finished): .long 5b
+ .previous
++
++#endif // defined(VGP_x86_linux)
+
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_x86_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
diff --git a/dev-util/valgrind/valgrind-3.6.0.ebuild b/dev-util/valgrind/valgrind-3.6.0.ebuild
new file mode 100644
index 000000000000..b2be0c0fa61b
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.0.ebuild,v 1.1 2010/11/10 01:40:41 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}/valgrind-3.6.0-local-labels.patch"
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}/valgrind-3.6.0-non-exec-stack.patch"
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}/valgrind-3.4.1-glibc-2.10.1.patch"
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ if use ppc || use ppc64 || use amd64 ; then
+ ewarn "Valgrind will not work on ppc, ppc64 or amd64 if glibc does not have"
+ ewarn "debug symbols (see https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=274771)."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf and"
+ ewarn "remerge glibc."
+ fi
+}