summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-10 23:25:42 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-10 23:25:42 +0000
commitbea2646edf90b439cc1e0d4a71df8885f32a8330 (patch)
tree7d961a7b7668468d4186be4ae35f18f644152314 /dev-util
parentMark amd64/x86 stable. (diff)
downloadgentoo-2-bea2646edf90b439cc1e0d4a71df8885f32a8330.tar.gz
gentoo-2-bea2646edf90b439cc1e0d4a71df8885f32a8330.tar.bz2
gentoo-2-bea2646edf90b439cc1e0d4a71df8885f32a8330.zip
Version bump.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw-runtime/ChangeLog8
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.15.2.ebuild81
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-util/mingw-runtime/ChangeLog b/dev-util/mingw-runtime/ChangeLog
index 930e7d89c69a..978f5fb9ffcf 100644
--- a/dev-util/mingw-runtime/ChangeLog
+++ b/dev-util/mingw-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/mingw-runtime
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.15 2009/01/10 23:25:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.16 2009/01/10 23:25:42 vapier Exp $
+
+*mingw-runtime-3.15.2 (10 Jan 2009)
+
+ 10 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +mingw-runtime-3.15.2.ebuild:
+ Version bump.
10 Jan 2009; Mike Frysinger <vapier@gentoo.org> mingw-runtime-3.15.1.ebuild:
Mark amd64/x86 stable.
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.15.2.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.15.2.ebuild
new file mode 100644
index 000000000000..82db8ce54910
--- /dev/null
+++ b/dev-util/mingw-runtime/mingw-runtime-3.15.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.15.2.ebuild,v 1.1 2009/01/10 23:25:42 vapier Exp $
+
+# This version does not work as the configure script expects the installed
+# cross-compiler to be able to link binaries ... except we haven't provided
+# any of the crt objects yet so it is impossible to link binaries.
+# Older mingw-runtime packages hacked around the issue, but this version seems
+# to have dropped said hack thus breaking the package.
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit eutils flag-o-matic
+
+MY_P="mingwrt-${PV}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
+ $(find -name configure) || die
+ epatch "${FILESDIR}"/${PN}-3.12-DESTDIR.patch
+}
+
+src_compile() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ econf --host=${CTARGET} || die
+ emake || die
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/* || die
+ else
+ local insdir
+ is_crosscompile \
+ && insdir=${D}/usr/${CTARGET} \
+ || insdir=${D}
+ emake install DESTDIR="${insdir}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${insdir}"/usr/doc
+ dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
+ fi
+ is_crosscompile && dosym usr /usr/${CTARGET}/mingw
+}