summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-03-06 06:59:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-03-06 06:59:03 +0000
commitb4e421f8348aca2db9242ab7911745e967ed9d6e (patch)
tree6d1b303a62a4c00bcdee13ff8ac973b81406dbb2 /dev-util
parentVersion bump (diff)
downloadgentoo-2-b4e421f8348aca2db9242ab7911745e967ed9d6e.tar.gz
gentoo-2-b4e421f8348aca2db9242ab7911745e967ed9d6e.tar.bz2
gentoo-2-b4e421f8348aca2db9242ab7911745e967ed9d6e.zip
Version bump per bug #261241. Also fix bugs #256964, #238586. EAPI2 now in use.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog9
-rw-r--r--dev-util/git/files/20090305-git-1.6.2-noperl.patch370
-rw-r--r--dev-util/git/git-1.6.2.ebuild304
3 files changed, 682 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 4c040aa9ace3..a4ba4a28259e 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/git
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.320 2009/02/11 22:44:38 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.321 2009/03/06 06:59:03 robbat2 Exp $
+
+*git-1.6.2 (06 Mar 2009)
+
+ 06 Mar 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +files/20090305-git-1.6.2-noperl.patch, +git-1.6.2.ebuild:
+ Version bump per bug #261241. Also fix bugs #256964, #238586. EAPI2 now in
+ use.
*git-1.6.1.3 (11 Feb 2009)
diff --git a/dev-util/git/files/20090305-git-1.6.2-noperl.patch b/dev-util/git/files/20090305-git-1.6.2-noperl.patch
new file mode 100644
index 000000000000..b34e7cea33ae
--- /dev/null
+++ b/dev-util/git/files/20090305-git-1.6.2-noperl.patch
@@ -0,0 +1,370 @@
+Implement 95% of the NO_PERL functionality, to build Git without any Perl
+support, because some Gentoo users want a Git without any Perl whatesoever
+(Gentoo bug #214168).
+
+Remaining bits are doing configure.ac as well as git-remote usage in:
+t5502-quickfetch.sh
+t5512-ls-remote.sh
+t5520-pull.sh
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+Updated-by: Bernd Lommerzheim <bernd@lommerzheim.com>
+Bugzilla-URL: http://bugs.gentoo.org/show_bug.cgi?id=214168
+Notes: Ported from 20080423-git-1.5.5.1-noperl.patch
+Notes: Ported from 20080322-git-1.5.4.5-noperl.patch
+Notes: Ported from 20080528-git-1.5.6.1-noperl.patch
+Notes: Ported from 20080626-git-1.5.6.1-noperl.patch and 20081123-git-1.6.0.4-noperl-cvsserver.patch
+Notes: Ported from 20090126-git-1.6.1.1-noperl.patch
+
+diff --git a/Makefile b/Makefile
+index 0675c43..0adb2b5 100644
+--- a/Makefile
++++ b/Makefile
+@@ -139,6 +139,8 @@ all::
+ # Define NO_PERL_MAKEMAKER if you cannot use Makefiles generated by perl's
+ # MakeMaker (e.g. using ActiveState under Cygwin).
+ #
++# Define NO_PERL if you do not want Perl scripts at all.
++#
+ # Define NO_TCLTK if you do not want Tcl/Tk GUI.
+ #
+ # The TCL_PATH variable governs the location of the Tcl interpreter
+@@ -277,6 +279,8 @@ SCRIPT_SH += git-stash.sh
+ SCRIPT_SH += git-submodule.sh
+ SCRIPT_SH += git-web--browse.sh
+
++SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH))
++ifndef NO_PERL
+ SCRIPT_PERL += git-add--interactive.perl
+ SCRIPT_PERL += git-archimport.perl
+ SCRIPT_PERL += git-cvsexportcommit.perl
+@@ -285,10 +289,11 @@ SCRIPT_PERL += git-cvsserver.perl
+ SCRIPT_PERL += git-relink.perl
+ SCRIPT_PERL += git-send-email.perl
+ SCRIPT_PERL += git-svn.perl
+-
+-SCRIPTS = $(patsubst %.sh,%,$(SCRIPT_SH)) \
+- $(patsubst %.perl,%,$(SCRIPT_PERL)) \
+- git-instaweb
++SCRIPTS += $(patsubst %.perl,%,$(SCRIPT_PERL)) \
++ git-instaweb
++else
++SCRIPT_PERL =
++endif
+
+ # Empty...
+ EXTRA_PROGRAMS =
+@@ -335,7 +340,10 @@ BUILT_INS += git-whatchanged$X
+ ALL_PROGRAMS = $(PROGRAMS) $(SCRIPTS)
+
+ # what 'all' will build but not install in gitexecdir
+-OTHER_PROGRAMS = git$X gitweb/gitweb.cgi
++OTHER_PROGRAMS = git$X
++ifndef NO_PERL
++OTHER_PROGRAMS += gitweb/gitweb.cgi
++endif
+
+ # Set paths to tools early so that they can be used for version tests.
+ ifndef SHELL_PATH
+@@ -868,6 +876,10 @@ else
+ endif
+ endif
+
++ifdef NO_PERL
++ BASIC_CFLAGS += -DNO_PERL
++endif
++
+ ifdef ZLIB_PATH
+ BASIC_CFLAGS += -I$(ZLIB_PATH)/include
+ EXTLIBS += -L$(ZLIB_PATH)/$(lib) $(CC_LD_DYNPATH)$(ZLIB_PATH)/$(lib)
+@@ -1067,6 +1079,11 @@ endif
+ ifeq ($(TCLTK_PATH),)
+ NO_TCLTK=NoThanks
+ endif
++ifeq ($(PERL_PATH),)
++NO_PERL=NoThanks
++export NO_PERL
++export NO_PERL_MAKEMAKER
++endif
+
+ QUIET_SUBDIR0 = +$(MAKE) -C # space to separate -C and subdir
+ QUIET_SUBDIR1 =
+@@ -1142,7 +1159,9 @@ ifndef NO_TCLTK
+ $(QUIET_SUBDIR0)git-gui $(QUIET_SUBDIR1) gitexecdir='$(gitexec_instdir_SQ)' all
+ $(QUIET_SUBDIR0)gitk-git $(QUIET_SUBDIR1) all
+ endif
++ifndef NO_PERL
+ $(QUIET_SUBDIR0)perl $(QUIET_SUBDIR1) PERL_PATH='$(PERL_PATH_SQ)' prefix='$(prefix_SQ)' all
++endif
+ $(QUIET_SUBDIR0)templates $(QUIET_SUBDIR1)
+
+ please_set_SHELL_PATH_to_a_more_modern_shell:
+@@ -1189,6 +1208,7 @@ $(patsubst %.sh,%,$(SCRIPT_SH)) : % : %.sh
+ chmod +x $@+ && \
+ mv $@+ $@
+
++ifndef NO_PERL
+ $(patsubst %.perl,%,$(SCRIPT_PERL)): perl/perl.mak
+
+ perl/perl.mak: GIT-CFLAGS perl/Makefile perl/Makefile.PL
+@@ -1248,6 +1268,7 @@ git-instaweb: git-instaweb.sh gitweb/gitweb.cgi gitweb/gitweb.css
+ $@.sh > $@+ && \
+ chmod +x $@+ && \
+ mv $@+ $@
++endif # NO_PERL
+
+ configure: configure.ac
+ $(QUIET_GEN)$(RM) $@ $<+ && \
+@@ -1455,9 +1476,12 @@ install: all
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+ $(INSTALL) $(ALL_PROGRAMS) '$(DESTDIR_SQ)$(gitexec_instdir_SQ)'
+- $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
++ $(INSTALL) git$X git-upload-pack$X git-receive-pack$X git-upload-archive$X git-shell$X '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(MAKE) -C templates DESTDIR='$(DESTDIR_SQ)' install
++ifndef NO_PERL
+ $(MAKE) -C perl prefix='$(prefix_SQ)' DESTDIR='$(DESTDIR_SQ)' install
++ $(INSTALL) git-cvsserver '$(DESTDIR_SQ)$(bindir_SQ)'
++endif
+ ifndef NO_TCLTK
+ $(MAKE) -C gitk-git install
+ $(MAKE) -C git-gui gitexecdir='$(gitexec_instdir_SQ)' install
+@@ -1565,9 +1589,11 @@ clean:
+ $(RM) -r $(GIT_TARNAME) .doc-tmp-dir
+ $(RM) $(GIT_TARNAME).tar.gz git-core_$(GIT_VERSION)-*.tar.gz
+ $(RM) $(htmldocs).tar.gz $(manpages).tar.gz
+- $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C Documentation/ clean
++ifndef NO_PERL
++ $(RM) gitweb/gitweb.cgi
+ $(MAKE) -C perl clean
++endif
+ $(MAKE) -C templates/ clean
+ $(MAKE) -C t/ clean
+ ifndef NO_TCLTK
+diff --git a/builtin-add.c b/builtin-add.c
+index 08443f2..01e18a1 100644
+--- a/builtin-add.c
++++ b/builtin-add.c
+@@ -15,7 +15,9 @@ static const char * const builtin_add_usage[] = {
+ "git add [options] [--] <filepattern>...",
+ NULL
+ };
++#ifndef NO_PERL
+ static int patch_interactive, add_interactive;
++#endif
+ static int take_worktree_changes;
+
+ static void fill_pathspec_matches(const char **pathspec, char *seen, int specs)
+@@ -158,6 +160,7 @@ static const char **validate_pathspec(int argc, const char **argv, const char *p
+ return pathspec;
+ }
+
++#ifndef NO_PERL
+ int interactive_add(int argc, const char **argv, const char *prefix)
+ {
+ int status, ac;
+@@ -186,6 +189,7 @@ int interactive_add(int argc, const char **argv, const char *prefix)
+ free(args);
+ return status;
+ }
++#endif
+
+ static struct lock_file lock_file;
+
+@@ -199,8 +203,10 @@ static struct option builtin_add_options[] = {
+ OPT__DRY_RUN(&show_only),
+ OPT__VERBOSE(&verbose),
+ OPT_GROUP(""),
++#ifndef NO_PERL
+ OPT_BOOLEAN('i', "interactive", &add_interactive, "interactive picking"),
+ OPT_BOOLEAN('p', "patch", &patch_interactive, "interactive patching"),
++#endif
+ OPT_BOOLEAN('f', "force", &ignored_too, "allow adding otherwise ignored files"),
+ OPT_BOOLEAN('u', "update", &take_worktree_changes, "update tracked files"),
+ OPT_BOOLEAN('N', "intent-to-add", &intent_to_add, "record only the fact that the path will be added later"),
+@@ -252,10 +258,12 @@ int cmd_add(int argc, const char **argv, const char *prefix)
+
+ argc = parse_options(argc, argv, builtin_add_options,
+ builtin_add_usage, 0);
++#ifndef NO_PERL
+ if (patch_interactive)
+ add_interactive = 1;
+ if (add_interactive)
+ exit(interactive_add(argc, argv, prefix));
++#endif
+
+ git_config(add_config, NULL);
+
+diff --git a/builtin-commit.c b/builtin-commit.c
+index 46e649c..944f3ac 100644
+--- a/builtin-commit.c
++++ b/builtin-commit.c
+@@ -100,7 +100,9 @@ static struct option builtin_commit_options[] = {
+ OPT_GROUP("Commit contents options"),
+ OPT_BOOLEAN('a', "all", &all, "commit all changed files"),
+ OPT_BOOLEAN('i', "include", &also, "add specified files to index for commit"),
++#ifndef NO_PERL
+ OPT_BOOLEAN(0, "interactive", &interactive, "interactively add files"),
++#endif
+ OPT_BOOLEAN('o', "only", &only, "commit only specified files"),
+ OPT_BOOLEAN('n', "no-verify", &no_verify, "bypass pre-commit hook"),
+ OPT_BOOLEAN(0, "amend", &amend, "amend previous commit"),
+@@ -223,6 +225,7 @@ static char *prepare_index(int argc, const char **argv, const char *prefix)
+ struct string_list partial;
+ const char **pathspec = NULL;
+
++#ifndef NO_PERL
+ if (interactive) {
+ interactive_add(argc, argv, prefix);
+ if (read_cache_preload(NULL) < 0)
+@@ -230,6 +233,7 @@ static char *prepare_index(int argc, const char **argv, const char *prefix)
+ commit_style = COMMIT_AS_IS;
+ return get_index_file();
+ }
++#endif
+
+ if (*argv)
+ pathspec = get_pathspec(prefix, argv);
+diff --git a/t/lib-git-svn.sh b/t/lib-git-svn.sh
+index 67c431d..83a5535 100644
+--- a/t/lib-git-svn.sh
++++ b/t/lib-git-svn.sh
+@@ -9,6 +9,12 @@ then
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-svn tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ GIT_DIR=$PWD/.git
+ GIT_SVN_DIR=$GIT_DIR/svn/git-svn
+diff --git a/t/t5505-remote.sh b/t/t5505-remote.sh
+index eb63718..e3bcf20 100755
+--- a/t/t5505-remote.sh
++++ b/t/t5505-remote.sh
+@@ -3,6 +3,12 @@
+ test_description='git remote porcelain-ish'
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ setup_repository () {
+ mkdir "$1" && (
+diff --git a/t/t7501-commit.sh b/t/t7501-commit.sh
+index b4e2b4d..2e74ce5 100755
+--- a/t/t7501-commit.sh
++++ b/t/t7501-commit.sh
+@@ -38,7 +38,7 @@ test_expect_success \
+ "echo King of the bongo >file &&
+ test_must_fail git commit -m foo -a file"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "using paths with --interactive" \
+ "echo bong-o-bong >file &&
+ ! (echo 7 | git commit -m foo --interactive file)"
+@@ -119,7 +119,7 @@ test_expect_success \
+ "echo 'gak' >file && \
+ git commit -m 'author' --author 'Rubber Duck <rduck@convoy.org>' -a"
+
+-test_expect_success \
++[ -z "$NO_PERL" ] && test_expect_success \
+ "interactive add" \
+ "echo 7 | git commit --interactive | grep 'What now'"
+
+diff --git a/t/t9001-send-email.sh b/t/t9001-send-email.sh
+index cb3d183..1d5355d 100755
+--- a/t/t9001-send-email.sh
++++ b/t/t9001-send-email.sh
+@@ -2,6 +2,12 @@
+
+ test_description='git send-email'
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-send-email tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ PROG='git send-email'
+ test_expect_success \
+diff --git a/t/t9200-git-cvsexportcommit.sh b/t/t9200-git-cvsexportcommit.sh
+index 245a7c3..6cd779a 100755
+--- a/t/t9200-git-cvsexportcommit.sh
++++ b/t/t9200-git-cvsexportcommit.sh
+@@ -13,6 +13,12 @@ then
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsexportcommit tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ CVSROOT=$(pwd)/cvsroot
+ CVSWORK=$(pwd)/cvswork
+diff --git a/t/t9400-git-cvsserver-server.sh b/t/t9400-git-cvsserver-server.sh
+index 6a37f71..84a0d31 100755
+--- a/t/t9400-git-cvsserver-server.sh
++++ b/t/t9400-git-cvsserver-server.sh
+@@ -17,6 +17,12 @@ then
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsserver tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+ perl -e 'use DBI; use DBD::SQLite' >/dev/null 2>&1 || {
+ test_expect_success 'skipping git-cvsserver tests, Perl SQLite interface unavailable' :
+ test_done
+diff --git a/t/t9500-gitweb-standalone-no-errors.sh b/t/t9500-gitweb-standalone-no-errors.sh
+index 6ed10d0..d4580a4 100755
+--- a/t/t9500-gitweb-standalone-no-errors.sh
++++ b/t/t9500-gitweb-standalone-no-errors.sh
+@@ -72,6 +72,13 @@ safe_chmod () {
+ }
+
+ . ./test-lib.sh
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping gitweb-standalone-no-errors tests, NO_PERL defined' :
++ test_done
++ exit
++fi
++
+
+ perl -MEncode -e 'decode_utf8("", Encode::FB_CROAK)' >/dev/null 2>&1 || {
+ test_expect_success 'skipping gitweb tests, perl version is too old' :
+diff --git a/t/t9600-cvsimport.sh b/t/t9600-cvsimport.sh
+index d2379e7..75bf178 100755
+--- a/t/t9600-cvsimport.sh
++++ b/t/t9600-cvsimport.sh
+@@ -16,6 +16,12 @@ then
+ test_done
+ exit
+ fi
++if test -n "$NO_PERL"
++then
++ test_expect_success 'skipping git-cvsimport tests, NO_PERL defined' :
++ test_done
++ exit
++fi
+
+ cvsps_version=`cvsps -h 2>&1 | sed -ne 's/cvsps version //p'`
+ case "$cvsps_version" in
diff --git a/dev-util/git/git-1.6.2.ebuild b/dev-util/git/git-1.6.2.ebuild
new file mode 100644
index 000000000000..80d8d1aeeff3
--- /dev/null
+++ b/dev-util/git/git-1.6.2.ebuild
@@ -0,0 +1,304 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.2.ebuild,v 1.1 2009/03/06 06:59:03 robbat2 Exp $
+
+EAPI=2
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="curl cgi doc emacs gtk iconv mozsha1 perl ppcsha1 tk threads webdav xinetd cvs subversion"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ app-arch/cpio
+ perl? ( dev-lang/perl )
+ tk? ( dev-lang/tk )
+ curl? (
+ net-misc/curl
+ webdav? ( dev-libs/expat )
+ )
+ emacs? ( virtual/emacs )"
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/Error
+ dev-perl/Net-SMTP-SSL
+ dev-perl/Authen-SASL
+ cgi? ( virtual/perl-CGI )
+ cvs? ( >=dev-util/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
+ subversion? ( dev-util/subversion[-dso] dev-perl/libwww-perl dev-perl/TermReadKey )
+ )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=50${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use perl ; then
+ use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
+ use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
+ use subversion && ewarn "git-svn needs USE=perl, it won't work"
+ fi
+ if use webdav && ! use curl ; then
+ ewarn "USE=webdav needs USE=curl. Ignoring"
+ fi
+ if use subversion && has_version dev-util/subversion && built_with_use --missing false dev-util/subversion dso ; then
+ ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
+ ewarn "with USE=dso, there may be weird crashes in git-svn. You"
+ ewarn "have been warned."
+ fi
+}
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ fi
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk || myopts="${myopts} NO_TCLTK=YesPlease"
+ use perl || myopts="${myopts} NO_PERL=YesPlease"
+ use threads && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
+ use subversion || myopts="${myopts} NO_SVN_TESTS=YesPlease"
+
+ export MY_MAKEOPTS="${myopts}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && \
+ cd "${S}"/Documentation && \
+ unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
+
+ sed -i \
+ -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
+ -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
+ -e 's:^\(CC = \).*$:\1$(OPTCC):' \
+ -e 's:^\(AR = \).*$:\1$(OPTAR):' \
+ Makefile || die "sed failed"
+}
+
+git_emake() {
+ emake ${MY_MAKEOPTS} \
+ DESTDIR="${D}" \
+ OPTCFLAGS="${CFLAGS}" \
+ OPTLDFLAGS="${LDFLAGS}" \
+ OPTCC="$(tc-getCC)" \
+ OPTAR="$(tc-getAR)" \
+ prefix=/usr \
+ htmldir=/usr/share/doc/${PF}/html \
+ "$@"
+}
+
+src_configure() {
+ exportmakeopts
+}
+
+src_compile() {
+ git_emake || die "emake failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/git.el || die "emacs modules failed"
+ fi
+ if use perl && use cgi ; then
+ git_emake \
+ gitweb/gitweb.cgi || die "emake gitweb/gitweb.cgi failed"
+ fi
+}
+
+src_install() {
+ git_emake \
+ install || \
+ die "make install failed"
+
+ doman man?/*
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/git.{el,elc} || die
+ #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}${SITELISP}/${PN}/compat/.nosearch"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/fast-import/git-p4
+ dodoc contrib/fast-import/git-p4.txt
+ newbin contrib/fast-import/import-tars.perl import-tars
+
+ dodir /usr/share/${PN}/contrib
+ # The following are excluded:
+ # svnimport - use git-svn
+ # p4import - excluded because fast-import has a better one
+ # examples - these are stuff that is not used in Git anymore actually
+ # patches - stuff the Git guys made to go upstream to other places
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh stats \
+ workdir convert-objects blameview ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ if use perl && use cgi ; then
+ dodir /usr/share/${PN}/gitweb
+ insinto /usr/share/${PN}/gitweb
+ doins "${S}"/gitweb/gitweb.cgi
+ doins "${S}"/gitweb/gitweb.css
+ doins "${S}"/gitweb/git-{favicon,logo}.png
+
+ # Make sure it can run
+ fperms 0755 /usr/share/${PN}/gitweb/gitweb.cgi
+
+ # INSTALL discusses configuration issues, not just installation
+ docinto /
+ newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
+ newdoc "${S}"/gitweb/README README.gitweb
+ fi
+ if ! use subversion ; then
+ rm -f "${D}"/usr/libexec/git-core/git-svn \
+ "${D}"/usr/share/man/man1/git-svn.1*
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+ fi
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ local disabled=""
+ local tests_cvs="t9200-git-cvsexportcommit.sh \
+ t9400-git-cvsserver-server.sh \
+ t9600-cvsimport.sh"
+ local tests_perl="t5502-quickfetch.sh \
+ t5512-ls-remote.sh \
+ t5520-pull.sh"
+
+ # Unzip is used only for the testcase code, not by any normal parts of Git.
+ if ! has_version app-arch/unzip ; then
+ einfo "Disabling tar-tree tests"
+ disabled="${disabled} t5000-tar-tree.sh"
+ fi
+
+ cvs=0
+ use cvs && let cvs=$cvs+1
+ if ! has userpriv "${FEATURES}"; then
+ if [[ $cvs -eq 1 ]]; then
+ ewarn "Skipping CVS tests because CVS does not work as root!"
+ ewarn "You should retest with FEATURES=userpriv!"
+ disabled="${disabled} ${tests_cvs}"
+ fi
+ # Bug #225601 - t0004 is not suitable for root perm
+ # Bug #219839 - t1004 is not suitable for root perm
+ disabled="${disabled} t0004-unwritable.sh t1004-read-tree-m-u-wf.sh"
+ else
+ [[ $cvs -gt 0 ]] && \
+ has_version dev-util/cvs && \
+ let cvs=$cvs+1
+ [[ $cvs -gt 0 ]] && \
+ built_with_use dev-util/cvs server && \
+ let cvs=$cvs+1
+ if [[ $cvs -lt 3 ]]; then
+ einfo "Disabling CVS tests (needs dev-util/cvs[USE=server])"
+ disabled="${disabled} ${tests_cvs}"
+ fi
+ fi
+
+ if ! use perl ; then
+ einfo "Disabling tests that need Perl"
+ disabled="${disabled} ${tests_perl}"
+ fi
+
+ # Reset all previously disabled tests
+ cd "${S}/t"
+ for i in *.sh.DISABLED ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
+ done
+ einfo "Disabled tests:"
+ for i in ${disabled} ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
+ done
+ cd "${S}"
+ # Now run the tests
+ einfo "Start test run"
+ git_emake \
+ test || die "tests failed"
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ if use subversion && has_version dev-util/subversion && ! built_with_use --missing false dev-util/subversion perl ; then
+ ewarn "You must build dev-util/subversion with USE=perl"
+ ewarn "to get the full functionality of git-svn!"
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache )"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}