summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2009-11-16 21:59:58 +0000
committerDror Levin <spatz@gentoo.org>2009-11-16 21:59:58 +0000
commitac27dbeba77e633c5fbb4c4914f0fbf6c05b95a7 (patch)
tree377a718b20f5c3e1ffa67acc2443fc8d94df29aa /dev-util
parentFix encrypted swap detection, bug #292090. Use slotted virtual/libusb depende... (diff)
downloadgentoo-2-ac27dbeba77e633c5fbb4c4914f0fbf6c05b95a7.tar.gz
gentoo-2-ac27dbeba77e633c5fbb4c4914f0fbf6c05b95a7.tar.bz2
gentoo-2-ac27dbeba77e633c5fbb4c4914f0fbf6c05b95a7.zip
Version bump, bug 284731. Forward port all patches and also bump ada-mode version.
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ctags/ChangeLog10
-rw-r--r--dev-util/ctags/ctags-5.8.ebuild65
-rw-r--r--dev-util/ctags/files/ctags-5.8-ada.patch28
-rw-r--r--dev-util/ctags/files/ctags-5.8-f95-pointers.patch12
-rw-r--r--dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch13
5 files changed, 127 insertions, 1 deletions
diff --git a/dev-util/ctags/ChangeLog b/dev-util/ctags/ChangeLog
index 4008f8340b9c..c5e844d5dda8 100644
--- a/dev-util/ctags/ChangeLog
+++ b/dev-util/ctags/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/ctags
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.72 2009/10/24 02:04:29 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.73 2009/11/16 21:59:58 spatz Exp $
+
+*ctags-5.8 (16 Nov 2009)
+
+ 16 Nov 2009; Dror Levin <spatz@gentoo.org> +ctags-5.8.ebuild,
+ +files/ctags-5.8-ada.patch, +files/ctags-5.8-f95-pointers.patch,
+ +files/ctags-5.8-python-vars-starting-with-def.patch:
+ Version bump, bug 284731. Forward port all patches and also bump ada-mode
+ version.
*ctags-5.7-r2 (24 Oct 2009)
diff --git a/dev-util/ctags/ctags-5.8.ebuild b/dev-util/ctags/ctags-5.8.ebuild
new file mode 100644
index 000000000000..f8175aaf30d3
--- /dev/null
+++ b/dev-util/ctags/ctags-5.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ctags-5.8.ebuild,v 1.1 2009/11/16 21:59:58 spatz Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
+HOMEPAGE="http://ctags.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ ada? ( mirror://sourceforge/gnuada/ctags-ada-mode-4.3.11.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ada"
+
+DEPEND="app-admin/eselect-ctags"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-5.6-ebuilds.patch"
+ # Upstream fix for python variables starting with def
+ epatch "${FILESDIR}/${P}-python-vars-starting-with-def.patch"
+
+ # Bug #273697
+ epatch "${FILESDIR}/${P}-f95-pointers.patch"
+
+ # enabling Ada support
+ if use ada; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}"
+ epatch "${FILESDIR}/${P}-ada.patch"
+ fi
+}
+
+src_configure() {
+ econf \
+ --with-posix-regex \
+ --without-readlib \
+ --disable-etags \
+ --enable-tmpdir=/tmp \
+ || die "econf failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # namepace collision with X/Emacs-provided /usr/bin/ctags -- we
+ # rename ctags to exuberant-ctags (Mandrake does this also).
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags}
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1
+
+ dodoc FAQ NEWS README || die
+ dohtml EXTENDING.html ctags.html || die
+}
+
+pkg_postinst() {
+ eselect ctags update
+ elog "You can set the version to be started by /usr/bin/ctags through"
+ elog "the ctags eselect module. \"man ctags.eselect\" for details."
+}
+
+pkg_postrm() {
+ eselect ctags update
+}
diff --git a/dev-util/ctags/files/ctags-5.8-ada.patch b/dev-util/ctags/files/ctags-5.8-ada.patch
new file mode 100644
index 000000000000..48ed96f0d88e
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-ada.patch
@@ -0,0 +1,28 @@
+--- parsers-orig.h 2009-11-16 23:39:49.747328066 +0200
++++ parsers.h 2009-11-16 23:40:26.541581805 +0200
+@@ -16,6 +16,7 @@
+
+ /* Add the name of any new parser definition function here */
+ #define PARSER_LIST \
++ AdaParser, \
+ AntParser, \
+ AsmParser, \
+ AspParser, \
+--- source-orig.mak 2009-11-16 23:41:17.184586699 +0200
++++ source.mak 2009-11-16 23:41:48.358331136 +0200
+@@ -8,6 +8,7 @@
+ strlist.h vstring.h
+
+ SOURCES = \
++ ada.c \
+ args.c \
+ ant.c \
+ asm.c \
+@@ -70,6 +71,7 @@
+ REGEX_HEADERS = gnu_regex/regex.h
+
+ OBJECTS = \
++ ada.$(OBJEXT) \
+ args.$(OBJEXT) \
+ ant.$(OBJEXT) \
+ asm.$(OBJEXT) \
diff --git a/dev-util/ctags/files/ctags-5.8-f95-pointers.patch b/dev-util/ctags/files/ctags-5.8-f95-pointers.patch
new file mode 100644
index 000000000000..4ac9560f8785
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-f95-pointers.patch
@@ -0,0 +1,12 @@
+--- fortran-orig.c 2009-11-16 23:38:06.154328652 +0200
++++ fortran.c 2009-11-16 23:38:08.711335501 +0200
+@@ -1319,7 +1319,8 @@
+ readToken (token);
+ skipPast (token, TOKEN_OPERATOR);
+ }
+- else if (strcmp (vStringValue (token->string), "=") == 0)
++ else if ((strcmp (vStringValue (token->string), "=") == 0) ||
++ (strcmp (vStringValue (token->string), "=>") == 0))
+ {
+ while (! isType (token, TOKEN_COMMA) &&
+ ! isType (token, TOKEN_STATEMENT_END))
diff --git a/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch b/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch
new file mode 100644
index 000000000000..83d9f7e887eb
--- /dev/null
+++ b/dev-util/ctags/files/ctags-5.8-python-vars-starting-with-def.patch
@@ -0,0 +1,13 @@
+--- python-orig.c 2009-11-16 23:33:44.930351712 +0200
++++ python.c 2009-11-16 23:35:08.433328150 +0200
+@@ -264,8 +264,8 @@
+ while (*cp)
+ {
+ cp = skipEverything (cp);
+- if (!strncmp(cp, "def", 3) || !strncmp(cp, "class", 5) ||
+- !strncmp(cp, "cdef", 4) || !strncmp(cp, "cpdef", 5))
++ if (!strncmp(cp, "def ", 4) || !strncmp(cp, "class ", 6) ||
++ !strncmp(cp, "cdef ", 5) || !strncmp(cp, "cpdef ", 6))
+ {
+ return cp;
+ }