summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-07 03:02:43 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-07 03:02:43 +0000
commita93a07c73071d6e0c5b34fa306e0e345468e69ab (patch)
treeb980e8859d689ab83ea7971b1453a8e69798fe61 /dev-util
parentUse relative paths in patch. (diff)
downloadgentoo-2-a93a07c73071d6e0c5b34fa306e0e345468e69ab.tar.gz
gentoo-2-a93a07c73071d6e0c5b34fa306e0e345468e69ab.tar.bz2
gentoo-2-a93a07c73071d6e0c5b34fa306e0e345468e69ab.zip
Version bump to 2.0.6_pre1 for testing.
(Portage version: 2.1.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog8
-rw-r--r--dev-util/catalyst/catalyst-2.0.6_pre1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index b97334a70b1b..6804343e3f0e 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.178 2008/01/25 17:38:22 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.179 2008/02/07 03:02:43 wolf31o2 Exp $
+
+*catalyst-2.0.6_pre1 (07 Feb 2008)
+
+ 07 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ +catalyst-2.0.6_pre1.ebuild:
+ Version bump to 2.0.6_pre1 for testing.
25 Jan 2008; Chris Gianelloni <wolf31o2@gentoo.org>
-catalyst-1.1.10.10.ebuild, catalyst-2.0.5.ebuild:
diff --git a/dev-util/catalyst/catalyst-2.0.6_pre1.ebuild b/dev-util/catalyst/catalyst-2.0.6_pre1.ebuild
new file mode 100644
index 000000000000..785ce1e9e3d8
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.6_pre1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6_pre1.ebuild,v 1.1 2008/02/07 03:02:43 wolf31o2 Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="release metatool used for creating Gentoo releases"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+#KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ doins -r arch modules livecd || die "copying files"
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst ./catalyst /usr/$(get_libdir)/${PN}
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}