summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-02-21 01:06:59 +0000
committerJonathan Callen <abcd@gentoo.org>2010-02-21 01:06:59 +0000
commita23bed2f70e593f666a111bf5572a29de8a3084f (patch)
treee1471fd55a4431ae8a649640b161803d864d990f /dev-util
parent5.0.90-r2: Bug #305221: Fix ppc64 builds with new revision due to updated pat... (diff)
downloadgentoo-2-a23bed2f70e593f666a111bf5572a29de8a3084f.tar.gz
gentoo-2-a23bed2f70e593f666a111bf5572a29de8a3084f.tar.bz2
gentoo-2-a23bed2f70e593f666a111bf5572a29de8a3084f.zip
Transfer prefix keywords, bump EAPI, cleanup
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/aegis/ChangeLog7
-rw-r--r--dev-util/aegis/aegis-4.24.ebuild37
2 files changed, 21 insertions, 23 deletions
diff --git a/dev-util/aegis/ChangeLog b/dev-util/aegis/ChangeLog
index ba319ae58ca5..a3a3afaf2c17 100644
--- a/dev-util/aegis/ChangeLog
+++ b/dev-util/aegis/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/aegis
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.25 2009/12/17 21:29:01 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/ChangeLog,v 1.26 2010/02/21 01:06:59 abcd Exp $
+
+ 21 Feb 2010; Jonathan Callen <abcd@gentoo.org> aegis-4.24.ebuild:
+ Transfer prefix keywords, bump EAPI, cleanup
17 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> aegis-4.24.ebuild:
Use emake -j1 for build, bug #297334.
diff --git a/dev-util/aegis/aegis-4.24.ebuild b/dev-util/aegis/aegis-4.24.ebuild
index fa6eac6cecd0..d6b4b475d4e7 100644
--- a/dev-util/aegis/aegis-4.24.ebuild
+++ b/dev-util/aegis/aegis-4.24.ebuild
@@ -1,15 +1,20 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.24.ebuild,v 1.2 2009/12/17 21:29:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/aegis/aegis-4.24.ebuild,v 1.3 2010/02/21 01:06:59 abcd Exp $
-inherit autotools
+EAPI=3
-IUSE="tk"
+inherit autotools
DESCRIPTION="A transaction based revision control system"
SRC_URI="mirror://sourceforge/aegis/${P}.tar.gz"
HOMEPAGE="http://aegis.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE="tk"
+
DEPEND="sys-libs/zlib
sys-devel/gettext
sys-apps/groff
@@ -18,33 +23,23 @@ DEPEND="sys-libs/zlib
tk? ( >=dev-lang/tk-8.3 )"
RDEPEND="" #221421
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~ppc ~sparc ~x86"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
#FIXME: ? Not sure what effect this has. Only way to get it to compile.
sed -i 's/$(SH) etc\/compat.2.3//' Makefile.in || \
die "sed Makefile.in failed"
eautomake || die "eautomake failed"
}
-src_compile() {
+src_configure() {
# By default aegis configure puts shareable read/write files (locks etc)
# in ${prefix}/com/aegis but the FHS says /var/lib/aegis can be shared.
- myconf="${myconf} --with-nlsdir=/usr/share/locale"
-
econf \
--sharedstatedir=/var/lib/aegis \
- ${myconf} || die "./configure failed"
-
- # Second ebuild causes redefined/undefined function errors
- #make clean
+ --with-nlsdir=/usr/share/locale
+}
+src_compile() {
# bug #297334
emake -j1 || die
}
@@ -55,14 +50,14 @@ src_install () {
# OK so ${D}/var/lib/aegis gets UID=3, but for some
# reason so do the files under /usr/share, even though
# they are read-only.
- chown -R root:root "${D}"/usr/share
+ use prefix || fowners -R root:root /usr/share
dodoc lib/en/*
# Link to share dir so user has a chance of noticing it.
dosym /usr/share/aegis /usr/share/doc/${PF}/scripts
# Config file examples are documentation.
- mv "${D}"/usr/share/aegis/config.example "${D}"/usr/share/doc/"${PF}"/
+ mv "${ED}"/usr/share/aegis/config.example "${ED}"/usr/share/doc/${PF}/
dodoc BUILDING README
}