summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-07-29 10:32:34 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-07-29 10:32:34 +0000
commita1cc8f43fe4ca0214f4288eefc8afbe02d10e713 (patch)
tree2d4b7488848d71407f9fe5ca6ff7c1cb16ce3ff7 /dev-util
parentDrop unused version. (diff)
downloadgentoo-2-a1cc8f43fe4ca0214f4288eefc8afbe02d10e713.tar.gz
gentoo-2-a1cc8f43fe4ca0214f4288eefc8afbe02d10e713.tar.bz2
gentoo-2-a1cc8f43fe4ca0214f4288eefc8afbe02d10e713.zip
Version bump (bug #186811)
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/ChangeLog8
-rw-r--r--dev-util/boost-build/boost-build-1.34.1.ebuild67
-rw-r--r--dev-util/boost-build/files/digest-boost-build-1.34.13
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 7aff42e33bbf..35a661133789 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.9 2007/06/23 17:57:12 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.10 2007/07/29 10:32:34 dev-zero Exp $
+
+*boost-build-1.34.1 (29 Jul 2007)
+
+ 29 Jul 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +boost-build-1.34.1.ebuild:
+ Version bump (bug #186811)
23 Jun 2007; Joshua Kinard <kumba@gentoo.org> boost-build-1.34.0.ebuild:
Marked unstable on mips, per #182196.
diff --git a/dev-util/boost-build/boost-build-1.34.1.ebuild b/dev-util/boost-build/boost-build-1.34.1.ebuild
new file mode 100644
index 000000000000..d7b7d4bad711
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.34.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.1.ebuild,v 1.1 2007/07/29 10:32:34 dev-zero Exp $
+
+inherit flag-o-matic toolchain-funcs versionator
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerfull."
+HOMEPAGE="http://www.boost.org/tools/build/v2/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="!<dev-libs/boost-1.34.0"
+RDEPEND=""
+
+S=${WORKDIR}/boost_${MY_PV}/tools
+
+src_unpack() {
+ unpack ${A}
+
+ # Remove stripping option
+ cd "${S}/jam/src"
+ sed -i \
+ -e 's/-s\b//' \
+ build.jam || die "sed failed"
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}/build/v2"
+ sed -i \
+ -e 's/\(feature optimization : off speed space\)/\1 none/' \
+ -e 's/\(feature debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+}
+
+src_compile() {
+
+ cd jam/src
+ local toolset
+
+ if [ "${ARCH}" == "ppc-macos" ] ; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ CC=$(tc-getCC) ./build.sh ${toolset} || die "building bjam failed"
+}
+
+src_install() {
+ dobin jam/src/bin.*/bjam
+
+ cd "${S}/build/v2"
+ insinto /usr/share/boost-build
+ doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
+ build kernel options tools util
+}
diff --git a/dev-util/boost-build/files/digest-boost-build-1.34.1 b/dev-util/boost-build/files/digest-boost-build-1.34.1
new file mode 100644
index 000000000000..2ec12588df9d
--- /dev/null
+++ b/dev-util/boost-build/files/digest-boost-build-1.34.1
@@ -0,0 +1,3 @@
+MD5 2d938467e8a448a2c9763e0a9f8ca7e5 boost_1_34_1.tar.bz2 12986931
+RMD160 303327ff852bc19dd7a94657fdef3c56f5882e06 boost_1_34_1.tar.bz2 12986931
+SHA256 0f866c75b025a4f1340117a106595cc0675f48ba1e5a9b5c221ec7f19e96ec4c boost_1_34_1.tar.bz2 12986931