summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-14 00:11:35 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-05-14 00:11:35 +0000
commit9fbbee2640539c7486ffc31223087d643d1b5ae1 (patch)
treece25545706188e1cfc1471ae74442fb85115b079 /dev-util
parentFixes #2566. (diff)
downloadgentoo-2-9fbbee2640539c7486ffc31223087d643d1b5ae1.tar.gz
gentoo-2-9fbbee2640539c7486ffc31223087d643d1b5ae1.tar.bz2
gentoo-2-9fbbee2640539c7486ffc31223087d643d1b5ae1.zip
Fixes #2339.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/devhelp/ChangeLog28
-rw-r--r--dev-util/devhelp/devhelp-0.4.ebuild63
-rw-r--r--dev-util/devhelp/files/digest-devhelp-0.41
3 files changed, 82 insertions, 10 deletions
diff --git a/dev-util/devhelp/ChangeLog b/dev-util/devhelp/ChangeLog
index ff84b861ca33..ba604cb1886f 100644
--- a/dev-util/devhelp/ChangeLog
+++ b/dev-util/devhelp/ChangeLog
@@ -1,20 +1,28 @@
# ChangeLog for dev-util/devhelp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/ChangeLog,v 1.2 2002/02/20 02:55:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/ChangeLog,v 1.3 2002/05/14 00:11:35 karltk Exp $
+
+*devhelp-0.4 (16 Feb 2002)
+
+ 14 May 2002; Karl Trygve Kalleberg <karltk@gentoo.org> devhelp-0.4.ebuild :
+
+ New upstream version.
+
+ Added license and slot info.
*devhelp-0.3-r1 (16 Feb 2002)
- 16 Feb 2002; Aron Griffis <agriffis@gentoo.org> devhelp-0.3-r1.ebuild :
+ 16 Feb 2002; Aron Griffis <agriffis@gentoo.org> devhelp-0.3-r1.ebuild :
- Fixed to not violate sandbox.
+ Fixed to not violate sandbox.
*devhelp-0.3 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that
- the comments should well explained and written in clean English. The
- details about writing correct changelogs are explained in the
- skel.ChangeLog file which you can find in the root directory of the
- portage repository.
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ Portage repository.
diff --git a/dev-util/devhelp/devhelp-0.4.ebuild b/dev-util/devhelp/devhelp-0.4.ebuild
new file mode 100644
index 000000000000..587fab194531
--- /dev/null
+++ b/dev-util/devhelp/devhelp-0.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.4.ebuild,v 1.1 2002/05/14 00:11:35 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Developer help browser"
+SRC_URI="http://devhelp.codefactory.se/download/${P}.tar.gz"
+HOMEPAGE="http://devhelp.codefactory.se/"
+LICENSE="GPL"
+SLOT="0"
+
+RDEPEND=">=gnome-base/gnome-libs-1.2.8
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-base/bonobo-1.0.9-r1
+ >=gnome-base/libglade-0.17-r1
+ >=dev-libs/libxml-1.8.15
+ >=gnome-extra/gtkhtml-0.10.0
+ >=gnome-base/gconf-1.0.4-r2
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-more-warnings \
+ --disable-install-schemas \
+ --without-python $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+}
+
+pkg_postinst() {
+ # This is directly from the rpm specfile for devhelp...
+ # Fix gconf permissions
+ killall gconfd-1 2>/dev/null >/dev/null
+ chmod o+rX /etc/gconf -R
+ # Install schemas
+ gconftool-1 --shutdown
+ SOURCE=xml::/etc/gconf/gconf.xml.defaults
+ GCONF_CONFIG_SOURCE=$SOURCE \
+ gconftool-1 --makefile-install-rule \
+ /etc/gconf/schemas/devhelp.schemas \
+ # 2>/dev/null >/dev/null || exit 1
+ assert "gconftool-1 execution failed"
+}
diff --git a/dev-util/devhelp/files/digest-devhelp-0.4 b/dev-util/devhelp/files/digest-devhelp-0.4
new file mode 100644
index 000000000000..b851b8dd107c
--- /dev/null
+++ b/dev-util/devhelp/files/digest-devhelp-0.4
@@ -0,0 +1 @@
+MD5 0475b6a225d76173702d26dc05fba278 devhelp-0.4.tar.gz 363429