summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2006-06-11 12:12:37 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2006-06-11 12:12:37 +0000
commit9fb0edb224503dc538b5019fbb36f8f993b31199 (patch)
tree4e542b27b788048b9eadc14a7ea73f217bce923a /dev-util
parentMigrated to modular X. (diff)
downloadgentoo-2-9fb0edb224503dc538b5019fbb36f8f993b31199.tar.gz
gentoo-2-9fb0edb224503dc538b5019fbb36f8f993b31199.tar.bz2
gentoo-2-9fb0edb224503dc538b5019fbb36f8f993b31199.zip
Fixed bug #136047 and fixed the valgrind part of bug #136303
(Portage version: 2.1_rc4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/valgrind-3.2.0.ebuild11
2 files changed, 14 insertions, 5 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 703d23df05ad..9325d03a0fa9 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.61 2006/06/09 20:01:40 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.62 2006/06/11 12:12:37 griffon26 Exp $
+
+ 11 Jun 2006; Maurice van der Pot <griffon26@gentoo.org>
+ valgrind-3.2.0.ebuild:
+ Fixed bug #136047 as proposed by Jean Bréfort <jean.brefort@normalesup.org>
+ and added a blocking dep for callgrind as part of a fix for bug #136303
+ reported by Daniel Franke <franke.daniel@gmail.com>.
09 Jun 2006; Maurice van der Pot <griffon26@gentoo.org>
-files/valgrind-2.2.0-current-macro-clash.patch,
diff --git a/dev-util/valgrind/valgrind-3.2.0.ebuild b/dev-util/valgrind/valgrind-3.2.0.ebuild
index ef35ee4a951b..e0cce9629f2e 100644
--- a/dev-util/valgrind/valgrind-3.2.0.ebuild
+++ b/dev-util/valgrind/valgrind-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.2.0.ebuild,v 1.1 2006/06/07 09:24:49 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.2.0.ebuild,v 1.2 2006/06/11 12:12:37 griffon26 Exp $
inherit eutils flag-o-matic
@@ -16,6 +16,8 @@ IUSE="X"
# bug #49147 (bogus stacktrace in gdb with --db-attach=yes) does not seem to be applicable anymore
#RESTRICT="strip"
+RDEPEND="!dev-util/callgrind"
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -34,9 +36,6 @@ src_unpack() {
einfo "Regenerating autotools files..."
autoconf || die "autoconf failed"
automake || die "automake failed"
-
- # fix for amd64 no-multilib profile till valgrind 3.2.0 is out (bug #114407)
- use amd64 && (has_multilib_profile || epatch "${FILESDIR}/valgrind-3.1.0-amd64-nomultilib-fix.patch")
}
src_compile() {
@@ -57,6 +56,10 @@ src_compile() {
# Optionally build in X suppression files
use X && myconf="--with-x" || myconf="--with-x=no"
+ if use amd64 && ! has_multilib_profile; then
+ myconf="${myconf} --enable-only64bit"
+ fi
+
econf ${myconf} || die "Configure failed!"
emake || die "Make failed!"
}