summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-09-30 17:29:45 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-09-30 17:29:45 +0000
commit9a093ba6127d8c1dc35df7ab9dde407294053c1a (patch)
tree90bdd6f7a05ac422a7ff33eb9f0d93670eea014e /dev-util
parentOld. (diff)
downloadgentoo-2-9a093ba6127d8c1dc35df7ab9dde407294053c1a.tar.gz
gentoo-2-9a093ba6127d8c1dc35df7ab9dde407294053c1a.tar.bz2
gentoo-2-9a093ba6127d8c1dc35df7ab9dde407294053c1a.zip
Version bump buildbot-slave to 0.8.7.
(Portage version: 2.1.11.23/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-slave/ChangeLog7
-rw-r--r--dev-util/buildbot-slave/buildbot-slave-0.8.7.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-util/buildbot-slave/ChangeLog b/dev-util/buildbot-slave/ChangeLog
index 7acc60f1ad3e..e4e21378de08 100644
--- a/dev-util/buildbot-slave/ChangeLog
+++ b/dev-util/buildbot-slave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/buildbot-slave
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.26 2012/09/30 17:24:35 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/ChangeLog,v 1.27 2012/09/30 17:29:45 djc Exp $
+
+*buildbot-slave-0.8.7 (30 Sep 2012)
+
+ 30 Sep 2012; Dirkjan Ochtman <djc@gentoo.org> +buildbot-slave-0.8.7.ebuild:
+ Version bump to 0.8.7.
30 Sep 2012; Dirkjan Ochtman <djc@gentoo.org> files/buildslave.initd:
Let s-s-d know about custom pidfile (bug 397759, thanks to jbergstroem).
diff --git a/dev-util/buildbot-slave/buildbot-slave-0.8.7.ebuild b/dev-util/buildbot-slave/buildbot-slave-0.8.7.ebuild
new file mode 100644
index 000000000000..85f18656e9b8
--- /dev/null
+++ b/dev-util/buildbot-slave/buildbot-slave-0.8.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot-slave/buildbot-slave-0.8.7.ebuild,v 1.1 2012/09/30 17:29:45 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="trial buildslave"
+DISTUTILS_DISABLE_TEST_DEPENDENCY="1"
+
+inherit distutils user
+
+DESCRIPTION="BuildBot Slave Daemon"
+HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"
+
+MY_PV="${PV/_p/p}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools
+ >=dev-python/twisted-2
+ !!<dev-util/buildbot-0.8.1
+ !<dev-util/buildbot-0.8.3"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+PYTHON_MODNAME="buildslave"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_pkg_setup
+ enewuser buildbot
+}
+
+src_install() {
+ distutils_src_install
+
+ doman docs/buildslave.1 || die "doman failed"
+
+ newconfd "${FILESDIR}/buildslave.confd" buildslave || die "newconfd failed"
+ newinitd "${FILESDIR}/buildslave.initd" buildslave || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The \"buildbot\" user and the \"buildslave\" init script has been added"
+ elog "to support starting buildslave through Gentoo's init system. To use this,"
+ elog "set up your build slave following the documentation, make sure the"
+ elog "resulting directories are owned by the \"buildbot\" user and point"
+ elog "\"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can"
+ elog "run as a different user if desired. If you need to run more than one"
+ elog "build slave, just copy the scripts."
+}