summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-12 12:11:00 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-12 12:11:00 +0000
commit98fb913f65c4027ed93977d1517070b4c65b1238 (patch)
treecdd6773c8279f758b0c28071e8fc49ac1efc2042 /dev-util
parentRemove old (diff)
downloadgentoo-2-98fb913f65c4027ed93977d1517070b4c65b1238.tar.gz
gentoo-2-98fb913f65c4027ed93977d1517070b4c65b1238.tar.bz2
gentoo-2-98fb913f65c4027ed93977d1517070b4c65b1238.zip
Version bump, bug #493854.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/kdevplatform/ChangeLog7
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.6.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-util/kdevplatform/ChangeLog b/dev-util/kdevplatform/ChangeLog
index 49683725fcfc..53dfce9ed347 100644
--- a/dev-util/kdevplatform/ChangeLog
+++ b/dev-util/kdevplatform/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/kdevplatform
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.88 2014/02/09 12:13:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/ChangeLog,v 1.89 2014/03/12 12:11:00 johu Exp $
+
+*kdevplatform-1.6.0 (12 Mar 2014)
+
+ 12 Mar 2014; Johannes Huber <johu@gentoo.org> +kdevplatform-1.6.0.ebuild:
+ Version bump, bug #493854.
09 Feb 2014; Johannes Huber <johu@gentoo.org> -kdevplatform-1.5.1.ebuild:
Remove old.
diff --git a/dev-util/kdevplatform/kdevplatform-1.6.0.ebuild b/dev-util/kdevplatform/kdevplatform-1.6.0.ebuild
new file mode 100644
index 000000000000..dd4d943046e7
--- /dev/null
+++ b/dev-util/kdevplatform/kdevplatform-1.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevplatform/kdevplatform-1.6.0.ebuild,v 1.1 2014/03/12 12:11:00 johu Exp $
+
+EAPI=5
+
+KMNAME="kdevelop"
+KDE_LINGUAS="bs ca ca@valencia da de el es et fi fr gl it kk nb nl pl pt pt_BR
+ru sk sl sv th uk zh_CN zh_TW"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+EGIT_REPONAME="${PN}"
+inherit kde4-base
+
+DESCRIPTION="KDE development support libraries and apps"
+LICENSE="GPL-2 LGPL-2"
+IUSE="cvs debug reviewboard subversion"
+SRC_URI="mirror://kde/stable/kdevelop/${KDEVELOP_VERSION}/src/${P}.tar.xz"
+
+if [[ $PV == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/grantlee
+ reviewboard? ( dev-libs/qjson )
+ subversion? (
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-vcs/subversion
+ )
+"
+RDEPEND="${DEPEND}
+ !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
+ $(add_kdebase_dep konsole)
+ cvs? ( dev-vcs/cvs )
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build cvs)
+ $(cmake-utils_use_find_package reviewboard QJSON)
+ $(cmake-utils_use_build subversion)
+ )
+
+ kde4-base_src_configure
+}