summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-11-15 21:34:22 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-11-15 21:34:22 +0000
commit976548fb76383554d2f1cb833749acd9c07bd76f (patch)
tree5a7d83e8a0cf65e28a35359018f13dd99d18dbe6 /dev-util
parentfix #155298, wrong path in samples for mount command. (diff)
downloadgentoo-2-976548fb76383554d2f1cb833749acd9c07bd76f.tar.gz
gentoo-2-976548fb76383554d2f1cb833749acd9c07bd76f.tar.bz2
gentoo-2-976548fb76383554d2f1cb833749acd9c07bd76f.zip
New upstream version.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.49
-rw-r--r--dev-util/git/git-1.4.4.ebuild151
3 files changed, 166 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index b4869ff3c371..679738aeb633 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.144 2006/11/12 22:09:04 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.145 2006/11/15 21:34:22 ferdy Exp $
+
+*git-1.4.4 (15 Nov 2006)
+
+ 15 Nov 2006; Fernando J. Pereda <ferdy@gentoo.org> +git-1.4.4.ebuild:
+ New upstream version.
*git-1.4.3.5 (12 Nov 2006)
diff --git a/dev-util/git/files/digest-git-1.4.4 b/dev-util/git/files/digest-git-1.4.4
new file mode 100644
index 000000000000..5106c260a0d6
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.4
@@ -0,0 +1,9 @@
+MD5 3bf19bd4c5746c5dc74f19cf167f4eb1 git-1.4.4.tar.bz2 886549
+RMD160 99352e32da5b79928d85e3176cc5abe5013ba474 git-1.4.4.tar.bz2 886549
+SHA256 ae878e93dbade210601b47fe56a7a36c84ae8a28457c5f415626f829e511fe17 git-1.4.4.tar.bz2 886549
+MD5 e25f433c6f605cd3a557db9390ece1f4 git-htmldocs-1.4.4.tar.bz2 321241
+RMD160 225fb4067857e4e242783d314ab4ab1c31970470 git-htmldocs-1.4.4.tar.bz2 321241
+SHA256 d73d3fb7093d2a2ed60be4c24389324ce153b7f6c26de0fbf9611a804561d2ba git-htmldocs-1.4.4.tar.bz2 321241
+MD5 9996ee76099d68229bc85565a799715c git-manpages-1.4.4.tar.bz2 103893
+RMD160 51e717edb8ab53239b098f2ea47ddbedd24a806c git-manpages-1.4.4.tar.bz2 103893
+SHA256 549ad09b5a70bf059a1a0d994778aabfef17e02433dc019585d48c0343f73c06 git-manpages-1.4.4.tar.bz2 103893
diff --git a/dev-util/git/git-1.4.4.ebuild b/dev-util/git/git-1.4.4.ebuild
new file mode 100644
index 000000000000..49e275be973a
--- /dev/null
+++ b/dev-util/git/git-1.4.4.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.4.ebuild,v 1.1 2006/11/15 21:34:22 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common perl-module bash-completion
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc elibc_uclibc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ einfo " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo "These additional scripts need some dependencies:"
+ einfo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn "dev-util/subversion(USE=perl)" "dev-perl/libwww-perl"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dep-perl/DBD-SQLite"
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}