summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-05 17:53:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-05 17:53:01 +0000
commit9531ab5741791aea338d1db898f4730a9166aafe (patch)
treec18f8a818ee37563e4c30d4a883d6bc2f98d5cba /dev-util
parentDrop gnome-icon-theme dependency, bug #437246 by timtasse. gnome-settings-dae... (diff)
downloadgentoo-2-9531ab5741791aea338d1db898f4730a9166aafe.tar.gz
gentoo-2-9531ab5741791aea338d1db898f4730a9166aafe.tar.bz2
gentoo-2-9531ab5741791aea338d1db898f4730a9166aafe.zip
Version bump.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catfish/ChangeLog8
-rw-r--r--dev-util/catfish/catfish-0.4.0.2.ebuild65
-rw-r--r--dev-util/catfish/files/catfish-gentoo.patch-r148
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/catfish/ChangeLog b/dev-util/catfish/ChangeLog
index 65ce74f39bbd..4b7c6e2b5ce6 100644
--- a/dev-util/catfish/ChangeLog
+++ b/dev-util/catfish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/catfish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.3 2012/08/02 14:20:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.4 2012/10/05 17:53:01 ssuominen Exp $
+
+*catfish-0.4.0.2 (05 Oct 2012)
+
+ 05 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> +catfish-0.4.0.2.ebuild,
+ +files/catfish-gentoo.patch-r1:
+ Version bump.
*catfish-0.3.2-r1 (02 Aug 2012)
diff --git a/dev-util/catfish/catfish-0.4.0.2.ebuild b/dev-util/catfish/catfish-0.4.0.2.ebuild
new file mode 100644
index 000000000000..fb56271eacc8
--- /dev/null
+++ b/dev-util/catfish/catfish-0.4.0.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-0.4.0.2.ebuild,v 1.1 2012/10/05 17:53:01 ssuominen Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.7"
+inherit eutils gnome2-utils multilib python
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="http://launchpad.net/catfish-search http://twotoasts.de/index.php/catfish/"
+SRC_URI="http://launchpad.net/${PN}-search/${PV%.*.*}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ >=dev-python/pygtk-2
+ dev-python/pyxdg"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-gentoo.patch-r1
+
+ python_convert_shebangs 2 {build,catfish}.py
+
+ cat <<-EOF > "${T}"/${PN}
+ #!/bin/sh
+ cd /usr/$(get_libdir)/${PN}
+ python2 ${PN}.pyc "\$@"
+ EOF
+}
+
+src_configure() {
+ ./configure --prefix=/usr || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+
+ dobin "${T}"/${PN}
+
+ dodoc AUTHORS ChangeLog README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+ gnome2_icon_cache_update
+}
diff --git a/dev-util/catfish/files/catfish-gentoo.patch-r1 b/dev-util/catfish/files/catfish-gentoo.patch-r1
new file mode 100644
index 000000000000..815e4ff9c7f5
--- /dev/null
+++ b/dev-util/catfish/files/catfish-gentoo.patch-r1
@@ -0,0 +1,48 @@
+--- Makefile.in
++++ Makefile.in
+@@ -3,9 +3,9 @@
+ PYTHON=`which python`
+ LANGUAGE_FILES=$(patsubst po/%.po, locale/%/LC_MESSAGES/$(APPNAME).mo, $(wildcard po/*.po))
+ DESTDIR=
++LIBDIR=lib
+
+ all: $(LANGUAGE_FILES)
+- $(PYTHON) ./build.py build $(APPNAME)
+ sed -e s,%prefix%,$(PREFIX), $(APPNAME).in > $(APPNAME)
+ chmod +x $(APPNAME)
+
+@@ -14,29 +14,19 @@
+ msgfmt $< -o $@
+
+ install: all
+- install -d $(DESTDIR)/$(PREFIX)/bin
+- install $(APPNAME) $(DESTDIR)/$(PREFIX)/bin
+-
+- install -d $(DESTDIR)/$(PREFIX)/share/$(APPNAME)
+- install $(APPNAME).pyc $(DESTDIR)/$(PREFIX)/share/$(APPNAME)
+- install $(APPNAME).glade $(DESTDIR)/$(PREFIX)/share/$(APPNAME)
++ install -d $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(APPNAME)
++ install $(APPNAME).py $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(APPNAME)
++ install $(APPNAME).glade $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(APPNAME)
+
+ install -d $(DESTDIR)/$(PREFIX)/share/icons/hicolor/scalable/apps
+ install $(APPNAME).svg $(DESTDIR)/$(PREFIX)/share/icons/hicolor/scalable/apps
+- ln -sf $(DESTDIR)/$(PREFIX)/share/icons/hicolor/scalable/apps/$(APPNAME).svg $(DESTDIR)/$(PREFIX)/share/$(APPNAME)/$(APPNAME).svg
+-
+- install -d $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
+- install AUTHORS $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
+- install COPYING $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
+- install ChangeLog $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
+- install INSTALL $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
+- install README $(DESTDIR)/$(PREFIX)/share/doc/$(APPNAME)
++ ln -sf $(DESTDIR)/$(PREFIX)/share/icons/hicolor/scalable/apps/$(APPNAME).svg $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(APPNAME)/$(APPNAME).svg
+
+ install -d $(DESTDIR)/$(PREFIX)/share/applications
+ install --mode=644 $(APPNAME).desktop $(DESTDIR)/$(PREFIX)/share/applications
+
+ cp -rf locale $(DESTDIR)/$(PREFIX)/share
+- ln -sf $(DESTDIR)/$(PREFIX)/share/locale $(DESTDIR)/$(PREFIX)/share/$(APPNAME)/locale
++ ln -sf $(DESTDIR)/$(PREFIX)/share/locale $(DESTDIR)/$(PREFIX)/$(LIBDIR)/$(APPNAME)/locale
+
+ uninstall:
+ rm -f $(DESTDIR)/$(PREFIX)/share/applications/$(APPNAME).desktop