summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2012-04-22 04:26:30 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2012-04-22 04:26:30 +0000
commit94be3e27ef4b5f6bbc7991f9ea8009d7cec697ba (patch)
treea9aac9d3c4309c1927ab415daac1832e4e504a27 /dev-util
parentVersion bump, translation updates only. (diff)
downloadgentoo-2-94be3e27ef4b5f6bbc7991f9ea8009d7cec697ba.tar.gz
gentoo-2-94be3e27ef4b5f6bbc7991f9ea8009d7cec697ba.tar.bz2
gentoo-2-94be3e27ef4b5f6bbc7991f9ea8009d7cec697ba.zip
[dev-util/catalyst] Bump catalyst to the 2.0.8 revision.
Drop metadata_overlay, update portage at the start of stage1, update mips and amd64 specs, move /etc/make.profile to /etc/portage/make.profile and don't die if /etc/portage already exists. (Portage version: 2.2.0_alpha100/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog12
-rw-r--r--dev-util/catalyst/catalyst-2.0.8.ebuild96
2 files changed, 107 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index dd6ef63b654d..b647d25152a9 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/catalyst
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.237 2012/03/19 21:03:34 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.238 2012/04/22 04:26:30 jmbsvicetto Exp $
+
+*catalyst-2.0.8 (22 Apr 2012)
+
+ 22 Apr 2012; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +catalyst-2.0.8.ebuild:
+ [dev-util/catalyst] Bump catalyst to the 2.0.8 revision.
+ Drop metadata_overlay, update portage at the start of stage1, update mips and
+ amd64 specs, move /etc/make.profile to /etc/portage/make.profile and don't
+ die if /etc/portage already
+ exists.
19 Mar 2012; Zac Medico <zmedico@gentoo.org>
files/0001-Add-new-T-purgetmponly-option.patch:
diff --git a/dev-util/catalyst/catalyst-2.0.8.ebuild b/dev-util/catalyst/catalyst-2.0.8.ebuild
new file mode 100644
index 000000000000..42ab28a3aa91
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.8.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.8.ebuild,v 1.1 2012/04/22 04:26:30 jmbsvicetto Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-2.9999 -> catalyst_2 branch from Git
+# catalyst-VER -> normal catalyst release
+
+EAPI=2
+
+if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git-2
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+inherit eutils multilib
+
+DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="ccache"
+
+DEPEND="app-text/asciidoc"
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ virtual/cdrtools
+ ccache? ( dev-util/ccache )
+ ia64? ( sys-fs/dosfstools )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+ if [[ ${PV} == 9999* || ${PV} == 2.9999* ]]; then
+ ewarn "The ${EGIT_BRANCH:-master} branch (what you get with this ${PV} ebuild) contains"
+ ewarn "work-in-progress code. Be aware that it's likely that it will not"
+ ewarn "be in a working state at any given point. Please do not file bugs"
+ ewarn "until you have posted on the gentoo-catalyst mailing list and we"
+ ewarn "have asked you to do so."
+ fi
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README ChangeLog AUTHORS
+ doman files/catalyst.1
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst/catalyst.conf
+ dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}