summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-06-23 01:59:45 +0000
committerMike Gilbert <floppym@gentoo.org>2015-06-23 01:59:45 +0000
commit8bbc25b4daacda083e5761cb24c5ececb79cd736 (patch)
tree55b08ce3ff63f0e5cc36d58fa7fa2f7b1087b574 /dev-util
parentBackport hotwording flag. (diff)
downloadgentoo-2-8bbc25b4daacda083e5761cb24c5ececb79cd736.tar.gz
gentoo-2-8bbc25b4daacda083e5761cb24c5ececb79cd736.tar.bz2
gentoo-2-8bbc25b4daacda083e5761cb24c5ececb79cd736.zip
Add a live ebuild.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ninja/ChangeLog7
-rw-r--r--dev-util/ninja/ninja-9999.ebuild128
2 files changed, 134 insertions, 1 deletions
diff --git a/dev-util/ninja/ChangeLog b/dev-util/ninja/ChangeLog
index b69406fc1df8..0ee56dc33ea5 100644
--- a/dev-util/ninja/ChangeLog
+++ b/dev-util/ninja/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ninja
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.44 2015/06/22 23:04:12 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ChangeLog,v 1.45 2015/06/23 01:59:45 floppym Exp $
+
+*ninja-9999 (23 Jun 2015)
+
+ 23 Jun 2015; Mike Gilbert <floppym@gentoo.org> +ninja-9999.ebuild:
+ Add a live ebuild.
22 Jun 2015; Mike Gilbert <floppym@gentoo.org> -ninja-1.4.0.ebuild:
Remove old.
diff --git a/dev-util/ninja/ninja-9999.ebuild b/dev-util/ninja/ninja-9999.ebuild
new file mode 100644
index 000000000000..699228b979ee
--- /dev/null
+++ b/dev-util/ninja/ninja-9999.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ninja/ninja-9999.ebuild,v 1.1 2015/06/23 01:59:45 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martine/ninja.git"
+else
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A small build system similar to make"
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+run_for_build() {
+ if tc-is-cross-compiler; then
+ local -x AR=$(tc-getBUILD_AR)
+ local -x CXX=$(tc-getBUILD_CXX)
+ local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x LDFLAGS=${BUILD_LDFLAGS}
+ fi
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ # configure.py uses CFLAGS instead of CXXFLAGS
+ export CFLAGS=${CXXFLAGS}
+
+ run_for_build "${PYTHON}" configure.py --bootstrap --verbose || die
+
+ if tc-is-cross-compiler; then
+ mv ninja ninja-build || die
+ "${PYTHON}" configure.py || die
+ ./ninja-build -v ninja || die
+ else
+ ln ninja ninja-build || die
+ fi
+
+ if use doc; then
+ ./ninja-build -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ if ! tc-is-cross-compiler; then
+ # Bug 485772
+ ulimit -n 2048
+ ./ninja-build -v ninja_test || die
+ ./ninja_test || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}