summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-24 15:11:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-24 15:11:26 +0000
commit8b3d310c35d41169eaa4a69665c4d90327320877 (patch)
tree453e5897c1bf44e2d2f63184a8d0010feb16becf /dev-util
parentVersion bump. Run cucumber features for ruby18/ree18 since we don't have it y... (diff)
downloadgentoo-2-8b3d310c35d41169eaa4a69665c4d90327320877.tar.gz
gentoo-2-8b3d310c35d41169eaa4a69665c4d90327320877.tar.bz2
gentoo-2-8b3d310c35d41169eaa4a69665c4d90327320877.zip
Version bump; tests are enabled, but there is a failure still, which needs to be identified.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/google-perftools/ChangeLog9
-rw-r--r--dev-util/google-perftools/google-perftools-1.9.ebuild76
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-util/google-perftools/ChangeLog b/dev-util/google-perftools/ChangeLog
index ba13a3636aab..61d55feef062 100644
--- a/dev-util/google-perftools/ChangeLog
+++ b/dev-util/google-perftools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/google-perftools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.13 2011/08/28 15:22:40 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/ChangeLog,v 1.14 2011/12/24 15:11:26 flameeyes Exp $
+
+*google-perftools-1.9 (24 Dec 2011)
+
+ 24 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +google-perftools-1.9.ebuild:
+ Version bump; tests are enabled, but there is a failure still, which needs to
+ be identified.
28 Aug 2011; Naohiro Aota <naota@gentoo.org> google-perftools-1.8.3.ebuild:
Add ~x86-fbsd, bug #377199
diff --git a/dev-util/google-perftools/google-perftools-1.9.ebuild b/dev-util/google-perftools/google-perftools-1.9.ebuild
new file mode 100644
index 000000000000..81a00e9bf4b9
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-1.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/google-perftools/google-perftools-1.9.ebuild,v 1.1 2011/12/24 15:11:26 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils flag-o-matic
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="http://code.google.com/p/google-perftools/"
+SRC_URI="http://google-perftools.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="largepages +debug minimal test"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ makeopts="${makeopts} noinst_PROGRAMS= "
+
+ # don't install _anything_ from the documentation, since it would
+ # install it in non-standard locations, and would just waste time.
+ makeopts="${makeopts} dist_doc_DATA= "
+}
+
+src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ $(use_enable debug debugalloc) \
+ $(use_enable minimal)
+}
+
+src_compile() {
+ emake ${makeopts}
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sanbox is enabled."
+ ewarn "See http://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install ${makeopts}
+
+ # Remove libtool files since we dropped the static libraries
+ find "${D}" -name '*.la' -delete
+
+ dodoc README AUTHORS ChangeLog TODO NEWS
+ pushd doc
+ dohtml -r *
+ popd
+}