summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-06 09:21:25 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-06 09:21:25 +0000
commit690c7522284a194c8cb81954a37b1cbcf8ab11f8 (patch)
treee89e6ee5e2e507ede80973c8640c07a1cbf06433 /dev-util
parentStable on sparc wrt bug #191336 (diff)
downloadgentoo-2-690c7522284a194c8cb81954a37b1cbcf8ab11f8.tar.gz
gentoo-2-690c7522284a194c8cb81954a37b1cbcf8ab11f8.tar.bz2
gentoo-2-690c7522284a194c8cb81954a37b1cbcf8ab11f8.zip
version bump. fixed tests and removed RESTRICT=test
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bzr/ChangeLog12
-rw-r--r--dev-util/bzr/bzr-0.90.ebuild81
-rw-r--r--dev-util/bzr/files/bzr-0.90-tests-fix_root.patch30
-rw-r--r--dev-util/bzr/files/bzr-0.90-tests-sgid.patch13
-rw-r--r--dev-util/bzr/files/digest-bzr-0.903
5 files changed, 138 insertions, 1 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index 26fd3c3e08b0..069e28066fe6 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-util/bzr
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.37 2007/07/10 23:25:54 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.38 2007/09/06 09:21:25 hawking Exp $
+
+*bzr-0.90 (06 Sep 2007)
+
+ 06 Sep 2007; Ali Polatel <hawking@gentoo.org>
+ +files/bzr-0.90-tests-fix_root.patch, +files/bzr-0.90-tests-sgid.patch,
+ +bzr-0.90.ebuild:
+ Version bump. Added a patch to fix tests when running w/o userpriv (bug
+ 173301) and another patch to fix permission tests when running beneath a
+ directory with the setgid bit set. Pass --install-data /usr/share option to
+ distutils_src_install instead of patching for man page location.
10 Jul 2007; Markus Ullmann <jokey@gentoo.org> bzr-0.17.ebuild:
Stable on x86
diff --git a/dev-util/bzr/bzr-0.90.ebuild b/dev-util/bzr/bzr-0.90.ebuild
new file mode 100644
index 000000000000..b0f88069303e
--- /dev/null
+++ b/dev-util/bzr/bzr-0.90.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.90.ebuild,v 1.1 2007/09/06 09:21:25 hawking Exp $
+
+inherit distutils bash-completion elisp-common eutils
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Bazaar is a next generation distributed version control system."
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="curl emacs test"
+
+python_rdep="dev-python/celementtree
+ >=dev-python/paramiko-1.5
+ curl? ( dev-python/pycurl )"
+DEPEND=">=dev-lang/python-2.4
+ emacs? ( virtual/emacs )
+ test? (
+ $python_rdep
+ dev-python/medusa
+ )"
+RDEPEND=">=dev-lang/python-2.4
+ $python_rdep"
+
+PYTHON_MODNAME="bzrlib"
+
+DOCS="doc/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't run lock permission tests when running as root
+ epatch "${FILESDIR}/${P}-tests-fix_root.patch"
+ # Fix permission errors when run under directories with setgid set.
+ epatch "${FILESDIR}/${P}-tests-sgid.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install --install-data /usr/share
+ docinto developers
+ dodoc doc/developers/*
+ docinto user-guide
+ dodoc doc/en/user-guide/*
+ if use emacs; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/bzr-mode.el*
+ elisp-site-file-install "${FILESDIR}/70bzr-gentoo.el"
+ fi
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}
+
+src_test() {
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+}
diff --git a/dev-util/bzr/files/bzr-0.90-tests-fix_root.patch b/dev-util/bzr/files/bzr-0.90-tests-fix_root.patch
new file mode 100644
index 000000000000..03f95b33da3e
--- /dev/null
+++ b/dev-util/bzr/files/bzr-0.90-tests-fix_root.patch
@@ -0,0 +1,30 @@
+--- bzrlib/tests/test_lockdir.py 2007-08-28 22:51:01.000000000 +0300
++++ bzrlib/tests/test_lockdir.py 2007-08-31 15:54:46.000000000 +0300
+@@ -594,6 +594,8 @@
+ def test_lock_permission(self):
+ if not osutils.supports_posix_readonly():
+ raise tests.TestSkipped('Cannot induce a permission failure')
++ if not os.getuid():
++ raise tests.TestSkipped('Running as root')
+ ld1 = self.get_lock()
+ lock_path = ld1.transport.local_abspath('test_lock')
+ os.mkdir(lock_path)
+--- bzrlib/tests/per_lock/test_lock.py 2007-08-28 22:51:00.000000000 +0300
++++ bzrlib/tests/per_lock/test_lock.py 2007-08-31 16:34:22.000000000 +0300
+@@ -22,6 +22,7 @@
+ )
+
+ from bzrlib.tests.per_lock import TestCaseWithLock
++from bzrlib.tests import TestSkipped
+
+
+ class TestLock(TestCaseWithLock):
+@@ -62,6 +63,8 @@
+
+ But we shouldn't be able to take a write lock.
+ """
++ if not osutils.os.getuid():
++ raise TestSkipped('Running as root')
+ osutils.make_readonly('a-file')
+ # Make sure the file is read-only (on all platforms)
+ self.assertRaises(IOError, open, 'a-file', 'rb+')
diff --git a/dev-util/bzr/files/bzr-0.90-tests-sgid.patch b/dev-util/bzr/files/bzr-0.90-tests-sgid.patch
new file mode 100644
index 000000000000..2a47db5bef73
--- /dev/null
+++ b/dev-util/bzr/files/bzr-0.90-tests-sgid.patch
@@ -0,0 +1,13 @@
+https://bugs.launchpad.net/bzr/+bug/109124
+--- bzrlib/tests/__init__.py 2007-08-28 22:50:57.000000000 +0300
++++ bzrlib/tests/__init__.py 2007-08-31 14:28:44.000000000 +0300
+@@ -933,6 +933,9 @@
+ return
+ path_stat = transport.stat(path)
+ actual_mode = stat.S_IMODE(path_stat.st_mode)
++ # test if running run beneath a directory with the setgid bit set.
++ if actual_mode & stat.S_ISGID and not mode & stat.S_ISGID:
++ mode |= stat.S_ISGID
+ self.assertEqual(mode, actual_mode,
+ 'mode of %r incorrect (%o != %o)' % (path, mode, actual_mode))
+
diff --git a/dev-util/bzr/files/digest-bzr-0.90 b/dev-util/bzr/files/digest-bzr-0.90
new file mode 100644
index 000000000000..6346a071cb09
--- /dev/null
+++ b/dev-util/bzr/files/digest-bzr-0.90
@@ -0,0 +1,3 @@
+MD5 596020e249604418e5ab8bde1d512472 bzr-0.90.tar.gz 1745848
+RMD160 b37b59ed666b03eaf2ffd12aea19c1c2a7fab9fb bzr-0.90.tar.gz 1745848
+SHA256 adf447e039fe8733e112a3de19712659aaca967a2ba626e44daba74bf1da1011 bzr-0.90.tar.gz 1745848