summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Hrušecký <miska@gentoo.org>2013-03-18 11:37:19 +0000
committerMichal Hrušecký <miska@gentoo.org>2013-03-18 11:37:19 +0000
commit5e10e6f369ab1c7460cdc77b83a51df30249cfd4 (patch)
treeccf4fc459a2da8aa100f24fa99036e42cc6cb2c3 /dev-util
parentVersion bump. (diff)
downloadgentoo-2-5e10e6f369ab1c7460cdc77b83a51df30249cfd4.tar.gz
gentoo-2-5e10e6f369ab1c7460cdc77b83a51df30249cfd4.tar.bz2
gentoo-2-5e10e6f369ab1c7460cdc77b83a51df30249cfd4.zip
Revision bump to force reinstall with new paths (bug#446074)
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key D39CB7C5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/obs-service-source_validator/ChangeLog10
-rw-r--r--dev-util/obs-service-source_validator/obs-service-source_validator-0.2-r2.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/obs-service-source_validator/ChangeLog b/dev-util/obs-service-source_validator/ChangeLog
index 0178f4d21a18..64b373b1097a 100644
--- a/dev-util/obs-service-source_validator/ChangeLog
+++ b/dev-util/obs-service-source_validator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/obs-service-source_validator
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/obs-service-source_validator/ChangeLog,v 1.5 2012/11/19 13:16:58 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/obs-service-source_validator/ChangeLog,v 1.6 2013/03/18 11:37:19 miska Exp $
+
+*obs-service-source_validator-0.2-r2 (18 Mar 2013)
+
+ 18 Mar 2013; Michal Hrusecky <miska@gentoo.org>
+ +obs-service-source_validator-0.2-r2.ebuild:
+ Revision bump to force reinstall with new paths (bug#446074)
*obs-service-source_validator-0.2-r1 (19 Nov 2012)
diff --git a/dev-util/obs-service-source_validator/obs-service-source_validator-0.2-r2.ebuild b/dev-util/obs-service-source_validator/obs-service-source_validator-0.2-r2.ebuild
new file mode 100644
index 000000000000..a2165f21ebb2
--- /dev/null
+++ b/dev-util/obs-service-source_validator/obs-service-source_validator-0.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/obs-service-source_validator/obs-service-source_validator-0.2-r2.ebuild,v 1.1 2013/03/18 11:37:19 miska Exp $
+
+EAPI=5
+
+inherit obs-service
+
+# only one sanely packed service
+SRC_URI="${OBS_URI}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-perl/TimeDate"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+}
+
+src_install() {
+ # different folder and files in this module
+ exeinto /usr/lib/obs/service
+ doexe ${OBS_SERVICE_NAME}
+
+ insinto /usr/lib/obs/service
+ doins ${OBS_SERVICE_NAME}.service
+
+ exeinto /usr/lib/obs/service/${OBS_SERVICE_NAME}s
+ doexe [0-9]*
+ exeinto /usr/lib/obs/service/${OBS_SERVICE_NAME}s/helpers/
+ doexe helpers/*
+}