summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-10 09:24:24 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-10 09:24:24 +0000
commit5d6bc6c88b1af2f866c65efcabfa112f1aaa3b6d (patch)
tree4d773741bae9a702ccf183e291670a43a6f1e3ad /dev-util
parentarm/s390/sh stable (diff)
downloadgentoo-2-5d6bc6c88b1af2f866c65efcabfa112f1aaa3b6d.tar.gz
gentoo-2-5d6bc6c88b1af2f866c65efcabfa112f1aaa3b6d.tar.bz2
gentoo-2-5d6bc6c88b1af2f866c65efcabfa112f1aaa3b6d.zip
Version bump.
(Portage version: 2.1.5_rc9)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bzr/ChangeLog7
-rw-r--r--dev-util/bzr/bzr-1.4.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index 8d873ba1aca5..ae275211760a 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bzr
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.52 2008/05/05 03:29:27 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.53 2008/05/10 09:24:24 hawking Exp $
+
+*bzr-1.4 (10 May 2008)
+
+ 10 May 2008; Ali Polatel <hawking@gentoo.org> +bzr-1.4.ebuild:
+ Version bump.
05 May 2008; Olivier Crête <tester@gentoo.org> bzr-1.3.ebuild:
amd64 Stable
diff --git a/dev-util/bzr/bzr-1.4.ebuild b/dev-util/bzr/bzr-1.4.ebuild
new file mode 100644
index 000000000000..59479ab32839
--- /dev/null
+++ b/dev-util/bzr/bzr-1.4.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-1.4.ebuild,v 1.1 2008/05/10 09:24:24 hawking Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils bash-completion elisp-common eutils
+
+MY_P=${P/_rc/rc}
+
+DESCRIPTION="Bazaar is a next generation distributed version control system."
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="curl emacs sftp test"
+
+RDEPEND="|| ( dev-python/celementtree >=dev-lang/python-2.5 )
+ curl? ( dev-python/pycurl )
+ sftp? ( dev-python/paramiko )"
+
+DEPEND="emacs? ( virtual/emacs )
+ test? (
+ $RDEPEND
+ dev-python/medusa
+ )"
+
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="bzrlib"
+SITEFILE=71bzr-gentoo.el
+DOCS="doc/*.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # Don't regenerate .c files from .pyx when pyrex is found.
+ epatch "${FILESDIR}/${PN}-0.92-no-pyrex.patch"
+ # Don't run lock permission tests when running as root
+ epatch "${FILESDIR}/${PN}-0.90-tests-fix_root.patch"
+ # Fix permission errors when run under directories with setgid set.
+ epatch "${FILESDIR}/${PN}-0.90-tests-sgid.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install --install-data /usr/share
+
+ docinto developers
+ dodoc doc/developers/*
+ for doc in mini-tutorial tutorials user-{guide,reference}; do
+ docinto $doc
+ dodoc doc/en/$doc/*
+ done
+
+ if use emacs; then
+ elisp-install ${PN} contrib/emacs/*.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
+
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}${SITELISP}/${PN}/.nosearch"
+ fi
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ bash-completion_pkg_postinst
+
+ if use emacs; then
+ elisp-site-regen
+ elog "If you are using a GNU Emacs version greater than 22.1, bzr support"
+ elog "is already included. This ebuild does not automatically activate bzr support"
+ elog "in versions below, but prepares it in a way you can load it from your ~/.emacs"
+ elog "file by adding"
+ elog " (load \"bzr-mode\")"
+ fi
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}
+
+src_test() {
+ # Some tests expect the usual pyc compiling behaviour.
+ unset PYTHON_DONTCOMPILE
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+ # Just to make sure we don't hit any errors on later stages.
+ export PYTHON_DONTCOMPILE=1
+}