summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-08 17:01:07 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-08 17:01:07 +0000
commit58d276725752cd4d5448b5216f2fd3fcb40d69af (patch)
treebb4305386861a5d5136f8e385693bbf77b41383c /dev-util
parentarm stable, bug #483892 (diff)
downloadgentoo-2-58d276725752cd4d5448b5216f2fd3fcb40d69af.tar.gz
gentoo-2-58d276725752cd4d5448b5216f2fd3fcb40d69af.tar.bz2
gentoo-2-58d276725752cd4d5448b5216f2fd3fcb40d69af.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/plan9port/ChangeLog8
-rw-r--r--dev-util/plan9port/plan9port-20130907.ebuild82
2 files changed, 89 insertions, 1 deletions
diff --git a/dev-util/plan9port/ChangeLog b/dev-util/plan9port/ChangeLog
index fbdbd6179f1e..44da19832277 100644
--- a/dev-util/plan9port/ChangeLog
+++ b/dev-util/plan9port/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/plan9port
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.23 2013/08/15 12:15:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.24 2013/09/08 17:01:07 blueness Exp $
+
+*plan9port-20130907 (08 Sep 2013)
+
+ 08 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
+ +plan9port-20130907.ebuild:
+ Version bump
*plan9port-20130814 (15 Aug 2013)
diff --git a/dev-util/plan9port/plan9port-20130907.ebuild b/dev-util/plan9port/plan9port-20130907.ebuild
new file mode 100644
index 000000000000..c0eb31a5c201
--- /dev/null
+++ b/dev-util/plan9port/plan9port-20130907.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20130907.ebuild,v 1.1 2013/09/08 17:01:07 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Port of many Plan 9 programs and libraries"
+HOMEPAGE="http://swtch.com/plan9port/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="9base BSD-4 MIT LGPL-2.1 BigelowHolmes"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-apps/xauth )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PLAN9=/usr/lib/plan9
+
+src_prepare()
+{
+ epatch "${FILESDIR}/${PN}-"{9660srv-errno,noexecstack,cflags,builderr}".patch"
+
+ # Fix paths, done in place of ./INSTALL -c
+ einfo "Fixing hard-coded /usr/local/plan9 paths"
+ grep --null -l -r '/usr/local/plan9' |
+ xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
+}
+
+src_configure() {
+ if ! use X; then
+ echo "WSYSTYPE=nowsys" >> LOCAL.config
+ fi
+}
+
+src_compile() {
+ # Convert -j5 to NPROC=5 for mk
+ export NPROC="$(echo "$MAKEOPTS" | sed -r -n 's/.*(^| )-j([0-9]*).*/\2/p')"
+
+ # The INSTALL script builds mk then [re]builds everything using that
+ einfo "Compiling Plan 9 from User Space can take a very long time"
+ einfo "depending on the speed of your computer. Please be patient!"
+ ./INSTALL -b
+}
+
+src_install() {
+ dodir "${PLAN9}"
+
+ # P9P's man does not handle compression
+ docompress -x $PLAN9/man
+
+ # do* plays with the executable bit, and we should not modify them
+ cp -a * "${D}/${PLAN9}"
+
+ # build the environment variables and install them in env.d
+ cat > "${T}/30plan9" <<-EOF
+ PLAN9="${PLAN9}"
+ PATH="${PLAN9}/bin"
+ ROOTPATH="${PLAN9}/bin"
+ MANPATH="${PLAN9}/man"
+ EOF
+ doenvd "${T}/30plan9"
+}
+
+pkg_postinst() {
+ elog "Plan 9 from User Space has been successfully installed into"
+ elog "${PLAN9}. Your PLAN9 and PATH environment variables have"
+ elog "also been appropriately set, please use env-update and"
+ elog "source /etc/profile to bring that into immediate effect."
+ elog
+ elog "Please note that ${PLAN9}/bin has been appended to the"
+ elog "*end* or your PATH to prevent conflicts. To use the Plan9"
+ elog "versions of common UNIX tools, use the absolute path:"
+ elog "${PLAN9}/bin or the 9 command (eg: 9 troff)"
+ elog
+ elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port."
+}