summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-02-21 14:52:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-02-21 14:52:57 +0000
commit56dee5355dab47b97d9e33bef90b92a980b0ab16 (patch)
tree6b7fabf22134e15608a67a133aa30c1707ab7518 /dev-util
parentInitial import (diff)
downloadgentoo-2-56dee5355dab47b97d9e33bef90b92a980b0ab16.tar.gz
gentoo-2-56dee5355dab47b97d9e33bef90b92a980b0ab16.tar.bz2
gentoo-2-56dee5355dab47b97d9e33bef90b92a980b0ab16.zip
Version bump to the latest (some tests still fail, to be fixed).
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/cmake-2.8.4.ebuild150
-rw-r--r--dev-util/cmake/files/cmake-2.8.4-FindBoost.patch13
-rw-r--r--dev-util/cmake/files/cmake-2.8.4-FindPythonInterp.patch11
-rw-r--r--dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch12
5 files changed, 195 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 1f146d6de650..bafd959e2655 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.151 2011/01/17 23:29:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.152 2011/02/21 14:52:57 scarabeus Exp $
+
+*cmake-2.8.4 (21 Feb 2011)
+
+ 21 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> +cmake-2.8.4.ebuild,
+ +files/cmake-2.8.4-FindBoost.patch,
+ +files/cmake-2.8.4-FindPythonInterp.patch,
+ +files/cmake-2.8.4-FindPythonLibs.patch:
+ Version bump to the latest (some tests still fail, to be fixed).
17 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> cmake-2.8.3-r1.ebuild:
Fix tests per bug #315223.
diff --git a/dev-util/cmake/cmake-2.8.4.ebuild b/dev-util/cmake/cmake-2.8.4.ebuild
new file mode 100644
index 000000000000..c516edf91eb4
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.4.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.4.ebuild,v 1.1 2011/02/21 14:52:57 scarabeus Exp $
+
+EAPI=4
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
+
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 vim-syntax"
+
+DEPEND="
+ >=app-arch/libarchive-2.8.0
+ >=net-misc/curl-7.20.0-r1[ssl]
+ >=dev-libs/expat-2.0.1
+ sys-libs/zlib
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4 )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+
+# portme:
+# darwin-no-qt
+# findboost
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindPythonInterp.patch
+ "${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
+ "${FILESDIR}"/${PN}-2.8.3-fix_assembler_test.patch
+ "${FILESDIR}"/${PN}-2.8.4-FindBoost.patch
+)
+_src_bootstrap() {
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # disable bootstrap cmake and make run, we use eclass for that
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ _src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ $(cmake-utils_use_build qt4 QtDialog)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use emacs && elisp-compile Docs/cmake-mode.el
+}
+
+src_test() {
+ # fix OutDir test
+ sed -i -e 's:#IGNORE ::g' "${S}"/Tests/OutDir/CMakeLists.txt || die
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+ "${CMAKE_BUILD_DIR}"/bin/ctest || die "Tests failed"
+ popd > /dev/null
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.4-FindBoost.patch b/dev-util/cmake/files/cmake-2.8.4-FindBoost.patch
new file mode 100644
index 000000000000..4a56d43a9e5c
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.4-FindBoost.patch
@@ -0,0 +1,13 @@
+diff -urN cmake-2.8.4.old//Modules/FindBoost.cmake cmake-2.8.4/Modules/FindBoost.cmake
+--- cmake-2.8.4.old//Modules/FindBoost.cmake 2011-02-20 19:32:16.528655001 +0100
++++ cmake-2.8.4/Modules/FindBoost.cmake 2011-02-20 20:28:41.572936744 +0100
+@@ -73,6 +73,9 @@
+ # binary Boost releases do so.
+ #
+ # set(Boost_ADDITIONAL_VERSIONS "1.78" "1.78.0" "1.79" "1.79.0")
++set(Boost_ADDITIONAL_VERSIONS "1.50.0" "1.50" "1.49.0" "1.49" "1.48.0" "1.48"
++ "1.47.0" "1.47" "1.46.0" "1.46" "1.45.0" "1.45" "1.44.0" "1.44" "1.43.0"
++ "1.43" "1.42.0" "1.42")
+ #
+ # ===================================== ============= ========================
+ #
diff --git a/dev-util/cmake/files/cmake-2.8.4-FindPythonInterp.patch b/dev-util/cmake/files/cmake-2.8.4-FindPythonInterp.patch
new file mode 100644
index 000000000000..90a34aad0e83
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.4-FindPythonInterp.patch
@@ -0,0 +1,11 @@
+diff -urN cmake-2.8.4.old/Modules/FindPythonInterp.cmake cmake-2.8.4/Modules/FindPythonInterp.cmake
+--- cmake-2.8.4.old/Modules/FindPythonInterp.cmake 2011-02-20 19:32:16.545655003 +0100
++++ cmake-2.8.4/Modules/FindPythonInterp.cmake 2011-02-20 20:22:37.597936743 +0100
+@@ -26,6 +26,7 @@
+ ${Python_ADDITIONAL_VERSIONS}
+ 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+
++set(_Python_VERSIONS "")
+ # Run first with the Python version in the executable
+ foreach(_CURRENT_VERSION ${_Python_VERSIONS})
+ set(_Python_NAMES python${_CURRENT_VERSION})
diff --git a/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch b/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch
new file mode 100644
index 000000000000..28d2e4f87906
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.4-FindPythonLibs.patch
@@ -0,0 +1,12 @@
+diff -urN cmake-2.8.4.old/Modules/FindPythonLibs.cmake cmake-2.8.4/Modules/FindPythonLibs.cmake
+--- cmake-2.8.4.old/Modules/FindPythonLibs.cmake 2011-02-20 19:32:16.363655002 +0100
++++ cmake-2.8.4/Modules/FindPythonLibs.cmake 2011-02-20 19:33:51.905655001 +0100
+@@ -33,6 +33,8 @@
+ ${Python_ADDITIONAL_VERSIONS}
+ 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+
++EXECUTE_PROCESS(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
++ OUTPUT_VARIABLE _Python_VERSIONS)
+ FOREACH(_CURRENT_VERSION ${_Python_VERSIONS})
+ STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
+ IF(WIN32)