summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-01-21 20:39:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-01-21 20:39:04 +0000
commit507dd84dd6ea9225d22db16337787b1152f263d9 (patch)
tree26720120955a8996f25836419948beca14f46b3a /dev-util
parentversion bump, bug #496138 (diff)
downloadgentoo-2-507dd84dd6ea9225d22db16337787b1152f263d9.tar.gz
gentoo-2-507dd84dd6ea9225d22db16337787b1152f263d9.tar.bz2
gentoo-2-507dd84dd6ea9225d22db16337787b1152f263d9.zip
Fix build for IUSE=doc and add missing sphinx dependency. Bug #498672
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog6
-rw-r--r--dev-util/buildbot/buildbot-0.8.8-r2.ebuild11
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild11
3 files changed, 17 insertions, 11 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index c13e397c553f..bc74fea80383 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.146 2014/01/21 19:56:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.147 2014/01/21 20:39:04 hwoarang Exp $
+
+ 21 Jan 2014; Markos Chandras <hwoarang@gentoo.org> buildbot-0.8.8-r2.ebuild,
+ buildbot-9999.ebuild:
+ Fix build for IUSE=doc and add missing sphinx dependency. Bug #498672
21 Jan 2014; Markus Meier <maekke@gentoo.org> buildbot-9999.ebuild:
add dev-python/python-dateutil test dependency to live ebuild too
diff --git a/dev-util/buildbot/buildbot-0.8.8-r2.ebuild b/dev-util/buildbot/buildbot-0.8.8-r2.ebuild
index 91dfb3a2d563..91400926ca8c 100644
--- a/dev-util/buildbot/buildbot-0.8.8-r2.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.8-r2.ebuild,v 1.4 2014/01/21 19:54:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.8-r2.ebuild,v 1.5 2014/01/21 20:39:04 hwoarang Exp $
EAPI="5"
PYTHON_DEPEND="2"
@@ -35,7 +35,7 @@ RDEPEND=">=dev-python/jinja-2.1
manhole? ( dev-python/twisted-conch )"
DEPEND="${DEPEND}
dev-python/setuptools
- doc? ( sys-apps/texinfo )
+ doc? ( dev-python/sphinx )
test? (
dev-python/python-dateutil
dev-python/mock
@@ -65,7 +65,8 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
pushd docs > /dev/null
- emake buildbot.html buildbot.info
+ #'man' target is currently broken
+ emake html
popd > /dev/null
fi
}
@@ -76,8 +77,8 @@ src_install() {
doman docs/buildbot.1
if use doc; then
- dohtml -r docs/buildbot.html docs/images
- doinfo docs/buildbot.info
+ dohtml -r docs/_build/html
+ # TODO: install man pages
fi
if use examples; then
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index 58b2dbc1e2ed..bb993dfb2ba1 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.4 2014/01/21 19:56:41 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-9999.ebuild,v 1.5 2014/01/21 20:39:04 hwoarang Exp $
EAPI="5"
PYTHON_DEPEND="2"
@@ -41,7 +41,7 @@ RDEPEND=">=dev-python/jinja-2.1
manhole? ( dev-python/twisted-conch )"
DEPEND="${DEPEND}
dev-python/setuptools
- doc? ( sys-apps/texinfo )
+ doc? ( dev-python/sphinx )
test? (
dev-python/python-dateutil
dev-python/mock
@@ -72,7 +72,8 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
pushd docs > /dev/null
- emake buildbot.html buildbot.info
+ #'man' target is currently broken
+ emake html
popd > /dev/null
fi
}
@@ -84,8 +85,8 @@ src_install() {
doman docs/buildbot.1
if use doc; then
- dohtml -r docs/buildbot.html docs/images
- doinfo docs/buildbot.info
+ dohtml -r docs/_build/html
+ # TODO: install man pages
fi
if use examples; then